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머 리 말 

위대한�령도자�김정일원수님께서는�다음과�같이�말씀하시였다.�

《현대과학기술의 기초는 콤퓨터입니다. 콤퓨터가 출현하고 그에 따라 정보기술이 발전

하면서 사람들이 환상적으로만 생각하던 문제들이 현실로 되고있으며 자연을 정복하고 세계

를 개조하는 인간의 창조적힘은 더욱더 위력한것으로 되고있습니다.》 

현시대는�정보산업의�시대,�콤퓨터시대이다.�

이제는�누구나�다�콤퓨터기술을�배워�콤퓨터를�능숙하게�다룰줄�알아야�한다.�

위대한�령도자�김정일원수님의�현명한�령도에�의하여�우리의�과학과�기술은�급속히�

발전하고있으며�인민경제�여러�부문에�콤퓨터기술이�널리�도입되여�커다란�성과가�이룩

되고있다.�

나라의�인재양성에�커다란�관심을�돌리고계시는�위대한�령도자�김정일원수님께

서는�우리�학생들이�배움의�나래를�활짝�펴고�사회주의강성대국의�밝은�앞날을�떠메고

나갈�유능한�과학기술인재로�자라날수�있도록�크나큰�사랑과�은정을�돌려주고계신다.�

위대한�령도자�김정일원수님께서�돌려주시는�뜨거운�사랑에�보답하기�위하여서는�

배우고�배우고�또�배워�자신을�나라의 과학과�기술을�떠메고나갈�훌륭한�역군으로�준비

하여야�한다.�

특히�현대과학기술의�정수로�되고있는�콤퓨터기술을�높은�수준에서�소유하기�위하�

여�적극�노력하여야�한다.�

2학년�《콤퓨터》에서는�콤퓨터에서의�사용환경설정과�표계산�및�표처리방법,�자

료기지처리방법을�배우며�또한�사진이나�그림과�같은�2차원화상처리에�관한�지식들

과�동화상창작방법에�대하여�배운다.��

먼저�《붉은별》조작체계에서�화면과�마우스,�소리의�사용환경설정과�새로운�응

용프로그람의�설치방법,�삭제방법�그리고�날자와�시간의�설정,�사용자�및�탁상면의�

관리와�같은�여러가지�사용환경설정방법에�대하여�배운다.��

다음으로�통합사무처리프로그람�《우리》의�표계산프로그람�《표》를�리용하여�학

생성적표와�같은�표자료의�입력방법과�그것을�리용한�자료처리의�초보에�대한�지식

을�배우며�또한�자료기지관리프로그람�《자료기지》를�리용하여�간단한�자료기지작성방

법을�배운다.�

그리고�화상처리프로그람�《환상》을�리용하여�화상편집의�기초,�선택방식�그리고�화

상의�변형과�색조절,�층과�통로조작,�려과방법�등�2차원화상처리방법에�대하여�배운다.�

또한�콤퓨터에서�동화상만들기에�대한�개념과�Flash�MX를�리용한�간단한�동화상

작성방법에�대하여�배운다.�

우리들은�콤퓨터에�대한�학습을�열심히�하여�정보산업시대의�능력있는�과학자,�기

술자들로�준비함으로써�위대한�령도자�김정일원수님의�크나큰�믿음과�기대에�높은�실력

으로�보답하여야�한다.�
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제1장. 《붉은별》의 사용환경설정 

제1절. 화면과 마우스, 소리의 사용환경설정 

�

콤퓨터로�작업하는�과정에는�사용자가�새로운�프로그람을�더�추가할수도�있고�《붉

은별》의�작업환경을�자기의�요구에�맞게�변경시킬수�있다.�

례를�들면�탁상면에�어떤�사진이나�그림이�나타나있게�하든지�마우스의�이동속도나�

두번찰칵속도를�조절한다든가�《붉은별》의�기동시�소리효과�등을�여러가지로�변경시키

거나�추가할수�있다.��

이와�같이�콤퓨터의�작업환경을�새롭게�변경시키거나�추가�또는�삭제하는것을�사용

환경설정이라고�한다.�

1. 영상표시장치의 설정 

1) 《조종판》의 열기 

《붉은별》체계에서는�여러가지�사용환경설정을�《조종판》창문에서�진행한다.�
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《조종판》창문은�《시작》차림표의�

《조종판》을�실행하여�펼칠수�있다.��

또는�Alt+F2건을�누르면�《지령실행》

대화칸이�펼쳐지는데�여기에�kcontrol지령

을�입력하고�《실행(R)》단추를�찰칵하면�

《조종판》창문이�펼쳐진다.�

�

《조종판》창문을�펼치려면�어떻

게�해야�하겠는가?�

생각하기 
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《조종판》창문의�왼쪽칸에는�《모양》,�《사용자관리》,�《성능과�정비》,�《접근

편의성》,�《주변장치》,�《지역》,�《탁상면관리》,�《프로그람�추가�및�삭제》,�《음

성과�음향장치》,�《인터네트와�망》과�같은�사용환경조종묶음이름들이�현시되며�오른

쪽칸에는�왼쪽칸에서�선택한�조종묶음에�속하는�조종프로그람그림기호들이�현시된다.��

사용자는�여기서�필요한�조종프로그람을�두번찰칵하는�방법으로�실행시키고�자기

에게�편리한�환경설정을�진행할수�있다.�



�

�

5

 
�

�

�

�

�

�

�

탁상면의�배경화면과�화면보호기,�화면의�해상도와�색수를�설정하는것들이�영상표

시장치의�설정에�속한다.��

2) 배경설정 

《조종판》창문에서�조종묶음�《모양》을�찰칵하면�오른쪽칸에�프로그람의�시동

형식을�설정하기�위한�조종프로그람인�《시동양상》,�창문의�모양을�설정하기�위한�

조종프로그람인�《창문장식》,�창문과�그�부분품들의�속성�및�배경화면과�화면보호

기,�화면의�해상도와�색수를�설정하기�위한�조종프로그람인�《영상표시장치》들이�

현시된다.�
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여기서�배경을�설정하기�위해�《영상표시장치》를�두번찰칵하면�《편성-영상표시장

치》창문이�펼쳐진다.�이�창문에서�《배경(B)》표쪽을�찰칵한다.�

�

영상표시장치의�설정은�무엇을�하는것인가?�

생각하기 



�

�

6�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

여기에는�《탁상면설정》,�《배경》,�《추가선택》설정부분이�있다.�

《탁상면설정》에서는�사용자전용으로�배정되는�탁상면을�선택하게�한다.�

임의의�탁상면을�개별적으로�선택하거나�모든�탁상면을�선택할수도�있다.�

�

�

�

�

�

《배경》에서는�《그림없음(N)》과�《그림(P)》,�《흐름식보기(S)》를�선택할

수�있다.�

-�그림없음(N):�배경화면을�조작체계에�기정으로�들어있는�색설정목록의�어느�한�항

목에�따라�표시한다.��

이때�《추가선택》부분의�《색(L)》에서�여러가지�색설정항목을�선택할수�있다.��

실례로�《색(L)》의� 단추를�찰칵하여�나타나는�색설정목록에서�《8방향계조

도》를�찰칵하고�《적용(A)》단추를�찰칵하면�탁상면의�배경이�《8방향계조도》로�바

뀐다.�
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-�그림(P):�배경그림을�설정한다.�

탁상면의�배경을�《백두산천지》그림으로�설정하기�위해서는�다음과�같이�한다.�

①�《그림(P)》를�선택한�다음�오른쪽의� 단추를�찰칵하여�나타나는�그림목록에서�

《백두산천지》를�선택한다.�

②�《적용(A)》단추를�찰칵한다.�

그러면�탁상면은�선택된�《백두산천지》화면으로�바뀐다.�
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이밖에�체계에�등록되여있지�않는�그림파일을�배경화면으로�설정하기�위해서

는�《그림(P)》를�선택한�다음�오른쪽에�있는�파일열기대화칸그림기호� 를�찰칵

한다.�

이때�나타나는�《배경파일선택》대화칸에서�《나의�등록부》�혹은�《보관매체》를�찰

칵하고�해당한�등록부를�찾아�필요한�그림파일을�선택한�다음�《확인(O)》단추를�찰칵

하면�된다.�
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-�흐름식보기(S):�배경그림의�자동흐름식보기를�제공한다.�
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이�항목을�선택하면�여러개의�배경그림들이�일정한�시간간격으로�즉�흐름식으로�바

뀌여�표시되게�설정할수�있다.�

《붉은별》조작체계가�가지고있는�그림파일들인�《더�높이�날아라》,�《민들레》,�《백

두산천지》,�《푸른�하늘》그림들이�자동흐름식으로�나타나게�해보자.�

《흐름식보기(S)》를�선택한�다음�그옆의�《설치(U)》단추를�찰칵하면�《걸그림보

이기설치》대화칸이�나타난다.��

여기서는�그림변화간격시간과�그림들을�설정한다.�이�대화칸에서�《추가(A)》단추

를�찰칵하면�《화상선택》대화칸이�나타난다.�

이�대화칸에서�《보관매체》를�찰칵하고�파일목록칸에서�/usr/share/wallpapers등록

부에�있는�그림파일들인�《더�높이�날아라》,�《민들레》,�《백두산천지》,�《푸른�하

늘》을�Ctrl건을�누른�상태에서�선택한�다음�《확인(O)》단추를�찰칵한다.�
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그러면�《걸그림보이기설치》대화칸의�《다음의�그림보기》목록칸에�선택한�그림파

일들이�나타난다.��
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《그림변화간격(P)》칸에�그림들이�나타나는�시간을�입력한다.�실례로�《1min》이라고�

입력한�다음�《확인(O)》단추를�찰칵하고�탁상면을�보면�선택된�그림들이�1분간격으로�

바뀌는것을�볼수�있다.�

다른�그림들을�더�추가하기�위해서는�《걸그림보이기설치》대화칸에서�《추가(A)》단추를�

찰칵하고�앞에서와�같이�그림들을�선택하면�된다.�
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추가된�그림들은�사용자의�요구에�맞게�나타나기순서를�바꿀수도�있고�그림을�삭

제할수도�있다.�

실례로�《백두산천지》그림이�제일�먼저�나타나게�하려면�《다음의�그림보기》목록

칸에서�/usr/share/wallpapers/백두산천지.jpg를�선택하고�《우로�올리기(U)》단추

를�두번찰칵한다.��

그러면�/usr/share/wallpapers/백두산천지.jpg가�제일�우에�놓이게�된다.�

다음�/usr/share/wallpapers/더�높이�날아라.jpg를�선택하고�《아래로�내리기

(D)》단추를�두번찰칵하면�이것이�제일�마지막에�놓인다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

이제�/usr/share/wallpapers/민들레.png를�선택하고�《삭제(R)》단추를�찰칵하

면�선택한�그림이�목록칸에서�없어진다.��

다음�《확인(O)》단추를�찰칵하면�탁상면에�1분간격으로�《백두산천지》,�《더�높

이�날아라》,�《푸른�하늘》순서로�그림들이�나타나는것을�볼수�있다.�

3) 화면보호기의 설정 

콤퓨터를�일정한�시간�리용하지�않을�때�화면에�나타나는�움직이는�그림이나�문양,�

문자렬을�설정하는것을�화면보호기설정이라고�한다.�

화면보호기를�설정하려면�《편성-영상표시장치》창문의�《화면보호기(S)》표쪽을�찰

칵한다.�
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�

�

�

화면보호기로�어떤�문자렬이�나

타나게�하는�《표제》화면보호프로그

람을�설정하는�방법을�보기로�하자.�

《화면보호기》부분에서� 단추

를� 찰칵하면� 화면보호프로그람목록

이�펼쳐지는데�여기서�《표제》를�선

택한다.�

《설정(S)》단추를�찰칵하여�펼쳐

지는�《설치-표제》대화칸에서�《표제》

화면보호프로그람에� 대한� 여러가지�

설정을�진행할수�있다.�

여기서�서체의�종류,�크기,�색,�흐름속도�등을�설정하며�통보문을�입력한다.�

실례로�서체종류는�붓글,�크기는�72,�색은�풀색,�흐름속도는�중간으로�설정하고�통

보문칸에는�《21세기는�정보산업의�시대이다.》라고�입력한�다음�《확인(O)》단추를�찰칵

한다.�



�

�

13

��

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

�

《편성-영상표시장치》창문에서�《자동적으로�시작(U)》을�선택하고�《대기시간》을�

《5min》으로�지정한다.�그러면�사용자가�5분동안�아무런�동작을�하지�않는�경우�《21세기

는�정보산업의�시대이다.》라는�화면보호프로그람이�자동적으로�실행된다.�

《활성상태로�넘어가기�위해�통과어�요구(R)》를�선택하면�화면보호기를�끝내고�작업상

태로�돌아가기�위해�마우스나�건반을�동작시키는�경우�암호를�요구하는데�이�암호는�체계에�

가입할�때�사용하는�암호를�입력해야�한다.�

�

�

�

�

�

�

�

�

4) 화면의 해상도와 색수의 설정  

《편성-영상표시장치》창문에서�《설정(E)》표쪽을�찰칵하면�다음과�같이�된다.��

�

《활성상태로�넘어가기�위해�통과어�요구(R)》옆에�있는�《대기시간》에�

값을�입력하면�어떤�현상이�일어나는가?�

생각하기 
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�

《재생률》은�영상표시장치의�동작주파수를�설정한다.�보통�60Hz로�고정된다.�

《화면크기》에서는�화면의�해상도를�설정한다.�미끄럼자의�눈금을�찰칵하면�해당한�

해상도가�표시된다.�

�

�

�

�

�

�

《색도》에서는�화면의�색도를�설정한다.��

여기에는� 《수천가지색》과� 《백만가지색》이� 있는데� 보통� 《백만가지색》으로�

설정한다.�

�

�

�

�

�

�

매�항목을�변경시킨�다음�《적용(A)》단추를�찰칵하면�변경확인대화칸이�나타나는

데�《편성접수(A)》단추를�찰칵하면�설정한대로�변경된다.�
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�

�

�

�

�

�

어떤�경우에는�콤퓨터를�재시동시킬것을�요구하는�대화칸이�나타나기도�하는데�이

때�《예(Y)》단추를�찰칵하면�콤퓨터가�재시동하면서�설정한대로�변경된다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

콤퓨터의�화면을�가로,�세로�잘라서�살창모양으로�가를수�있다.�례를�들어

가로�600줄,�세로�800줄로�가르면�그�화면은�600×800개의�쪼각들로�갈라진

다.�이렇게�갈라진�한쪼각을�화소라고�한다.�

화면의�해상도는�화면을�몇개의�화소로�만들었는가를�표시하는것이다.�이

것을�

480×640,��600×800,��768×1024,��768×1152,��…�

으로�표시한다.�

해상도가�클수록�화소의�크기는�작아지고�화면이�더�섬세해진다.�

화면의�색도는�화면의�색을�이루는�요소색이�몇가지인가를�표시한다.�

요소색이�많을수록�화면에�나타나는�영상이�자연색에�더�가까와진다.�

알아두기
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2. 마우스의 사용환경설정 

�

�

�

�

�

�

�

�

마우스의�단추사용의�바꾸기와�사용방식변경,�마우스지시자의�형태바꾸기�등과�같이�

마우스의�사용과�관련한�설정을�진행하는것이�마우스의�사용환경설정이다.�

《조종판》창문에서�조종묶음�《주변장치》를�선택한�다음�오른쪽칸에서�《마우스》를�

두번찰칵한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

그러면�《편성-마우스》창문이�펼쳐진다.��

이�창문에서�마우스의�동작에�관계되는�다양한�설정을�할수�있다.�

�

마우스의�사용환경설정은�무엇을�하는것인가?�

생각하기 
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이�창문에는�《일반설정(G)》,�《유표주제(T)》,�《고급한�특성(V)》,�《마우스항

행(P)》표쪽들이�있다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

1) 일반설정 

《일반설정(G)》표쪽에는�《단추사용형태》와�《그림기호》부분�그리고�《굴리개방

향�바꾸기(L)》선택칸이�있는데�이것들을�리용하여�오른손이나�왼손으로�마우스를�리용

하기�위한�단추사용형태와�굴리개방향바꾸기,�마우스의�찰칵�혹은�두번찰칵으로�파일이

나�등록부열기�등을�설정할수�있다.��

단추사용형태 

단추사용은�표준적으로�《오른손�사용(R)》으로�설정되여있다.�

사용자가�왼손잡이인�경우�마우스의�왼쪽단추와�오른쪽단추사용을�바꾸려면�《왼손�

사용(F)》을�선택하고�《적용(A)》단추를�찰칵한다.��

그러면�왼쪽단추와�오른쪽단추의�기능이�바뀌여진다.�
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그림기호 

파일과�등록부의�열기를�마우스의�몇번�찰칵으로�하겠는가를�설정한다.�

실례로�찰칵으로�파일�혹은�등록부를�열기�위해서는�《마우스를�한번�찰칵하여�파일

과�등록부�열기(S)》를�선택한다.�

그리고�그림기호우에�마우스지시자가�놓일�때�지시자의�모양을�변경하기�위해서는�

《그림기호우에서�지시자형태�변경하기(N)》를�선택한다.�

다음�《적용(A)》단추를�찰칵한다.�

2) 유표주제 

《유표주제(T)》표쪽에서는�사용하려는�마우스지시자의�형태를�선택한다.��

목록칸에는�《《붉은별》마우스유표》,�《체계기정》,�《WindowsXP마우스유표》라

는�마우스지시자형태이름들이�있다.�

여기서�《《붉은별》마우스유표》를�선택한�다음�목록칸우에�표시되는�지시자형태들

가운데서�필요한�그림기호를�선택한다.��

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

다음�《적용(A)》단추를�찰칵하면�변경을�진행하겠는가를�묻는�대화칸이�나타

난다.�
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�

�

�

�

�

�

�

�

�

유효로�하려면�《대화접속탈퇴(L)》단추를�찰칵하여�체계를�재기동한다.��

그러면�재기동후�마우스지시자의�모양이�바뀐것을�확인할수�있다.�

하드디스크에�파일로�보관된�지시자파일을�리용하여�마우스지시자형태를�변경하기�

위하여서는�《편성-마우스》창문에서�《새�주제를�설치》단추를�찰칵한다.�그러면�다음

의�대화칸이�나타난다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

이�창문에서�《보관매체》를�선택한�다음�해당�지시자파일이�들어있는�등록부에서�그

림파일을�선택하고�《확인(O)》단추를�찰칵한다.�

3) 고급한 특성 

《고급한�특성(V)》표쪽에서는�《지시자�가속》에서�마우스지시자의�움직임속도,�《지

시자의�최소이동길이》에서�마우스지시자를�이동시킬�때의�최소이동길이,�《마우

스굴리개에�의한�흐름행수》에서는�굴리개를�굴릴�때�본문의�흘림행수를�설정할수�

있다.�
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4) 마우스항행 

《마우스항행(P)》에서는�수자건반으로�마우스지시자를�조종하기�위한�설정을�할수�

있다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

《건반으로�지시자이동(수자건반의�방향건사용)(M)》을�선택하면�사용자는�건반의�

오른쪽에�있는�수자건반을�리용하여�마우스의�동작을�모의할수�있다.��

이때�수자건반의�4,�6,�2,�8건은�마우스지시자를�각각�왼쪽,�오른쪽,�아래,�우로�이

동시키며�1,�3,�9,�7건은�대각선방향으로�마우스지시자를�이동시킨다.�그리고�5건은�마

우스단추를�누르는것과�같은�결과를�모의한다.�
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3. 소리의 환경설정 

�

�

�

�

�

�

《붉은별》조작체계가�기동될�때�또는�어떤�통보문이�표시될�때�등�《붉은별》조작

체계를�조작하는�과정에�울려나오는�소리를�사용자의�취미에�맞게�여러가지로�바꾸어주

는것을�소리의 환경설정이라고�한다.�

소리의�환경설정은�《조종판》창문에서�조종묶음�《음성과�음향장치》를�선택하여�진

행할수�있다.�

《음성과�음향장치》를�선택하면�오른쪽칸에는�《체계종소리》,�《체계통지》,�《음

성체계》가�나타난다.�

1) 체계종소리 

체계경고통보문대신에�체계종을�사용하도록�한다.�

《체계종소리》를�두번찰칵하면�《편성-체계종소리》창문이�펼쳐진다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

이�창문에서�《체계경고통보문대신�체계종을�사용(U)》을�선택한다.�

《음량(V)》,�《주파수(P)》,�《지속시간(B)》을�설정한다.�《시험(T)》단추를�찰

칵하여�소리를�들어본다.�

�

소리의�환경설정은�무엇을�하는것인가?�

생각하기 
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《적용(A)》단추를�찰칵하면�콤퓨터를�사용하면서�체계가�어떤�경고통보문을�통보

해야�할�경우에�통보문대신�체계종소리를�내보내게�된다.�

2) 체계통지 

체계통보가�표시될�때,�탁상환경이�변할�때�등�체계와�관련한�어떤�사건이�발생할�

때의�소리를�설정할수�있다.��

《조종판》창문에서 《체계통지》를�두번찰칵하면�《편성-체계통지》창문이�나타난다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

이�창문의�《사건원천》칸의�오른쪽에�있는� 단추를�찰칵하여�나타나는�목록에서�

《체계통지》를�선택한다.�

�

�

�

�

�

�

�

�

�

�

그러면�사건목록칸에는�《경고통보문이�표시되고있습니다.》,�《선택된�파일을�읽거나�쓰

기�위해�열수�없습니다.》�등�체계통보와�관련한�구체적인�사건목록들이�현시된다.�
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목록들가운데서�해당한�목록�실례로�《질문이�제시되고있습니다.》를�선택한다.�

《동작》부분에서�《음성연주(W)》를�선택하고�그옆의�입력칸의�오른쪽에�있는�

단추를�찰칵한다.�그러면�음성파일선택대화칸이�펼쳐진다.�

�

�

�

�

�

�

�

�

�

�

�

�

이�대화칸에서�필요한�음성파일을�선택한�다음�《확인(O)》단추를�찰칵한다.�

《적용(A)》단추를�찰칵하여�《편성-체계통지》창문을�닫는다.�그러면�질문이�제시

될�때마다�선택된�음성이�울린다.�

《편성-체계통지》창문의�오른쪽아래에�있는�《연주기설정(G)》단추를�찰칵하여�나

타나는�《연주기설정-체계통지》대화칸에서�음성연주방식을�변경할수�있다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

《음성체계를�리용(K)》을�선택하면�음성체계에�의한�통보음을�내보내며�《음량

(V)》의�밀기자를�끌기하여�음량의�크기를�조절할수�있다.�
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《다른�연주기사용(U)》을�선택하고�《연주기》입력칸에�음성체계에�의한�통보음이�

아닌�다른�음성파일이름을�직접�입력하여�리용할수�있다.�

음성파일은�오른쪽에�있는� 단추를�찰칵하여�나타나는�대화칸에서�해당�등록부를�

찾아�음성파일을�선택하여�리용할수도�있다.�

《음성출력이�없음(N)》을�선택하면�모든�음성통보를�사용하지�않는다.�

3) 음성체계 

탁상환경의�음성체계를�조종하기�위하여�《음성체계》를�두번찰칵하면�다음과�같은�

창문이�나타난다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

《음성체계허가(Y)》를�선택하여�음성체계를�리용한다.�

음성의�입력과�출력에�대해�어느�음성체계를�사용하겠는가를�결정하기�위해서는�

《음성장치의�선택�및�편성》부분에서�《음성장치선택(T)》의�오른쪽에�있는� 단추를�찰

칵하여�나타나는�목록에서�해당한�음성체계를�선택하면�된다.�

�

�

�

�

�

�

표준으로는�《자동검출》이�선택된다.�
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음성봉사기가�동시에�록음과�연주를�다�진행하도록�하기�위해서는�《전2중화(P)》를�

선택한다.�

연주될�음성들의�질을�설정하기�위해서는�《품질(Q)》

의�오른쪽옆에�있는� 단추를�찰칵하여�선택한다.��

련습문제 

1.�탁상면의�배경그림을�《백두산천지》로�설정하여라.�

2.�탁상면의�배경을�디스크에�보관된�그림파일로�바꾸는�방법을�설명하여라.�

3.�마우스의�동작을�수자건반으로�동작하게�설정하여라.�

4.�두번찰칵간격시간을�조절하는�방법을�설명하여라.�

5.�화면보호기에서�통보문을�《강성부흥아리랑》으로,�대기시간을�1분으로�설정하여라.�

6.�배경그림설정을�《흐름식보기》로�하고�디스크에�보관된�그림파일들로�이것을�실현하

는�방법을�설명하여라.�

7.�화면보호기의�통과암호설정방법을�설명하여라.�

�

제2절. 새로운 프로그람 및 장치의 설치 

이�절에서는�《붉은별》조작체계에서�가장�많이�리용하는�대표적인�응용프로그람들

과�인쇄장치의�설치방법들에�대하여�보여준다.�

1. 새로운 응용프로그람의 설치  

1) 통합사무처리프로그람 《우리》의 설치  

-�설치방법�

《붉은별》조작체계에서�여러가지�사무처리�즉�우리�글�편집,�표계산,�자료기지관리�및�

선전물제작�등을�진행하려면�통합사무처리프로그람�《우리》를�설치하여야�한다.�

통합사무처리프로그람�《우리》의�설치방법에는�《조종판》을�리용하여�설치하는�방

법과�《파일열람기》창문에서�설치하는�방법이�있다.�

먼저�《조종판》창문에서�《응용프로그람묶음집》CD를�리용하여�《우리》를�설치하

는�방법을�보기로�하자.�

①�CD구동기에�《응용프로그람묶음집》CD를�넣는다.�

②�《조종판》창문에서�조종묶음�《프로그람�추가�및�삭제》를�선택하고�오른쪽칸에

서�《프로그람�추가�및�삭제》를�두번찰칵하면�《프로그람�추가�및�삭제》대화칸이�펼쳐

진다.�
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�

③�대화칸의�왼쪽칸에�있는�《새로�설치》를�선택한�다음�오른쪽칸에서�《국부저장

고설치》를�두번찰칵한다.�

④�이때�나타나는�《열기-프로그람�추가�및�삭제》대화칸에서�《보관매체》를�선택하

고�AppSet_2.0을�실행한다.�

�
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⑤�02_UriOffice3.0→product�Uri→UriOffice.repo를�실행한다.�그러면�통합사

무처리프로그람�《우리》�3.0설치대화칸이�나타난다.��

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

⑥�《다음(N)>》단추를�찰칵한다.�

⑦�다음은�쏘프트웨어선택단계로서�《통합사무처리프로그람�《우리》�3.0》을�선택

하고�《다음(N)>》단추를�찰칵한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

그러면�잠간�기다리라는�다음과�같은�통보가�나타난다.�
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�

⑧� 다음은�부속프로그람들의�설치�및� 삭제를�확인하기�위한�단계인데�여기서는�

설치를�시작하기�위해�《다음(N)>》단추를�찰칵한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

그러면�설치과정이�시작된다.�설치과정이�100%에�달하면�《우리》�3.0이�성과적으

로�설치되였다고�통보한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�
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⑨�《완료(F)》단추를�찰칵한다.�

다음은�《파일열람기》창문에서�설치하는�방법을�보기로�하자.�

①�CD구동기에�《응용프로그람묶음집》CD를�넣는다.�

②�《파일열람기》창문에서�AppSet_2.0→02_UriOffice3.0→product�Uri→Uri�

Office.repo를�실행한다.��

�

�

�

�

�

�

�

�

�

�

�
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�

�

�

�

그러면�통합사무처리프로그람�《우리》�3.0대화칸이�나타난다.��

③�우의�《조종판》창문에서의�설치과정�⑥부터�⑨과정을�반복한다.��

�

-�삭제방법�

모든�응용프로그람들의�삭제는�《조종판》창문의�《프로그람�추가�및�삭제》를�리용

하여�진행한다.�

통합사무처리프로그람�《우리》�3.0의�삭제도�《조종판》창문을�리용하여�진행한다.�

①�《조종판》창문의�조종묶음에서�《프로그람�추가�및�삭제》를�선택하고�오른쪽에

나타나는�《프로그람�추가�및�삭제》를�두번찰칵한다.�

②�《프로그람�추가�및�삭제》대화칸에서�《변경/삭제》를�선택한다.�

③�오른쪽부분에�있는�현재�추가된�프로그람목록들중에서�삭제하려는�《통합사무처

리프로그람�《우리》�3.0》을�선택한다.�
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④�《삭제》를�찰칵한다.�

그러면�통합사무처리�《우리》�3.0 삭제대화칸이�나타난다.�
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⑤�《다음(N)>》단추를�찰칵한다.�

⑥�삭제를�확인하는�단계에서는�삭제를�확인한�다음�《다음(N)>》단추를�찰칵한다.�

�

������� �
�

⑦�그러면�삭제를�진행하는�대화칸이�펼쳐지며�100%에�이르면�삭제를�성과적으로

진행하였다는�대화칸이�펼쳐진다.��

����
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⑧�《완료(F)》단추를�찰칵한다.�

그러면�《프로그람�추가�및�삭제》대화칸에서�《통합사무처리프로그람�《우리》�

3.0》이�삭제된것을�볼수�있다.�

�

�
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�

�

�

�

�

2) Windows환경지원프로그람 《만능》 2.0의 설치  

Windows체계에서�동작하는�프로그람들을�《붉은별》체계에서�그대로�설치하여�리

용하려면�Windows환경지원프로그람�《만능》�2.0이�설치되여야�한다.�

Windows환경지원프로그람�《만능》�2.0의�설치는�통합사무처리프로그람�《우리》�

3.0설치와�마찬가지방법으로�진행한다.�

이때�AppSet_2.0→04_CrossWin2.0→Product�crosswin→crosswin.repo를�실

행한다.�

그러면�Windows환경지원프로그람�《만능》�2.0설치를�환영하는�대화칸이�나타

난다.�

《다음(N)>》단추를�찰칵하면�쏘프트웨어를�선택하기�위한�다음의�대화칸이�펼

쳐진다.�
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�

�

《Windows환경지원프로그람�《만능》�2.0》을�선택하고�《다음(N)>》단추를�찰칵

하면�다음의�통보가�나타난다.�

�

이때�나타나는�대화칸에서�부속프로그람들의�설치�및�삭제를�확인하고�《다음(N)>》

단추를�찰칵한다.�

설치과정이�100%에�달하면�성과적설치를�보여주는�창문이�나타나는데�이�창문의�

《완료(F)》단추를�찰칵한다.�

3) 화상처리프로그람 《환상》의 설치 

화상을�수정하고�합성하여�화상을�창조하는것과�같은�여러가지�화상처리들을�진행

하려면�화상처리프로그람�《환상》이�설치되여야�한다.�

화상처리프로그람�《환상》을�설치하려면�AppSet_2.0→05_Image�Processer�1.1

→Product�img→Hwansang.repo를�실행한다.�

《환상》설치를�환영하는�대화칸에서�《다음(N)>》단추를�찰칵한다.�

다음�《환상》1.1을�선택하고�《다음(N)>》단추를�찰칵한다.�
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그러면�다음과�같은�통보가�나타난다.�

�

�

�

�

�

설치를�시작하기�위해�《다음(N)>》단추를�찰칵한다.�

�
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마지막으로�《완료(F)》단추를�찰칵한다.�

�

4) 전자문서편집기 Acrobat 의 설치 

전자문서편집기�Acrobat를�설치하는�방법을�보기로�하자.�

Acrobat는� Windows환경에서� 동작하는� 응용프로그람이므로� Windows환경지원�

프로그람�《만능》�2.0을�실행시키고�설치를�진행한다.�

①�《시작》→《응용프로그람》→《Windows환경지원프로그람》→《설치》를�실행한다.�

�

�

�

�

�

�

�

�

�

�

�

�
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�

�
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그러면�다음의�화면이�나타난다.�

�

②�다음의�대화칸에서�《프로그람설치》→《Adobe�Acrobat�Reader》를�선택하고�

《설치(I)》단추를�찰칵한다.�

�

③�《설치대화창》에서�설치방법을�선택한�다음�《설치(S)》단추를�찰칵한다.�

�

�

�

④�프로그람의�설치를�확인하는�다음의�대화칸에서�《예》단추를�찰칵한다.�

Adobe�Acrobat�Reader�6.0��
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�

�

그러면�잠간�기다리라는�다음의�통보가�나타난다.�

�

③�Acrobat�5.0설치대화칸에서�Next단추를�찰칵한다.��

�

④�언어를�선택하기�위한�단계에서는�해당�언어를�선택하고�Next단추를�찰칵

한다.�
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�

�

⑤�Acrobat설치를�동의하는가를�묻는�단계에서는�Acrobat설치를�위해�Accept단

추를�찰칵한다.�

�

�
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⑥�설치형태선택단계에서는�설치형태를�선택한�다음�Next단추를�찰칵한다.�

�

�
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�

�

�

�

�

⑦�이름,�작업조,�계렬번호를�입력하고�Next단추를�찰칵한다.�

�
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⑧�정보가�정확히�등록되였는가를�묻는�대화칸에서�Yes단추를�찰칵하면�설치등록

부를�보여주는�단계로�넘어간다.��

�

�
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�

�

�

�

⑨�Next단추를�찰칵하면�다음과�같이�설치과정이�나타난다.�

�

�
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⑩�다음의�대화칸에서�OK단추를�찰칵하면�설치완료를�나타내는�대화칸이�나

타난다.�

�

�

�

�

�

�

⑪�《완료(X)》단추를�찰칵한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

2. 새로운 장치의 설치  

새로운�장치의�설치�실례로�인쇄기설치방법에�대하여�보기로�하자.�

①�《조종판》창문의�왼쪽칸에서�《주변장치》를�선택한�다음�오른쪽칸에서�《인쇄

기》를�두번찰칵한다.�그러면�《편성-인쇄기》대화칸이�나타난다.�����



�

�

42�

②�《편성-인쇄기》대화칸에서�도구띠의�왼쪽에�있는� 를�찰칵하고�《인쇄기추가

(P)》를�선택한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

③�《인쇄기추가》대화칸에서�《다음(N)>》단추를�찰칵한다.�
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④�이�단계는�새로�설치할�인쇄기의�종류를�선택하기�위한�단계인데�여기서는�《국

부인쇄기(병렬,�직렬,�USB)(L)》을�선택하고�《다음(N)>》단추를�찰칵한다.��

�

⑤� 국부포구선택단계에서는� 포구선택을� 어떻게� 하겠는가를� 선택한� 다음� 《 다음

(N)>》단추를�찰칵한다.�

�
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만일�인쇄기가�없는�상태에서�인쇄기를�추가하려고�할�때는�USB포구를�리용한다.�

⑥�새로�가입하는�경우�구동프로그람자료기지를�자동적으로�구축하며�다음�나타나

는�인쇄기견본선택단계에서�인쇄기의�제작자이름과�모형이름을�선택하고�《다음(N)>》

단추를�찰칵한다.�

�

�

�

�

�

�

�
�

⑦�인쇄기검사단계에서는�《설정(S)》단추를�찰칵하여�인쇄용지의�크기,�색방식,�

해상도�등을�설정할수�있다.�
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⑧�일반정보입력단계에서는�인쇄기의�이름을�입력한�다음�《다음(N)>》단추를�찰칵

한다.�이때�이름에는�영문과�수자,�밑선만이�입력될수�있다.��

���������
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�

⑨�확인단계에서는�현재까지�설정한�설정정보들을�보여준다.�여기에서�《완료(F)》

단추를�찰칵하면�인쇄기추가가�완성된다.�
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련습문제 

1.�《조종판》을�리용하여�화상처리프로그람�《환상》을�설치해보아라.�

2.�《응용프로그람묶음집》CD에서�《문서처리체계�《서광》》을�설치해보아라.�

3.�현재�콤퓨터에�설치되여있는�Adobe�Acrobat�5.0을�삭제하려면�어떻게�해야�하는가

를�설명하여라.�

4.�비루스왁찐프로그람�《클락새》2.0을�설치해보아라.�

�

제3절. 여러가지 환경설정 

1. 날자와 시간의 변경 

콤퓨터에�표시되는�날자와�시간을�변경시킬수�있다.�

①�《조종판》창문에서�《지역》을�선택한�다음�오른쪽칸에서�《날자와�시간》을�두

번찰칵한다.�그러면�《편성-날자와�시간》창문이�펼쳐진다.�
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②�《날자와�시간(E)》표쪽을�찰칵한다.�그러면�현재�콤퓨터에�설정되여있는�날자와�

시간이�표시된다.�

③�시간을�변경하기�위해서는�시계가�있는�왼쪽칸에서�시,�분,�초�

표시칸� 에�해당�수값을�직접�입력하거나�

단추를�리용하여�수값을�변경한다.�

④� 년도를� 변경하기� 위해서는� 오른쪽칸의� 웃쪽에� 있는� 년부분

을�선택하여�이때�나타나는�입력칸

에�년도를�입력한다.�

⑤�달을�변경하기�위해서�달부분을 선택하여�나타나는�목록에서�해

당�달을�선택한다.��

⑥�날자는�달력에서�선택하는�방법으로�변경한다.�

⑦�《적용(A)》단추를�찰칵한다.�

그러면�탁상면의�오른쪽아래에�있는�날자와�시간이�변경된것을�볼수�

있다.�

�

�

2. 사용자관리의 설정 

《사용자관리》대화칸을�리용하여�한대의�콤퓨터를�여러명의�사용자가�각기�자기의�

독특한�환경에서�사용할수�있도록�할수�있다.�

Mycom이라는�사용자를�추가하기�위해서는�다음과�같이�한다.�

①�《조종판》창문에서�조종묶음�《사용자관리》를�선택한�다음�오른쪽칸에서�《사

용자관리》를�두번찰칵한다.�그러면�《사용자관리》창문이�나타난다.(여기에서는�사용자

를�새로�추가하고�삭제할수�있으며�사용자속성정보(전체�이름,�통과어)를�변경할수�있

다.�또한�매�사용자에�대한�그림기호를�설정하고�변경시킬수�있으며�묶음을�설정할수�

있다.)�

②�《사용자관리》창문에서�《추가(A)》단추를�찰칵한다.�

12� 0512�

탐 구 
�

《편성-날자와�시간》창문에서�《시간대역(T)》표쪽을�찰칵하고�여기서는�무

엇을�설정할수�있는가를�알아보아라.�
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③�《사용자추가》대화칸의�《사용자이름》칸에�Mycom이라고�입력하고�《전체이름》

칸에�《일반사용자》라고�입력한�다음�《다음(N)>》단추를�찰칵한다.�
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④�다음은�통과어입력단계인데�만일�통과어를�주려면�《통과어》칸에�해당�문자렬을�

입력한�다음�《통과어》칸에�입력한�문자렬을�《통과어확인》칸에�다시�입력한다.�이때�입

력한�문자는�점으로�나타난다.�《다음(N)>》단추를�찰칵한다.�

�

�

�

⑤�사용자가�속하게�될�그룹(단체)을�추가하기�위한�다음의�단계에서는�해당�그룹을�

추가한�다음�《다음(N)>》단추를�찰칵한다.(만일�주그룹을�추가하지�않으면�사용자이름

과�꼭같은�주그룹이�창조된다.)�

�

�

�

⑥�사용자추가의�완료를�나타내는�단계에서는�《완료(F)》단추를�찰칵한다.�
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그러면�《사용자관리》대화칸에�Mycom이라는�새로운�사용자가�추가된다.�
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추가된�사용자들가운데서�불필요한�사용자들을�삭제할수도�있다.��

우에서�추가한�Mycom이라는�사용자를�삭제하기�위해서는�다음과�같이�한다.�

①�《사용자관리》대화칸에서�Mycom사용자이름을�선택하고�《삭제(D)》단추를�찰

칵한다.�

②�《사용자삭제》대화칸에서�《확인(O)》단추를�찰칵한다.�

�
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�

그러면�그림과�같이�추가한�Mycom사용자가�삭제된다.�
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사용자속성변경에서는�사용자의�전체이름과�통과암호를�변경시킬수�있다.�

Mycom사용자의�속성을�변경하기�위해서는�다음과�같이�한다.�

①�《사용자관리》대화칸에서�Mycom사용자를�선택한�다음�《변경(E)》단추를�찰

칵한다.�

②�이때�나타나는�《사용자속성변경》대화칸에서�필요한�속성을�설정한다.�

�

�
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�

통과어를�변경하기�위해서는�《새�통과어》입력칸과�《새�통과어확인》입력칸에�해

당한�통과어를�입력한다.(새로운�통과암호를�설정할�때�이전의�통과암호를�모르면�새�

통과암호를�설정할수�없다.)��

③�대화칸의�《확인(O)》단추를�찰칵한다.�

사용자그림기호도�사용자가�요구하는대로�변경시킬수�있다.�

Mycom사용자의�《학》그림기호를�《사과》그림기호로�변경하기�위해서는�다음과�같

이�한다.�

①�《사용자관리》대화칸에서�Mycom사용자를�선택한�다음�《학》그림기호를�찰칵

한다.�

②�《변경(E)》단추를�찰칵한다.�

③�이때�나타나는�《그림기호선택》대화칸에서�사과그림파일인�Apple.png파일을�선

택하고�《열기(O)》단추를�찰칵한다.�
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그러면�Mycom사용자의�그림기호가�《학》으로부터�《사과》로�변경된것을�볼수�

있다.�
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3. 탁상면관리 

사용자의�취미와�요구에�맞게�탁상면의�형식과�작업방식을�설정할수�있다.��

《조종판》창문에서�조종묶음�《탁상면관리》를�선택하면�오른쪽칸에는�《조작판》,�

《지름건》,�《창문행동》,�《탁상면행동》,�《파일련관》그림기호들이�나타난다.�

1) 조작판 

조작판은�탁상면의�아래에�띠처럼�놓인것이다.�

《조작판》창문에서는�조작판의�배치,�숨기기,�차림표,�외관,�과제띠,�다중탁상면의�

설정�등을�진행할수�있다.�

-�배치:�조작판의�크기와�위치,�길이를�조절할수�있다.�

�

�
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-�숨기기:�조작판의�숨김방식과�숨김단추들을�설정하며�또한�조작판숨기기�동화를�

설정한다.�

�

�

�

-�차림표:�조작판차림표를�편성할수�있다.�즉�어느�특정한�프로그람을�시작차림표

우에�나타나게�하거나�가장�최근에�혹은�자주�사용하는�프로그람들을�표시하도록�설정

할수�있다.�
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-�외관:�조작판표시와�관련된�정보를�설정한다.�즉�조작판에서�매개�항목들에�마우

스지시자를�가져갈�때�그에�대한�해설문이�표시되거나�《시작》단추와�《탁상면접근》단

추의�배경색과�그의�형태설정,�조작판배경색�설정�등을�진행한다.�

�

�

�
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-�과제띠:�응용프로그람들사이의�절환조작을�설정한다.�

�

-�다중탁상면:�탁상면의�이름과�개수를�설정한다.�

《탁상면번호(U)》의�오른쪽에�있는�입력칸에�개수를�입력하고�탁상면이름입력칸에�

탁상면의�이름을�써넣어�탁상면의�이름을�변경할수�있다.�
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2) 지름건 

《지름건》은�여러가지�지름건들을�설정,�삭제하기�위한�프로그람이다.�

-� 지름건방식:� 지름건방식으로는� 탁상환경기정방식,� Windows방식,� Unix방식,�

Mac방식을�제공하며�매�방식들에서�지름건들을�임의로�변경할수�있다.��

지름건은�Shift,�Ctrl,�Alt중�어느�하나를�누른�상태에서�임의의�한개�건을�선택하

여�설정한다.���

�

-�지령지름건:�마우스로�임의의�지령항목을�선택하면�선택된�지령에�대한�지름건을�

설정할수�있게�《없음(N)》,�《전용(U)》항목들이�활성화된다.�

�

�

�
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이때�《전용(U)》항목을�선택하면�《지름건편성-지름건》대화칸이�표시되며�여기서

해당�지름건을�설정하면�된다.�

�

�

�

�

�

�

�

�

3) 창문행동 

《창문행동》은�응용프로그람창문들의�행동방식을�설정한다.�

-�초점(F):�창문에�마우스지시자를�가져갔을�때의�창문들의�행동방식을�설정한다.�

�

《지름건편성-지름건》대화칸에서�《고급<<》단추를�찰칵하면�어떻게�되는가?�

생각하기 



�

�

61

-�제목띠(T):�제목띠에서�찰칵할�때의�행동을�설정한다.�
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�

-�창문(N):�창문내부에서의�마우스단추의�행동을�설정한다.�

�
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-�이동(M):�창문의�이동과�관련한�정보를�설정한다.�

�

-�고급(V):�창문의�행동과�관련한�고급한�설정�즉�접어올리기,�초점얻기방식�등을�

진행한다.�
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4) 탁상면행동 

《탁상면행동》에서는�탁상면에�그림기호표시를�설정하거나�마우스단추동작�등을�설

정한다.��
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5) 파일련관 

《파일련관》에서는�응용프로그람들과�자료파일들의�련결을�설정해준다.�즉�파일열

람기에서�파일을�시동시킬�때�어느�응용프로그람으로�시동시키겠는가를�설정할수�있다.�
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련습문제 

 

1. 탁상면을�3개�만들고�각각�배경그림과�위치를�서로�다르게�설정하여라.�

2. 프로그람이�기동할�때�마우스지시자근방에서�그�프로그람의�그림기호가�10초동안�깜

박이게�하여라.��

�

�

�

제4절. 콤퓨터망 

1. 콤퓨터망의 개념 

콤퓨터망이란�개별적인�콤퓨터들이�호상�접속된�콤퓨터들의�묶음을�말한다.�

구체적으로�보면�콤퓨터망은�통신선로를�리용하여�서로�다른�지점에�분산되여있고�

독립적인�기능을�가지는�콤퓨터체계를�서로�련결하여�망규약에�따라�자료통신과�자원공

유를�실현하는�체계이다.�

콤퓨터망은�여러�콤퓨터들을�결합하여�장치들을�공유하거나�다양한�정보자료를�효

과적으로�리용할�목적으로�출현하였다.�

콤퓨터망기술은�급속히�발전하고있는�콤퓨터과학기술의�한�분야이다.�

콤퓨터망은� 경영활동과� 생산공정관리에서� 널리� 리용될뿐아니라� 사회생활의� 거의�

모든�분야에�침투되고있다.�

그러므로�우리는�콤퓨터망에�대한�폭넓고�깊은�지식을�소유하여야�한다.�

�

�

�

�

�

�

�

1) 콤퓨터망의 분류 

콤퓨터망은�여러�각도에서�분류할수�있다.�

①�망의�위상구조에�따라�별형,�나무형,�모선형,�고리형,�그물형�등으로�나눈다.�

�

콤퓨터망이란�무엇인가?�

생각하기
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②�망의�사용범위에�따라�공공망과�전용망으로�나눈다.�

공공망(Public�Network):�일반적으로�전화봉사망을�들수�있는데�사회의�모든�사

람들에게�봉사를�제공하는�망이다.�

전용망(Private�Network):�어느�부분의�특수업무를�위하여�건설된�망이며�다른�

단위의�사람들에게는�봉사를�제공하지�않는다.�

③�망의�분포범위에�따라�국부망,�지역망,�광대역망,�인터네트로�분류한다.�

국부망(LAN:�Local�Area�Network):�학교나�연구소�등�한�구역내에서�통신선로

를�통해�자원을�공유하고�정보를�교환할수�있게�하는�근거리망이다.�

분포범위가�대체로�10m로부터�10km이하인것은�국부망으로�본다.�

우리�나라에는�현재�김일성종합대학,�김책공업종합대학,�인민대학습당,�발명국,�중

앙과학기술통보사�등에�국부망이�구축되여있다.�

지역망(MAN:�Metropolitan�Area�Network):�도시규모에서�여러�기관,�기업소들

을�망라하는�망이다.�

MAN은�기본적으로�LAN의�확대판이며�LAN과�류사한�기술을�리용한다.�

광지역망(WAN:�Wide�Area�Network):�넓은�지리적령역인�한개�나라의�전�지역

을�포괄하거나�여러�대륙에�걸쳐�련결되여있는�망이다.�

분포범위가�보통�수십～수천km이다.��

광지역망의�통신매체로는�전화선�같은것을�리용할수�있다.�

먼거리통신을�진행하자면�콤퓨터와�함께�모뎀장치,�통신용프로그람,�전화회선,�경

로조종기�등이�필요하다.�

인터네트(Internet):�호상접속된�망들의�세계적인�모임이다.�

인터네트는�International�Network의�략자로서�말그대로�전세계의�수천,�수만대

의�콤퓨터들사이에�정보를�교환해주는�세계적인�콤퓨터망이다.�인터네트를�리용하면�전

세계에�있는�도서관의�자료도�임의의�시각에�리용할수�있다.��

별형� 나무형� 모선형�

그물형고리형�
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2) 콤퓨터망의 주요기능 

콤퓨터망의�리용목적은�자원의�공유가�기본이나�오늘날에�와서는�그의�높은�성능과�

광범한�보급에�의하여�그�이상의�다양한�목적들에�리용되고있다.�

콤퓨터망은�경영활동과�생산공정관리에서�널리�리용될뿐아니라�사회생활의�거의�모

든�분야에�침투되고있다.�

콤퓨터망은�주로�다음의�4가지�기능을�수행한다.�

①�자료전송기능�

자료전송은�콤퓨터망의�기초적인�기능으로서�이�기능이�있어야�콤퓨터들사이의�각종�

정보교환과�지리적으로�먼거리에�있는�대상과의�자료교환을�실현할수�있다.�

②�자원공유�

자원공유는�개별적인�콤퓨터체계들의�장치자원과�프로그람자원,�자료자원을�공동으

로�리용하는것이며�콤퓨터망의�가장�중요한�기능이라고�말할수�있다.�

③�콤퓨터의�믿음성과�리용성을�높이는것�

망에�있는�콤퓨터들을�서로�대리설비로�리용함으로써�어느�한�콤퓨터에�고장이�생

겨도�다른�콤퓨터에�의하여�그�과제가�수행될수�있으며�전체�체계에�영향을�주지�않게�한다.�

또한�망에�있는�한�콤퓨터의�부하가�클�때�망을�통하여�다른�콤퓨터에로�부하를�분

산시킴으로써�부하를�균등하게�하고�매�콤퓨터의�리용성을�높일수�있다.�

④�분산식처리기능�

하나의�콤퓨터능력으로는�완성하기�어려운�큰�문제에�대하여�일정한�알고리듬으로

과제를�여러�콤퓨터에�분공하여�협조완성하게�함으로써�망자원을�균형적으로�사용하게

하는�분산처리의�목적을�달성할수�있다.�

그러므로�콤퓨터망기술을�리용하여�많은�콤퓨터를�련결하면�고성능의�콤퓨터체계를

구축할수�있다.�이러한�체계를�사용하면�고성능의�대형,�중형콤퓨터를�쓰지�않고도�크

고�복잡한�문제를�해결할수�있다.�

2. 콤퓨터망의 설정 

여기서는�망접속방법과�자원공유방법에�대하여�보겠다.�

1) 망접속 

서로�다른�콤퓨터들사이에�통신을�진행하자면�콤퓨터들사이에�망접속이�이루어져야�

한다.�

망설정을�진행하려면�《조종판》창문에서�조종묶음�《인터네트와�망》을�선택하고�오

른쪽칸에�나타나는�《망편성》을�두번찰칵한다.�
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그러면�《망편성》창문이�펼쳐진다.�

�

�

�

�

�

�

�

�

�

�

�

�

이써네트(모선형국부망)망접속을�구성하는�과정을�통하여�망설정방법을�보자.�

이써네트는�가장�널리�리용되는�국부망으로서�사람들이�대화를�진행하는것과�같은�

방식으로�동작한다.�즉�두�콤퓨터가�동시에�정보전송작업을�하면�충돌하게�되므로�서로�

우선권을�주면서�잠시�기다렸다가�정보전송을�한다.�

이써네트접속을�실현하기�위하여서는�망대면부카드(NIC)와�망케블(보통�CAT5케

블),�련결할�망이�있어야�한다.�

《망편성》창문에서�도구띠의�《새로�작성》그림기호를�찰칵한다.�그러면�《새로운�장

치형�추가》대화칸이�나타난다.�



�

�

69

�

�

�

�

�

�

�

�

�

�

�

�

�

《장치형》목록에서�《이써네트접속》을�선택하고�《앞으로(F)》단추를�찰칵한다.�

만일�이미전에�망대면부카드를�하드웨어목록에�추가하였다면�《이써네트카드》목록

에서�해당�망카드를�선택하고�추가하지�않은�경우에는�하드웨어장치를�추가하기�위하여�

《다른�이써네트카드》를�선택한다.�이미전에�추가하였던�이써네트카드를�선택하려고�한

다면�그것을�선택하고�《앞으로(F)》단추를�찰칵한다.�

�

�

�
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�

그러면�《이써네트적응기�선택》으로�전환되는데�여기서�필요한�설정을�하고�《앞으

로(F)》단추를�찰칵한다.�
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이때�나타나는�《망설정편성》에서�《IP주소�정적으로�설정》항목을�선택하고�IP주

소(콤퓨터망에서�자기콤퓨터가�차지하는�자리표식)와�부분망마스크(콤퓨터망에서�자기

콤퓨터가�속해있는�부분망의�자리표식)를�입력하고�《앞으로(F)》단추를�찰칵한다.�

�
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�

이때�나타나는�《이써네트장치�창조》에서�《적용(A)》단추를�찰칵한다.�

192.168.0.112 

255.255.255.0 
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그러면�《망편성》창문의�장치목록에�새로운�망장치가�나타난다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

장치활성화를� 진행하려면� 활성화하려는� 장치를� 장치목록에서� 선택하고� 도구띠의�

《활성화》그림기호� 를�찰칵한다.�그러면�《망편성》창문에서�선택된�장치가�활성화

상태로�된다.�

192.168.0.112 

255.255.255.0 
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《파일(F)》차림표의�《보관(S)》지령을�실행하여�변화된�내용을�보관한다.�

구성상태를�변경하려면�장치목록에서�해당�장치를�선택하고�도구띠의�편집그림기호

를�선택하여�변경할수�있다.�

다른�망대면부형식들도�이써네트와�류사한�방법으로�망설정을�진행할수�있다.��

2) 자원공유 

망의�목적은�자료통신과�함께�자원공유를�목적으로�한다.�

Setup등록부를�공유하는�방법을�보기로�하자.�

《파일열람기》에서�Setup등록부를�오른쪽찰칵하여�나타나는�지름차림표에서�《공

유》지령을�찰칵한다.�

�

�

�

�

�

�
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이때�나타나는�대화칸에서�《공유(S)》표쪽을�찰칵하고�《서류철을�공유합니다(S).》

를�선택한다.�

�

�

�
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�

�

�

�

《다른�사용자들이�서류철을�변경하는것을�허용합니다(W).》를�선택하면�다른�콤퓨

터들에서�이�등록부의�내용을�지우거나�변경할수�있다.�

《공유체계를�설정하려면�여기를�누르십시오.》를�찰칵하여�나타나는�《공유체계설

정》대화칸에서�작업조이름과�공유방식을�설정한다.�
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《완료(F)》단추를�찰칵하면�《파일열람기》에서�Setup등록부의�그림기호가�

로�변한다.�이렇게�하면�Setup등록부의�내용을�다른�콤퓨터에서�열람�및�복사할수�있다.�
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다음은�콤퓨터장치를�활성화하고�등록부가�공유된�상태에서�다른�콤퓨터들에서�열

람하는�방법을�보자.�

먼저�《파일열람기》에서�《망자원》을�선택한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

다음�《Samba망》을�선택한다.�
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그림과�같이�Workgroup을�선택한다.�
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여기에서는�콤퓨터망에�가입된�모든�콤퓨터들의�주기계이름들이�나타난다.�

열람하려는�임의의�콤퓨터를�선택한다.�
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그러면�선택된�콤퓨터의�공유된�등록부목록이�나타난다.�

임의의�등록부를�열어�자료를�열람할수도�있고�자르기,�복사�및�붙이기지령을�실현

할수�있다.�

�

 

련습문제 

1.�두개의�콤퓨터를�서로�망으로�련결하고�활성화시켜라.�

2.�매�콤퓨터들에서�한개씩의�등록부를�공유시키고�서로�다른�콤퓨터들에서�다른�콤퓨

터의�자료를�열람하여라.�

3.�망에서�다른�콤퓨터의�자료를�삭제하여라.�

4. 망에서�다른�콤퓨터의�자료를�자기�콤퓨터에�복사하여라.�

5.�망에서�다른�콤퓨터의�자료를�자기�콤퓨터에�이동하여라.�

6.�망에서�자기�콤퓨터의�자료를�다른�콤퓨터에�복사하여라.�

7.�망에서�자기�콤퓨터의�자료를�다른�콤퓨터에�이동하여라.�

�

�

�

�

�

제 5절. 하드디스크의 구획관리 

�

하드디스크�구획가르기와�합치기는�구획관리도구로�실현할수�있다.�

구획관리도구는�하드디스크의�구획을�편리하게�관리할수�있도록�도와주는�매우�유

용한�프로그람이다.�

구획관리도구를�리용하여�디스크의�매�구획들을�상세하게�볼수�있으며�새로운�구획�

을�창조하고�해당한�파일체계로�초기화할수�있다.�또한�이미�창조된�구획을�삭제할수�있다.�

구획관리도구는�이밖에도�디스크의�해당�구획을�능동상태로�설정하는�기능과�숨기

는�기능을�비롯하여�보다�풍부한�기능을�제공한다.�

구획관리도구로�하드디스크의�구획가르기와�합치기를�하려면�먼저�구획관리도구를�

기동시켜야�한다.�
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구획관리도구는�《조종판》창문에서�《성능과�정비》를�선택하고�《구획관리도구》

를�두번찰칵하여�기동시킬수�있다.�

�

�

�

또는�《시작》→《지령실행》을�실행하여�나타나는�대화칸에서�그림과�같이�qtparted

지령을�입력하고�《실행(R)》단추를�찰칵하면�된다.�

�

�

지령을�실행하면�《구획관리도구》창문이�나타난다.�
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1) 디스크선택 

《구획관리도구》창문의�《디스크(D)》차림표�혹은�창문의�왼쪽에�있는�《검출된�장

치정보》목록에서�관리하려고�하는�디스크를�선택한다.�그러면�그�디스크에�대한�구획정

보가�나타난다.�

�

�
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디스크를�선택한�다음�구획을�선택하고�진행할�조작을�설정한다.�

《구획관리도구》창문의�《조작》차림표에서�기본적인�조작설정을�진행한다.�

기본조작에는�속성,�창조,�초기화,�삭제,�능동설정,�숨기기가�있다.�

2) 구역속성보기 

구획을�선택하고�《조작》→《속성》을�실행하거나�구획목록에서�오른쪽찰칵하여�나

타나는�지름차림표에서�《속성》지령을�실행한다.�

그러면�그림과�같이�현재�선택된�구획의�형태와�위치정보,�파일체계와�같은�정보들

을�보여주는�대화칸이�나타난다.�

�

�

�

�

�

�

�

�

3)�구획창조�

구획창조는�디스크에�빈�공간이�있을�때만�할수�있다.�

기본구획(Primary�Partition)은�확장구획(Extended�Partition)이�없는�경우�최대

4개,�확장구획이�있는�경우�최대�3개까지�창조할수�있다.��

그리고�확장구획은�1개만�창조할수�있다.��

론리구획(Logical�Partition)은�확장구획내에서만�창조할수�있으며�12개이상�창조

할수�없다.�

구획을�창조하기�위해서는�다음과�같이�한다.�

먼저�조작설정을�진행할�구획을�선택하고�《조작》→《창조》를�실행하거나�구획목

록에서�오른쪽찰칵하여�나타나는�지름차림표에서�《창조》지령을�실행하면�《구획창조》

대화칸이�나타난다.�

�

�

�

�

�

�
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《구획창조》대화칸에서�창조형태와�구획형태,�위치와�크기,�표식설정을�진행한다.�

구획형태에�따라�표식을�설정할수�있는�최대길이가�있으며�그이상은�설정할수�없다.�

구획형태에�따르는�표식의�최대길이는�다음과�같다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

구획을�창조할�때�창조형태가�확장구획이면�구획형태를�가지지�않는다.�즉�구획형

태설정이�불가능하다.�

구획형태에�따라�구획을�창조할수�있는�최소구획크기가�있으며�그�크기보다�더�작

은�구획은�창조할수�없다.�

다음�《동작》→《수행》지령을�실행시키거나�수행그림기호를�찰칵하여�새로운�구획

을�창조한다.��

창조조작을�수행한�다음에는�재시동을�하여야�진행된�조작이�유효하다.�

4) 구획초기화 

구획초기화는�창조된�구획의�구획형태를�변화시킨다.�

구획을�초기화하기�위해서는�구획을�선택하고�《조작》→《초기화》를�실행하거나�구

획목록에서�오른쪽찰칵하여�나타나는�지름차림표에서�《초기화》지령을�실행한다.�

그러면�《구획초기화》대화칸이�나타난다.�

��

�

�

�

�

�

�

�

�

������

�

구획형태들과 표식의 최대길이 

FAT16:�DOS와�Windows3.x/95/98/Me/2000/XP에서�사용하며�최대길

이는�11byte이다.�

FAT32:�Windows98/Me/2000/XP에서�사용하며�최대길이는�11byte이다.�

NTFS:�WindowsNT/2000/XP에서�사용하며�최대길이는�32byte이다.�

ext2,�ext3,�linux-swap:�《붉은별》체계에서�사용하며�ext2,�ext3는

16byte,�linux-swap는�15byte이다.�

알아두기 
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《구획초기화》대화칸에서�구획형태와�표식설정을�진행한다.�

초기화조작설정을�진행하고�《동작》→《수행》지령을�실행하면�선택된�구획이�초기

화된다.�

일부�변경내용이�반영되지�않을�때에는�콤퓨터를�재시동하여야�한다.�

5) 구획삭제 

구획삭제는�창조된�구획을�삭제하여�빈�공간으로�되게�한다.�

구획을�선택하고�《조작》→《삭제》�혹은�지름차림표에서�《삭제》지령을�실행한다.�

구획삭제조작을�진행하고�《동작》→《수행》지령을�실행하거나�수행그림기호를�찰

칵하면�선택된�구획이�삭제된다.��

삭제조작을�수행한�다음�재시동을�하여야�진행된�조작이�유효하다.�

6) 능동설정 

능동설정은�기본구획으로�창조된�구획을�능동상태(active)로�만든다.�

한�디스크에�능동설정된�구획이�두개이상�있을수�없다.�

구획을�선택하고�《조작》→《능동설정》�혹은�지름차림표에서�《능동설정》지령을�실

행한다.�

능동설정조작을�진행하고�《동작》→《수행》지령을�실행하거나�수행그림기호를�찰칵한다.�

7) 구획숨기기 

구획숨기기는�창조된�구획을�볼수�없게�한다.�

구획숨기기는�구획형태가�ext2나�ext3,�linux-swap인�구획에�대해서는�적용할수�

없다.�

구획관리도구를�리용하여�구획숨기기를�한�구획은�Windows�2000체계에서는�숨김

구획으로�표시되지�않는다.�

구획을�선택하고�《조작》→《숨기기》�또는�지름차림표에서�《숨기기》지령을�실행

한다.�

구획숨기기조작을�진행하고�《동작》→《수행》지령을�실행하거나�수행그림기호를�찰

칵한다.�

숨기기조작을�수행한�다음�재시동을�하여야�진행된�조작이�유효하다.�

8) 동작설정 

조작설정을�진행한�다음에는�동작설정을�진행한다.�

《구획관리도구》창문의�《동작》차림표에서�기본적인�동작설정을�진행한다.�

기본동작에는�수행,�취소,�끝내기가�있다.�

수행은�설정된�조작이�실지로�디스크에�반영되게�한다.�
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《동작》→《수행》지령을�실행하거나�수행그림기호를�찰칵한다.�그러면�해당�조작

이�실행되면서�디스크에�반영된다.�

취소는�설정된�조작을�취소하여�조작설정전의�상태를�회복한다.�

《동작》→《취소》지령을�실행하거나�취소그림기호를�찰칵한다.�그러면�설정된�조

작은�취소되고�설정전의�상태가�회복된다.�

끝내기는�구획관리도구를�끝낸다.�

《동작》→《끝내기》지령을�실행하면�된다.�

9)�추가설정�

《구획관리도구》창문의《추가설정》→《편성》지령을�실행하면�《편성》대화칸이�나

타난다.�

�

�

�

�

�

�

�

�

�

�

�

이�대화칸에서�디스크정보를�보여주는�방식을�설정할수�있으며�구획관리도구에서�리

용되는�외부프로그람의�목록과�그�실행경로를�볼수�있다.�

○�《구획관리도구배치(L)》�

디스크의�구획정보들을�보여주는�방식을�설정한다.��

방식에는�3가지가�있다.�

도표�-�구획정보를�그림으로만�보여준다.�

목록�-�구획정보를�목록으로만�보여준다.�

도표�및�목록�-�구획정보를�그림과�목록으로�둘다�

보여준다.�

구획정보를�그림으로�표시할�때�쉽게�구별할수�있

도록�구획형태에�따라서�서로�다른�색갈로�보여준다.�

오른쪽의�표는�구획표형태에�따르는�색표시를�보여

준다.�

○�《외부도구(E)》�

구획관리도구에서�리용하는�외부프로그람들을�보여준다.�

구획형태� 색�

FAT16� 풀색�

FAT32� 어두운�풀색

ext2� 분홍색�

ext3� 보라색�

NTFS� 붉은색�

swap� 푸른색�

Unknown� 흰색�

free� 재색�
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○�《실행프로그람�절대경로(F)》�

선택된�외부도구의�실행경로를�보여준다.�

10) 디스크에 대한 조작 

디스크에�대한�조작으로서�새�구획표만들기를�진행할수�있다.�

새�구획표만들기는�선택된�디스크의�구획표를�초기화한다.�

《구획관리도구》창문의�왼쪽에�있는�《검출된�장치정보》목록에서�디스크를�선택하

고�오른쪽찰칵하여�나타나는�지름차림표에서�《새�구획표만들기》지령을�실행한다.�그러

면�다음과�같은�통보가�나타난다.�

�

�
�

《확인》단추를�찰칵하면�새�구획이�만들어진다.�

�

련습문제 

1.�하드디스크의�구획정보를�확인하여라.�

2.�40Gbyte의�하드디스크를�5Gbyte의�Active�NTFS구획으로,�5Gbyte의�ext3구획으

로,�30Gbyte의�FAT32구획으로�구획을�설정하여라.�

3. 우의�구획으로�갈라진�하드디스크를�5Gbyte의�Active�NTFS구동기와�35Gbyte의�

FAT32구획으로�구획을�설정하여라.�

�
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제2장. 성적표 

�

제1절. 성적표만들기 

�

통합사무처리프로그람�《우리》에는�표계산프로그람�《표》가�있다.��

《표》를�리용하여�성적표와�같은�여러가지�계산표를�만들고�수값자료들의�총합이나�

평균값계산,�순위�등을�쉽게�계산할수�있으며�도표도�작성하고�자료들의�검색,�수정�등�

여러가지�처리를�진행할수�있다.�

�

1. 표계산프로그람 《표》의 기동과 창문구성 

�

표를�작성하고�각종�처리를�진행하려면�표계산프로그람�《표》를�기동하여야�

한다.�

�

�

�

�

�

�

�

�

�

�

《시작》차림표에서�《응용프로그람》을�찰칵하여�나타나는�부분차림표에서�《종

합사무처리》를�찰칵하고�다시�나타나는�부분차림표에서�《표》를�찰칵하여�실행

시킨다.�즉�

《시작》→《응용프로그람》→《종합사무처리》→《표》 

《표》를�기동하려면�어떻게�해야�하는가?�

�

생각하기 
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�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

《표》의�기본창문은�제목띠,�차림표띠,�표준도구띠,�서식지정도구띠,�수식입력칸,

작업표,�상태띠�등으로�구성되여있다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

제목띠�

차림표띠�

수식입력칸

작업표�

서식지정도구띠

표준도구띠�

렬머리부�

행머리부�

수식지정도구띠

상태띠�
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�

�

�

�

�

�

�

그림에서와�같이�《표》의�기본창문에는�《글》창문에�있는�차림표띠,�도구띠외�수

식입력칸이�있으며�작업표로�구성되여있다.�

《표》에서�기본은�작업표(용지)이며�작업표는�본문,�수식�또는�수값을�입력할수�있

는�렬과�행으로�이루어져있다.��

표를�이루는�매개�칸을�세포,�현재�작업이�진행되는�세포를�능동세포라고�한다.�

세포는�주소를�가지는데�주소는�렬번호와�행번호를�결합한것이다.�실례로��

A4,�C23,�B17,�…�

와�같이�줄수�있다.��

1) 상대주소와 절대주소 

주소에는�상대주소와�절대주소가�있다.�

상대주소는�렬번호와�행번호를�결합한�일반적인�주소로서�수식이나�함수가�다른�행

혹은�다른�렬에�복사될�때�상대적으로�변하는�세포의�주소이다.��

상대주소의�표시는�일반적인�주소표시와�같다.�

절대주소는�작업표안의�절대적인�위치에�토대하는�세포의�주소�즉�변하지�않는�본래�

자기주소로서�상대주소의�렬번호,�행번호앞에�$기호를�붙인�주소를�말한다.�즉��

$A$4�,�$C$23�,�$B$17�

로�표시한다.��

절대주소는�순위�등을�낼�때�참고하는�주소이다.�

2) 용지(작업판)의 이름 

《표》를�기동하였을�때�《표》의�기본창문에는�《용지1》,�《용지2》,�《용지3》

이라는�3개�용지가�있다.��

자기가�현재�작업한�작업표의�내용이�잘�알려지게�하려면�용지들의�이름을�달아주

는것이�좋다.��

실례로�학급학생들의�성적을�기록한�자료표는�《성적표》로�이름을�달아주면�리용하

기에�합리적이다.�

용지이름을�《성적표》로�달아주려면�다음과�같이�한다.�

《표》의�창문구성이�《글》의�창문구성과�어떻게�다른가?�

생각하기 
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①�용지의�아래끝에�있는�용지이름�실례로�《용지1》을�오른쪽찰칵하여�나타나는�지

름차림표에서�《용지이름바꾸기》지령을�실행한다.��

그러면�《용지이름바꾸기》대화칸이�나타난다.�

�

�

�

②�대화칸의�《이름(A)》칸에�《성적표》라고�이름을�입력하고�《확인》단추를�찰

칵한다.�

그러면�선택한�용지이름이�《성적표》로�바뀐다.�

새로운�용지를�더�삽입하려면�용지이름칸에서�오른쪽찰칵하여�나타나는�지름차림표

에서�《용지삽입》지령을�실행한다.�

�

�

�
�

�

그러면�다음과�같은�《용지삽입》대화칸이�나타나는데�이�대화칸에서�삽입할�용지의�

개수와�이름,�용지위치를�설정해준�다음�《확인》단추를�찰칵하면�된다.�
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�

�

�

필요없는�용지를�삭제하거나�용지들의�이동,�복사도�할수�있다.�

용지를�삭제하기�위해서는�해당�용지를�선택하고�오른쪽찰칵하여�나타나는�지름차

림표에서�《용지삭제》지령을�실행한다.�그러면�현재의�용지를�삭제하겠는가를�묻는��통

보가�나타난다.�

�

�

�

�

�

�

�

�

�

《예(Y)》단추를�찰칵하면�선택한�용지가�삭제된다.�

또한�용지들의�순서를�바꾸기�위해서는�해당�용지를�오른쪽찰칵하여�나타나는�지름

차림표에서�《용지�이동/복사》지령을�실행한다.��

그러면�다음의�대화칸이�나타난다.�
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�

�

�

�

�

�

�

�

�

�

�

�

�

�

이동위치를�선택하고�《확인》단추를�찰칵하면�해당�위치에로�용지가�이동된다.�

또한�해당�용지를�복사하기�위해서는�《용지�이동/복사》대화칸에서�《복사(C)》

를�선택하고�《확인》단추를�찰칵하면�해당�용지가�복사된다.�

�

2. 자료의 입력 

다음과�같은�자료를�입력하자.�

�

� � � �

� �

소년반성적표 
� �

번호 이름 혁명력사 수학 콤퓨터 외국어 총점 평점 순위 최우등생수

1 김영철 5 4 5 5     

2 김순희 5 3 4 5     

3 리복남 5 5 5 5     

4 박성길 5 5 3 5     

5 한명옥 5 5 4 3     
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세포를�선택하면�그�세포는�능동세포로�된다.��

C1세포를�선택하고�그의�오른쪽아래에서�마우스지시자가�+로�되였을�때�마우스를

H2세포까지�끌기하면�그�범위의�세포들이�모두�선택된다.��

이제�표준도구띠에서�세포합치기그림기호� 를�찰칵하면�선택된�세포들이�합쳐져

서�하나로�된다.�여기에�《소년반성적표》라고�제목을�입력한다.�

A3,�B3,�C3,�D3,�E3,�F3,�G3,�H3,�I3,�J3세포들을�차례로�선택하고�《번호》,�

《이름》,�《혁명력사》,�《수학》,�《콤퓨터》,�《외국어》,�《총점》,�《평점》,�《순

위》,�《최우등생수》라고�입력한다.��

세포에�문자나�수자자료들을�입력한�다음�자료들이�세포의�중심에�배치되게�하려면�

세포들을�선택하고�서식지정도구띠에�있는�가운데맞추기그림기호� 를�찰칵하면�된다.�

번호와�같이�련속인�자료를�하나하나�입력할수도�있지만�그것을�쉽게�입력할수도�

있다.��

실례로�《번호》렬에�학생번호를�다음과�같이�입력할수�있다.�

①�A4에�1을,�A5세포에�2를�입력한다.�

②�A4,�A5세포들을�선택하고�마우스지시자를�오른쪽아래끝에�가져간다.��

③�마우스지시자가�+모양으로�변하면�마우스끌기로�번호를�입력하려는�범위만큼�선

택한다.�그러면�련속된�번호들이�채워진다.�번호와�같이�련속되는�자료들은�이와�같은�

방법으로�쉽게�입력할수�있는데�그�간격은�먼저�입력된�두�세포의�값의�차와�같다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�
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《혁명력사》성적과�같이�같은�자료를�련속되는�몇개의�세포에�입력하려면�먼저�자

료를�두개이상의�세포에�입력한�다음�련속자료입력때와�같이�마우스를�조작한다.�

또는�같은�자료를�채우려는�세포범위를�선택한�다음�《편집(E)》→《채우기(L)》→

《아래로(D)》지령을�실행한다.��

그러면�선택한�범위만큼�같은�자료가�채워진다.�

�

�

�

�

�

�

�

�
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�
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�

�

�

�

�

이런�방법으로�《소년반성적표》에�학생들의�이름과�과목별성적들을�입력한다.�

만일�렬의�폭을�넓히거나�좁히려면�렬번호가�표시되여있는�렬머리부를�찰칵하여�폭

을�변경하려는�렬을�선택한�다음�렬경계선에�마우스지시자를�가져가�마우스지시자가�쌍

방향화살표모양으로�바뀌였을�때�마우스끌기로�렬의�폭을�조절한다.�행의�높이변경도�

같은�방법으로�진행한다.�

�

���������

�

�

�

�

�
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한편�세포의�입력내용에�기준을�설정하면�오유값이�입력되는것을�막을수�있다.�

①�입력기준을�정의할�세포를�선택한다.��

②�《자료》→《유효성》지령을�실행한다.�그러면�《유효성》대화칸이�펼쳐진다.�

③�《값》에서�세포에�입력을�허가하는�값을�지정한다.�이미�입력되여있는�값에�이

규칙은�적용되지�않는다.�

《목록칸�허용》은�표준설정에서�《모든�값》으로�되여있다.�이�경우�입력에�대한�제

한은�없다.�여기서는�정수,�소수,�날자,�시간,�본문의�길이를�선택할수�있다.�

�

주어진�자료를�보존하면서�새로운�항목을�삽입하여야�할�필요성이�있는�경우�렬이

나�행을�새로�삽입할수�있다.��

렬이나�행을�삽입하려면�렬머리부나�행머리부를�오른쪽찰칵하여�나타나는�지름차림

표에서�《렬삽입(I)》�혹은�《행삽입(I)》지령을�실행한다.�

�

�

�

�

�

�

�

�

�

�

�

�
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�
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�

�

�

�

�

그러면�선택된�렬이나�행의�앞에�새로운�렬,�행이�삽입된다.�이때�렬번호나�행번호

는�자동적으로�순서대로�설정된다.�

또한�렬이나�행의�수가�많아서�한개�화면을�벗어나�보기에�불편하면�필요없는�렬이

나�행을�일시적으로�숨길수�있다.�
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렬이나�행을�숨기려면�숨기려는�렬이나�행들을�선택하고�오른쪽찰칵하여�나타나는�

지름차림표에서�《숨기기(H)》지령을�실행한다.�

그러면�선택된�렬이나�행들이�숨겨진다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

숨긴�렬이나�행들을�다시�보이게�하려면�숨겨진�렬이나�행들이�있는�앞뒤�렬이나�

행들을�선택하고�오른쪽찰칵하여�나타나는�지름차림표에서�《보이기(S)》지령을�실행한

다.�그러면�숨겨진�렬들이나�행들이�다시�나타난다.�

다음은�화면분할과�제목을�고정하는�방법에�대하여�보기로�하자.��

표자료가�한페지(한개�화면)를�넘어서는�경우�화면을�2개�혹은�4개로�분할하여�필

요한�자료들을�좌우상하로�끌어당겨서�리용할수�있다.�

주로�자료들을�대비분석하는�경우�화면분할을�진행한다.�

화면을�분할하려면�《창》→《분할》지령을�실행한다.�분할을�해제하려면�《분할》

지령을�다시�찰칵하면�된다.�

�

�

�

�

�

�

�

�

�

�
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자료가�한페지를�넘어서는�경우�제목이�항상�화면에�나타나게�하려면�《창》→�

《고정》지령을�실행하면�된다.�

작성한�표를�후에�다시�사용하려면�표를�보관하여야�한다.�

《표》에서�작업한�내용의�보관은�《글》에서와�마찬가지방법으로�한다.�

①�《파일》→《보관》을�실행하거나�표준도구띠에서�보관그림기호� 를�찰칵한다.�

그러면�《다른�이름으로�보관》대화칸이�나타난다.�

�

�

�

�
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�

�

②� 대화칸에서� 보관할� 장소를� 설정하고� 《파일이름(N)》칸에� 파일이름� 실례로�

《성적표》라고�입력한다.�

《붉은별》조작체계에서�《표》파일의�확장자는�ods이다.�

�

�

�

�

�

�

�

�

�

《다른�이름으로�보관》대화칸에서�《암호를�사용하여�보관(B)》를�선

택하면�어떻게�되는가?�

생각하기 
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③�《보관(S)》단추를�찰칵한다.�

《표》에서�이미�작성한�파일열기도�《글》에서와�같이�진행한다.�

①�《파일》→《열기》지령을�실행한다.�그러면�《열기》대화칸이�나타난다.�

②�《열기》대화칸에서�보관된�장소를�찾고�파일이름을�선택한�다음�《열기(O)》단

추를�찰칵한다.�

�

�

�

�

�

�

�
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�

표준도구띠에�있는�열기그림기호� 를�리용하여�펼칠수도�있다.�

표준도구띠에�있는�인쇄그림기호를�찰칵하면�파일안의�모든�용지가�인쇄된다.��

일정한�범위만을�인쇄하려는�경우에는�인쇄범위를�정의해주어야�한다.�

인쇄범위정의는�인쇄할�범위를�선택한�다음�차림표의�《서식》→《인쇄범위》→《정

의》지령을�실행한다.�

현재�표시중에�있는�용지를�인쇄하려면�《파일》→《인쇄》지령을�실행한다.�

다음�이때�나타나는�《인쇄》대화칸의�《인쇄범위》에서�《선택》을�선택하고�《확

인》단추를�찰칵한다.��

그러나�용지안에�선택되여있는�세포가�있는�경우에는�화면우에�보이는�폭을�페지폭

으로�하여�선택세포만이�인쇄된다.�

여러개의�용지�실례로�《용지1》과�《용지2》를�동시에�인쇄하려면�다음과�같

이�한다.�

성적표 
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①�Ctrl건을�누르면서�《용지1》과�《용지2》를�선택한다.�

②�《파일》→《인쇄》지령을�실행한다.�

③�《인쇄》대화칸에서�《선택》을�선택하면�이미�선택해놓은�용지가�모두�인쇄된다.�

인쇄한�다음�Shift건을�누른�상태에서�표의�제목을�찰칵하고�다른�표의�선택을�해

제한다.��

이�조작을�진행하지�않고�표시중에�있는�표에�변경을�주면�다른�표에도�같은�변경

이�자동적으로�적용된다.�

련습문제 

1.�자기�학급�성적표를�만들고�번호,�이름,�수학,�영어,�물리,�콤퓨터�순서로�자료를�

입력하여라.�

2. 우에서�작성한�《성적표》를�《2학년�1반�성적표》로�보관하여라.�

3.�《용지2》의�이름을�《소년반명단》으로�바꾸어달아라.�

4.�학생명단�제목행을�고정해보아라.�

5.�《2학년�1반�성적표》를�열고�과목성적을�10개로�만든�다음�화면분할을�진행해보아라.�

6.�자기�학급�학생들의�4,�5,�6,�7월�학과경연성적을�용지�4개에�작성하고�5번째�용지

에�《월종합성적》이라고�이름을�표시하여라.�

�

�

제 2절. 총점과 평점구하기 

세포에�입력된�수값자료들의�일반적인�계산은�수식입력칸에�구하려는�세포의�주소

들을�연산수로�하여�산수연산기호들을�입력하는�방법,�함수조수를�리용하는�방법으로�

진행한다.�

1. 총점구하기 

먼저�수식입력칸을�리용하여�계산하는�방법을�보기로�하자.�

수식의�입력은�언제나�같기기호로�시작된다.��

수식에는�수,�본문�및�다른�요소(수의�서식�표시�등)를�사용할수�있다.�또한�연산

자,�론리연산자,�함수이름도�입력할수�있다.�

4칙연산은�+,�-,�*,�/�기호를�사용하며�곱하기,�나누기를�먼저�진행하고�더하기,�덜

기는�후에�진행된다.��

아래에서�수식의�례를�들어보자.�
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=A1+10� A1값에�10을�더한다.�

=A1*16%� A1값의�16퍼센트�

=A1*A2� A1값에�A2값을�곱한다.�

=ROUND(A1;1)� A1값을�소수점아래�한자리까지�둥그리기한다.�

=B8-SUM(B10:B14)� B10부터�B14까지�합을�B8에서�던다.�

=SUM(B8;SUM(B10:B14)) B10부터�B14까지의�합을�B8값에�더한다.�

�

실례문제에서�매�학생들의�총점을�구하자면�총점을�구하려는�세포를�선택하고�수식

입력칸에�계산될�점수들이�있는�세포주소들을�연산수로�하는�수식을�입력하여야�한다.�

실례로�김영철학생의�총점을�구하자면�먼저�G4세포를�선택한다.�

�

 A B C D E F G H I J 

1     

2   

소년반성적표 
  

3 번호 이름 혁명력사 수학 콤퓨터 외국어 총점 평점 순위 최우등생수 

4 1 김영철 5 4 5 5    

5 2 김순희 5 3 4 5    

6 3 리복남 5 5 5 5    

7 4 박성길 5 5 3 5    

8� 5� 한명옥 5� 5� 4� 3 � � �

�

다음�수식입력칸에�=C4＋D4＋E4＋F4라고�입력한�다음�Enter건을�누른다.�

다른�학생들의�총점을�구하는�방법도�같으며�평점을�구하는�방법도�마찬가지이다.�

즉�수식입력칸에는�일반적인�수학계산을�진행하는�임의의�산수연산기호들을�다�리

용할수�있다.�

또는�수식지정도구띠의�합계그림기호� 를�찰칵한�다음�과목별성적이�표시된�세포

들을�마우스끌기로�선택한�다음�Enter건을�누른다.�
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그러면�G4세포에는�김영철학생의�총점이�입력된다.�

한�학생의�총점을�구한데�기초하여�다른�학생들의�총점을�간단히�구할수도�있다.�

우에서�구한�김영철학생의�총점이�들어있는�G4세포를�선택하고�련속자료입력때와�같이�

마우스를�조작하면�된다.�

�

A B C D E F G H I J 

1 
� � � �

2 
� �

소년반성적표 
� �

3 번호 이름 혁명력사 수학 콤퓨터 외국어 총점 평점 순위 최우등생수 

4 1 김영철 5 4 5 5 19    

5 2 김순희 5 3 4 5 17    

6 3 리복남 5 5 5 5 20    

7 4 박성길 5 5 3 5 18    

8 5 한명옥 5 5 4 3 17    

�

�

여러개�용지에�입력되여있는�값들을�임의의�용지의�한�세포에�집계하려면�우선�집

계하려는�용지의�세포를�선택하고�도구띠의�합계그림기호� 를�찰칵한다.�

다음�해당�용지들의�값세포들을�Ctrl건을�누르면서�하나씩�선택한다.�

주의할것은�용지들을�펼칠�때에는�Ctrl건을�놓았다가�값세포들을�선택할�때�다시�

Ctrl건을�누르고�선택하여야�한다.��

자료들을�다�선택한�다음�Enter건을�누르면�집계가�완성되여�표시된다.�

2. 평점구하기 

수식계산은�함수를�리용하여�진행할수도�있다.�

함수는�많이�쓰이면서도�고급한�계산과정들을�정의하여놓고�값을�넣으면�즉시�결과

가�나오도록�한다.�



�

�

100�

그러면�함수를�리용하여�평점을�구하는�방법을�실례를�들어�보기로�하자.�

①�김영철학생의�평점을�입력할�H4세포를�선택하고�수식지정도구띠에서�함수조수

그림기호� 를�찰칵하여�《함수조수》대화칸을�펼친다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

《함수조수》대화칸에는�함수들을�기능별로�혹은�리용한�시기별로�참고할수�있는�

《범주(C)》목록이� 있는데� 일반적으로� 함수들을� 모두� 표시하는� 《모두》항목을�

설정하는것이�좋다.�

②�그아래의�《함수(F)》목록에서�평점을�구하는�함수�AVERAGE(평균)를�찾아�

두번찰칵한다.�그러면�수값들을�입력할수�있는�수자입력칸들이�나타난다.�

③�《수자1(C)》입력칸을�찰칵하고�김영철학생의�과목점수들이�표시된�세포들을�

마우스끌기로�선택하거나�C4:F4라고�입력하여�지정한다.�

④�《확인》단추를�찰칵한다.��

그러면�김영철학생의�평점이�선택된�세포�H4에�표시된다.(이때�평점을�소수점아래�

두자리까지�나타내려면�도구띠에서�수자형식:소수부추가그림기호� 를�찰칵하여�소

수부를�추가할수�있다.��

이�그림기호를�찰칵할�때마다�소수부자리가�한자리씩�추가되며�수자형식:소수
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부삭제그림기호� 를�찰칵할�때마다�소수부자리는�한자리씩�삭제된다.�

⑤�총점에서와�마찬가지로�련속자료입력기능으로�모든�학생들의�평점을�단번에�표

시한다.�

�

�

�

�

�

�

�

�

�

�

�

련습문제 

 

1.�2010년�1월�1일부터�1월�31일까지�자료를�련속입력방법으로�입력하여라.�

2.�임의의�수자와�문자를�입력하고�채우기방법으로�각각�10칸씩�입력하여라.�

3.�앞에서�만든�《2학년�1반�성적표》에서�《총점》과�《평점》항목을�만들고�수식입력

방법으로�총점과�평점을�구하여라.�

4.�우의�《성적표》에서�함수조수를�리용하여�총점과�평점을�구하는�방법을�말하고�구해

보아라.�

5.�《2학년�1반�성적표》에서�총점을�자동합구하기로�구하여라.�

�

�

�

제 3절. 자료의 형식화 

표를�작성한�다음�혹은�작성시에�세포나�표에�대하여�일정한�서식화를�적용

할수�있다.�

다시말하여�배경색을�설정한다든가�조건에�따라�일부�세포들의�서체와�글자색을�바

꾸기�등의�서식화를�할수�있다.�

탐 구 
�

총점을�함수를�리용하여�구해보아라.�
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1. 세포의 서식지정 

1) 본문 

본문서식지정은�《글》에서와�마찬가지로�서식지정도구띠를�리용하여�진행할수도�있

고�차림표의�지령을�리용하여�진행할수도�있다.�

차림표의�지령을�리용하여�우에서�작성한�표에서�《소년반성적표》의�서체는�광명체

로,�서체크기는�14로�주기�위해서는�다음과�같이�한다.�

①�서식지정할�본문�《소년반성적표》를�선택한다.��

②�차림표의�《서식》→《세포》지령을�실행하여�나타나는�《세포서식지정》대화칸

에서�《서체》표쪽을�찰칵한다.�

�

�

③�《서체》칸에서�《광명》을�선택하고�《크기》칸에서�14를�선택한다.�

④�《확인》단추를�찰칵한다.�

또한�본문의�량끝�맞추기,�가운데맞추기�등을�진행하기�위해서는�다음과�같이�한다.�

①�맞추기를�진행하려는�범위를�선택한다.�

②�《서식》→《세포》지령을�실행하여�나타나는�《세포서식지정》대화칸에서�《맞

추기》표쪽을�찰칵한다.�
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�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

이�대화칸에서는�본문의�맞추기,�본문방향,�속성을�설정한다.�

③�《본문맞추기》에서�해당�맞추기를�선택한다.�

④�《확인》단추를�찰칵한다.�

한편�서식지정은�서식지정하려는�해당�본문을�선택하고�오른쪽찰칵하여�나타나는�

지름차림표에서�《세포》지령을�실행하여�할수도�있다.�

�

�

�

�

�

�

�

�

�

�

�

탐 구 
�

《본문방향》에서�《참고모서리(F)》의� ,� ,� 들을�리용해보아라.�어

떤�결과가�얻어지는가를�알아보아라.�
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2) 수자 

수의�서식지정도�본문의�서식지정방법과�마찬가지로�서식지정도구띠를�리용하거나�

차림표,�지름차림표를�리용하여�진행할수�있다.�

차림표를�리용하여�분수를�입력하는�방법을�보기로�하자.�

①�분수를�입력하려는�세포를�선택한다.�

②�《서식》→《세포》지령을�실행한다.�

③�《세포서식지정》대화칸에서�《수자》표쪽을�찰칵한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

④�《범주(C)》부분에서�《분수》를,�《서식(O)》부분에서�해당한�형태를�선택

한다.�

실례로�1/10과�같이�분모가�두자리이상으로�되는�수를�표시하려면�《서식(O)》칸에

서�《-1234�10/81》을�선택한다.�

⑤�해당�설정을�진행하고�《확인》단추를�찰칵한다.�

�
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3) 테두리와 배경 

어떤�특정한�세포�혹은�범위에�테두리를�주거나�배경색�등을�주기�위해서는�다음과�

같이�한다.�

①�세포범위를�선택한다.�

②�《서식》→《세포》를�실행한다.�

③�《세포서식지정》대화칸에서�세포에�테두리를�주기�위해서�《테두리》표쪽을�찰

칵하고�해당�테두리형식을�준다.�

�

�
�

④�세포에�배경을�주기�위해서�《배경》표쪽을�찰칵한�다음�해당�배경색을�선

택한다.�

또한�인쇄페지전체에�대한�서식을�설정하려면�《서식》→《페지》지령을�실행

한�다음�이때�펼쳐지는�《페지격식:표준》대화칸에서�테두리,�배경,�머리글�등을�설

정한다.�
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2. 자동서식과 조건적서식 

1) 자동서식 

작성한�표에�여러가지�서식을�지정하여�보기�좋게�완성할수�있다.�

실례로�자동서식기능을�리용하여�용지나�세포범위를�간단히�서식지정할수�있다.�

《성적표》를�자동서식지정하기�위해서는�다음과�같이�한다.�

①�《성적표》의�전체�세포범위를�마우스끌기로�선택한다.�

②�《서식》→《자동서식》지령을�실행하여�《자동서식》대화칸을�펼친다.�

�

�

�

�

�

�

�

�

�

�

③�《자동서식》대화칸의�《서식(O)》목록에서�해당한�서식�례를�들어�《표준》을�선

택한다.�그러면�가운데에�있는�미리보기칸에�그�형태가�나타난다.�

④�《확인》단추를�찰칵한다.�

결과�다음과�같이�표가�자동서식된다.�

�
� �

�
�

소년반성적표 
�

번호 이름 혁명력사 수학 콤퓨터 외국어 총점 평점 순위 최우등생수 

1� 김영철 5 4 5 5     

2� 김순희 5 3 4 5     

3� 리복남 5 5 5 5     

4� 박성길 5 5 3 5     

5� 한명옥 5 5 4 3     



�

�

108�

2) 조건적서식 

�

�

�

�

�

�

�

�

�

�

�

�

�

�

《소년반성적표》에서�5점인�세포들에는�붉은색,�4점에는�푸른색으로�하고�3점에는

노란색으로�조건적서식을�진행하여�보기로�하자.�

①�비여있는�3개�세포의�배경색을�붉은색,�푸른색,�노란색으로�설정한다.��

②�《서식》→《격식�및�서식》지령을�실행한다.�그러면�《격식�및�서식》대화칸이�나

타난다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

③�《붉은색》세포를�선택하고�《격식�및�서식》대화칸에�있는�선택된�부분으로부터

의�새�격식그림기호를�찰칵한다.��

�

�

조건적서식 

�

세포의�내용에�일정한�조건을�주고�그것이�만족되는�세포에�대하여�해당한

격식을� 설정하여� 세포의� 바탕색이나� 세포안의� 서체색갈,� 크기,� 테두리� 등을

사용자의�요구에�맞게�변화시키는�기능이다.�

�

알아두기 
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그러면�《격식만들기》대화칸이�나타난다.�격식이름을�red라고�입력하고�《확인》단

추를�찰칵한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

마찬가지방법으로�푸른색(blue)과�노란색(yellow)을�격식으로�설정한�다음�《격식�

및�서식》대화칸을�닫는다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

④�특정한�조건에�따라�서식격식을�지정하기�위하여�《서식》→《조건적서식》을�실

행한다.�

격식이�이미�세포에�할당된�경우�해당�격식은�바뀌지�않는다.�그다음�여기에서�입

력한�격식이�평가된다.��

세포값이나�서식의�내용을�질문하는�세가지�조건을�입력할수�있다.��

이�조건은�1에서�3까지�평가되며�조건�1이�일치할�경우�지정된�격식이�사용된다.�

그렇지�않으면�조건�2가,�조건�2의�격식이�일치하지�않으면�조건�3이�평가되고�지정된�

격식이�사용된다.�
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�
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�

�

�

�

�

�

�

�

�

�

�

그림과�같이�3가지�조건을�입력하고�세포격식을�설정한다.�즉�4이상이면�붉은색,�4

아래이면서�3이상이면�푸른색으로,�그아래이면�노란색으로�설정한다.��

조건설정과�세포격식설정이�끝나면�《확인》단추를�찰칵한다.�

주어진�조건을�해제하려면�해당한�검사칸선택을�해제한다.�

�

련습문제 

�

1.�조건적서식을�리용하여�《성적표》에서�수학성적�5점만을�붉은색으로�표시하여라.�그

리고�3점부터�5점사이를�노란색으로�표시하여라.�

2.�세포안의�글자색과�배경색을�설정해보고�차이점을�설명하여라.�

3.�《학기말성적표》를�작성하고�총점,�평점을�구한�다음�최우등생,�우등생,�보통생들을�

따로따로�서식지정하여�표시하여라.�

�

�

�

�

�

�

3

3

4�
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제3장. 우리 학급 자료기지 

제1절. 자료기지의 개념과 기초조작 

1. 자료기지란 무엇인가 

흔히�기지라고�하면�어떤�대상이�자리를�잡고있는�지역을�말한다.�

실례를�들어�과학연구기지라고�하면�과학연구기관들이�자리를�잡고있는�지역을�두

고�하는�말이다.�

자료기지라고�하면�이와�마찬가지로�자료들이�있는�대상이나�범위를�가리키는�개념

으로서�가치있는�자료들을�모아놓고�필요할�때�요구되는�자료들을�참고할수�있는�자료

들의�모임이라고�할수�있다.�

간단한�실례로�《학급학생명단》,�《2학년�1학기�성적표》와�같이�일정한�목적을�위

하여�작성하여놓고�필요할�때마다�리용하는�자료들의�모임을�자료기지라고�말할수�

있다.�

�

�

�

�

�

�

�

�

�

자료기지는�크게�마당과�레코드로�이루어져있다.�

마당은�자료의�가장�작은�단위로서�자료를�이루는�구체적인�항목이다.�실례로�《학급

명단》에서�《번호》,�《이름》,�《성별》,�《난날》,�《주소》�등과�같은�항목들이�마

당으로�될수�있다.�

레코드는�마당들의�모임을�말한다.�실례를�들어�《이름》，�《성별》，�《난날》，�《주

소》,�《전화번호》의�항목들에�대한�매개�학생들의�자료값들의�총체가�레코드로�된다.�

결국�《번호》,�《이름》,�《성별》,�《난날》,�《주소》의�항목을�가지는�표에�25

명�학생의�자료가�기록되여있다면�5개의�마당에�25개의�레코드가�있는것으로�된다.�

그리고�이�레코드들의�모임이�바로�표(자료기지)이다.��

�

자료기지는�무엇으로�구성되여있는가?�

�

생각하기 
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�

�

�

번�호� 이�름� 성�별� 난�날� 주��소� 전화번호�

1� 김철남� 남�자� 주체90.1.14� 보통강구역…� 457-3421�

2� 리옥성� 녀�자� 주체90.10.5� 만경대구역…� 756-5491�

�

�

마당이라는�개념에�대해서�좀�더�구체적으로�보자.�

우의�실례를�보고�알수�있는바와�같이�마당들은�서로�다른형의�자료값을�취할

수�있다.�

《번호》마당은�수값자료�더�정확히는�옹근수로�되여있는�수값자료를�취하게�되며�

그�길이도�일반적인�표에서는�수백,�수천정도의�길이를�넘지�않는다.�

《이름》마당은�문자렬자료이며�길이를�보면�조선사람의�이름인�경우�5글자를�넘지

않는다.�

또�《난날》마당은�문자와�수자들의�결합으로�이루어져있다.�물론�여기서�수자들은�

어떤�계산에�리용되는�수자들은�아니다.�

이와�같이�마당들의�자료들은�여러가지�형태의�여러가지�크기를�가지게�된다.�

이런�구체적인�개념들을�자료형,�자료길이로�정의한다.�

자료기지안의�모든�마당들에�대해서는�자료형과�자료길이(기억크기)를�정의해야�한다.�

한편�매개�마당은�다시�부분마당들로�가를수�있다.�

실례로�《1학년�성적》이라는�마당안에�《1학기�성적》과�《2학기�성적》이라는�부

분마당을�가질수�있다.�

통합사무처리프로그람�《우리》에는�자료기지관리프로그람�《자료기지》가�있다.�

�

�

�

��

�

�

�

《자료기지》로는�학급명단과�같은�여러가지�자료기지들을�만들고�필요한�자료를�검

색,�추출하는것과�같은�자료관리를�쉽게�진행할수�있다.�

자료기지에는�자료들이�들어있는것만큼�자료들을�리용하는�여러가지�정보처리들을

진행할수�있다.�

�

마당

레코드

�

자료기지에�기초하여�무엇을�할수�있는가?�

�

생각하기 



�

�

113

정보산업시대인�오늘의�시대에는�일반적인�사무처리는�물론�과학연구사업,�생산조

종,�군사지휘�등�모든�사업들을�콤퓨터로�진행하기때문에�자료기지를�구축하여�리용하

는�문제는�필수적으로�제기되는�문제이다.�

�

2. 《자료기지》의 기동과 기본화면 

《자료기지》를�기동하려면��

《시작》→《응용프로그람》→《종합사무처리》→《자료기지》 

를�실행한다.�즉��

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

혹은�탁상면에�자료기지그림기호가�배치되여있는�경우�그�그림기호를�두번찰칵하여�

펼칠수�있다.�

《자료기지》를�기동시키면�처음에�다음과�같은�《자료기지조수》대화칸이�펼쳐진다.�
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�

�

�

�

�

�

�

�

�

�

�

�

�

이�대화칸에서는�자료기지들에�대한�선택을�진행한다.�

실례로�새�자료기지를�만들기�위해서는�《새�자료기지�만들기(E)》를�선택한다.�

만일�이미�있는�자료기지를�열기�위해서는�《기존�자료기지파일열기(F)》를�선택한�

다음�《최근�사용(A)》칸에서�해당�파일을�선택하면�된다.�

한편�《자료기지》체계에�이미�준비되여있는�형식으로�자료기지를�작성하려고�할�때

에는�《기존�자료기지에�련결(X)》을�선택한다.�

다음�《끝내기(F)》단추를�찰칵하거나�자료기지를�보관한�후에�진행방법을�결정하기�

위해서�《다음(N)>>》단추를�찰칵한다.��

그러면�다음의�그림과�같이�두번째�단계로�넘어간다.��

�

�

�

�

�

�

�

�

�

�

�

�

�

�
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다음�《끝내기(F)》단추를�찰칵한다.�

그러면�자료기지이름을�보관하기�위한�《다른�이름으로�보관》대화칸이�나타난다.��

�

�

�

�

�

�

�

�

�

�

�

�

�

이�대화칸의�《파일이름(N)》칸에�파일이름�실례로�《우리�학급�자료기지》라고�입

력하고�보관장소를�설정해준다.�

다음�《보관(S)》단추를�찰칵하면�자료기지를�작성할�자료기지의�기본창문이�펼쳐

진다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

제목띠�차림표띠�도구띠

객체목록칸�

작업선택칸�

표목록칸

설명칸�
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기본창문에는�《글》,�《표》�등�다른�응용프로그람들과�마찬가지로�제목띠,�차림표

띠,�도구띠가�있으며�왼쪽에�객체목록칸이�있다.�

이�목록칸에는�자료기지에서�작성하고�리용하게�되는�기본형태들인�표,�질문,�양식,�

보고서항목들이�있으며�표준적으로�표항목이�설정되여있다.�

그리고�작업항목을�선택하는�목록칸과�그에�대한�설명이�표시되는�부분,�작성된�자

료기지들이�현시되는�목록칸이�있다.�

《자료기지》의�모든�작업은�이�창문에서부터�시작된다.�

�

�

제 2절. 자료기지만들기 

1. 우리 학급 자료기지 

�

�

�

�

�

�

�

�

�

우선�학급명단이�있어야�하며�지난�기간의�성적표들이�있어야�할것이다.�그리고�학

급의�조직구성이라든가�출석정형,�꼬마계획수행기록부�등�여러가지�자료들도�있게�될것

이다.�

이러한�자료들을�다�모아놓는다면�바로�그것이�자료기지,�우리�학급의�자료기지로�

된다.�

일반적으로�자료기지라고�하면�관계형자료기지를�두고�말하기때문에�그�형식은�표

로�고정된다.�

물론�생활속에는�본문형식의�자료들도�있지만�자료관리를�목적으로�하는�자료들은

서로�관계되는�마당들을�가지고�표형식을�이루게�되는것이다.�

따라서�《자료기지》프로그람에서�자료기지를�구축하는�방법도�보통�표형식을�취하

게�된다.�

모든�자료기지는�표들의�모임으로�이루어진다고�할수�있다.�

그러면�실지�우리�학급�자료기지를�만드는�과정을�통하여�자료기지작성방법을�보기

로�하자.�

�

우리�학급관리에�관한�사무처리를�콤퓨터로�진행한다고�하면�어떤

자료들이�필요하겠는가?�

생각하기 
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1) 《학급명단》만들기 

《학급명단》이�다음과�같은�마당들로�구성되여있다고�하자.�

�

�

�

�

�

�

�

�

�

�

�

�

�

①�자료기지기본창문의�객체목록칸에서��������를�선택한다.��

�

�

�

그림�2-5�새로운�표�만들기��

�

그러면�표설계창문이�펼쳐진다.�

�

�

�

�

�

�

�

�

�

�

②�새로운�표를�작성하기�위해�《설계보기에서�표만들기(G)》를�두번찰칵한다.�

그러면�표에서�리용하게�되는�구체적인�항목들�즉�마당들의�이름과�자료형,�크기�

등을�결정하기�위한�창문이�나타난다.�

마당이름 자료형 

번호 수값형 

이름 문자렬형 

성별 문자렬형 

난날 날자형 

집주소 문자렬형 

전화번호 문자렬형 
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�

③�《마당이름》렬에�《번호》라고�입력하고�《마당류형》칸에서�마우스(혹은�건반

에서�Tab)를�찰칵한다.�

그러면�보통�문자렬(본문[VARCHAR])형이�표시된다.�

《번호》는�일반적으로�본문자료가�아니라�수값자료이므로�� 를�찰칵

하고�《번호》마당을�《옹근수[INTEGER]》로�선택한다.��

④�Tab건을�눌러�설명입력칸으로�유표를�이동시킨다.�이�칸에는�해당�마당에�대한

설명을�써넣을수�있는데�명백한�경우에는�설명을�주지�않아도�된다.�

⑤�Enter건을�눌러�다음행으로�이동하여�우와�같은�방법으로�《이름》,�《성별》,

《난날》,�《집주소》,�《전화번호》마당들을�입력한다.�

이때�매�마당을�정의할�때�자료형과�길이를�정확히�주는것을�잊지�말아야�한다.�

가령�《난날》마당을�정의할�때�자료형식에서�《날자［DATE］》를�선택하고�《서식

실례》에서�주체년호를�설정할수�있다.�

�

또�《전화번호》마당은�수값이기는�하지만�계산하는�수가�아니고�《‐》와�같은�기

호와�함께�쓰이기때문에�본문형으로�정의하여야�한다.�
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《자료기지》에서 리용할수 있는 자료형 

①�본문형(VARCHAR)�

일반�문자렬자료들과�주소와�같이�문자렬과�수자를�조합한것�또는�전화번호,

우편번호�등과�같이�계산에�사용되지�않는�수자도�본문형으로�취급한다.�

본문형은�표준적으로�50문자까지�취급할수�있으며�사용자정의로�변화시킬수�있다.�

마당에�입력된�문자만�보관되고�문자렬마당에서�자리를�차지하지�않는�공백

문자는�제외된다.�

②�옹근수형(INTEGER)�

크지�않은�일반적인�옹근수들을�표시할수�있다.�

수값은�표준적으로�10자리까지�표시할수�있으며�사용자정의로�변화시킬수�있다.

이�형의�특징은�자동값으로�취급할수�있는것이다.�

자동값으로�설정되면�번호와�같은�마당에서�자동적으로�수값이�증가되여�표시된다.�

③�수값형(NUMERIC)�

화페기호계산(화페형식사용)을�제외한�산수계산을�할수�있는�수값자료는�수값형으

로�취급한다.��

마당크기는�표준적으로�10으로�되여있으며�구체적으로�수값형을�정의하려면�크기

를�입력하여�변화시킬수�있다.�

또한�소수점아래�자리수도�지정할수�있다.�

④�날자형(DATE)�

날자를�보관하는�자료형이다.�형식은�YYYY-MM-DD이다.��

《서식�실례》항목에서�참고단추� 를�찰칵하여�입력서식형식을�선택할수�있다.

⑤�시간형(TIME)�

시간을�표현할�때�리용한다.�

시간형도�날자형과�마찬가지로�《서식�실례》항목의�참고단추� 를�찰칵하여

형식을�선택할수�있다.��

⑥�예/아니형(BOOLEAN)�

Yes/No(예/아니),�True/False(참/거짓),�On/Off(설정/해제)�등과�같이

두�값중에�어느�하나만�가지는�경우에�취급하는�자료형이다.��

⑦�화상형(LONGVERBINARY)�

그림자료를�표시하는데�리용하는�자료형이다.�

길이값은�다른�형에�비하여�매우�큰�바이트수를�가진다.�

이밖에도�《자료기지》에서는�21개의�자료형들을�리용할수�있다. 

알아두기 
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⑥�표작성이�끝나면�보관그림기호� 를�찰칵하여�나타나는�대화칸에서�이름을�입

력한다.��

실례로�《학급명단》이라고�입력하고�《확인》단추를�찰칵하여�보관한다.�

�

�

�

��

�

�

�

⑦�기본열쇠(Primary�key)를�설정하지�않았으면�설정하겠는가를�묻는�대화칸이�나

타난다.�

�

�

�

�

�

�

�

�

�

�

�

새로�작성한�표를�보관할�때�기본열쇠를�작성하지�않았다면�기본열쇠를�지정하겠는

가를�묻는�통보가�나타난다.�이때�《예(Y)》단추를�찰칵하면�자동번호형식의�기본열쇠

가�설정된다.�

기본열쇠는�표에�있는�매개�레코드(매�학생의�자료)를�고유하게�정의하는�마당을�

말한다.�

실례로�표에�25명의�학생자료가�있을�때�25명의�매�학생들을�고유하게�갈라볼수�

있는�마당을�기본열쇠마당으로�설정한다.�

가령�우의�실례에서�《이름》마당을�본다면�같은�이름이�있을수�있고�《성별》,�《집

주소》도�같을수가�있다.�

결국�매�학생들의�자료들을�유일하게�갈라볼수�있는�마당은�《번호》마당이나�《전

화번호》�등이�될수�있다.��

일단�표의�기본열쇠를�지정하면�기본열쇠를�고유하게�하기�위해�기본열쇠마당에�입력되

는�값이�중복되거나�Null인�값은�입력할수�없게�된다.�

⑧�《예(Y)》단추를�찰칵하고�《번호》마당을�기본열쇠로�설정한다.�
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이를�위해서�《번호》마당앞에서�오른쪽찰칵하여�나타나는�지름차림표에서�《기본열

쇠(B)》지령을�실행한다.��

�

�

�

�

�

�

�

�

�

�

�

�

�

�

그러면� 표식이�나타나는데�이것은�《번호》마당에�기본열쇠가�설정되였다는것을

나타낸다.�

표설계창문을�닫고�자료기지창문에서�표를�선택하면�그림과�같이�표목록칸에�《학급

명단》표가�나타나있는것을�볼수�있다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�
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이�창문에서�《학급명단》표를�두번찰칵하면�다음과�같은�창문이�나타난다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

여기에�마당에�해당하는�자료를�입력하면�《학급명단》표가�완성된다.�

자료는�마당을�정의할�때�기준한�특성에�따라�해당�자료형과�길이에�맞게�입력하여

야�한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

이렇게�되면�자료표(《학급명단》)�한개를�가지는�간단한�자료기지파일이�작성되였

다고�할수�있다.�

2) 《성적표》와 《조직구성》만들기 

우에서�《학급명단》표를�작성한데�기초하여�그림과�같이�《성적표》와�《조직구성》

표를�만든다.�

전화번호

331�
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(주의할것은�표설계창문에서�마당을�정의할�때�성적마당들의�자료형은�소수점아래

값을�참고하여�실수형(REAL)으로�설정한다.)�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

이렇게�되면�《학급명단》,�《성적표》,�《조직구성》의�자료들을�포함하는�간단한�우

리�학급�자료기지가�완성된다.�
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2. 간단한 자료관리방법 

자료를�관리한다는것은�사용자의�요구에�맞게�자료들을�어떤�기준에�따라�정렬하여

놓거나�어떤�기준에�해당한것들만�골라내거나�혹은�필요없는�자료들을�없애기,�새로운�

자료들의�추가�등을�진행한다는것이다.�

《자료기지》에서는�이러한�작업들을�아주�쉽게�진행할수�있다.�

우선�입력된�자료들의�서체변경,�렬폭과�행폭의�조절�등의�편집기능을�실현할수�있

으며�또한�다른�프로그람에서�만든�화상들의�파일도�레코드에�삽입할수�있다.�

1) 렬폭의 변경 

자료표에서�렬폭은�표준적인�크기로�주어지므로�마당이름이�길거나�마당에�입력될

자료의�내용이�길면�렬의�폭을�넓히거나�입력될�자료의�크기에�맞게�맞추어야�한다.�

실례로�우에서�작성한�표에서�《집주소》마당을�다�표시하기�위해서는�《집주소》마

당과�《전화번호》마당의�경계선에�마우스지시자를�가져간다.��

그러면�지시자의�모양이�쌍방향화살모양으로�바뀌는데�이�상태에서�오른쪽,�왼쪽으

로�끌기하면�렬의�폭이�변경된다.��

마당에�입력된�자료의�크기에�꼭�맞추어�렬의�폭을�조절하기�위해서는�마당과�마당

사이의�경계에서�두번찰칵한다.�그러면�입력된�자료나�마당이름의�크기에�맞게�폭이�자

동적으로�조절된다.�

2) 렬의 숨기기 

렬(마당)의�수가�많아서�한개�페지너비를�벗어나는�경우�일부�마당들이�나타나지�

않게�할수도�있다.�

《성별》마당을�숨기자면�《성별》마당이름에서�오른쪽찰칵하여�나타나는�지름차림

표에서�《렬숨기기(H)》지령을�실행한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�
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그러면�선택한�렬�즉�《성별》마당이�보이지�않게�된다.�

숨긴�렬을�다시�보기�위해서는�렬머리부�즉�마당이름에서�오른쪽찰칵하여�나타나는

�지름차림표에서�《렬보이기(S)》지령을�실행하면�된다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

3) 자료의 정렬 

자료관리에서�가장�우수한�기능은�자료들의�정렬기능이라고�할수�있다.�

무질서하게�입력된�자료들을�크기순서�혹은�자모순서로�단번에�정렬하는것은�종이

매체에서는�생각할수�없는�매우�효과적인�기능이다.�

자료정렬은�임의로�입력된�자료들을�레코드별로�일정한�조건에�따라�순서대로�정리

하는�기능이다.��

실례로�자료들을�자모순서,�나이순서,�수값의�크기순서�등�여러가지�방식으로�정돈

할수�있다.�

《이름》마당을�자모순서대로�정렬하기�위해서는�다음과�같이�한다.�

①�《이름》마당을�선택한다.�

②�도구띠에서� (내림순서)를�찰칵한다.�

그러면�《이름》마당이�내림순서로�정렬된다.�

결과는�그림과�같이�된다.�

331
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�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

《이름》마당을�오름순서로�정렬하기�위해서�도구띠에서� 단추를�찰칵하면�다음과�

같이�《이름》마당이�오름순서로�정렬된다.�

�

�

�

�

�

�

�

�

�

�

�

4) 자료의 려과 

《자료기지》는�필요한�자료들만을�골라내는�려과기능도�있다.�

려과는�표에서�어떤�조건에�해당하는�자료만을�추출하여�표시하는�기능을�말한다.�

《자료기지》에서�려과기능은�마당별로�실현된다.�

자동려과는�표에서�임의의�마당의�임의의�값을�선택하면�그�값을�가지는�모든�레

331
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코드들이�추출되여�표시되는�기능이다.�

먼저�자동려과기능을�리용하여�자료의�려과를�진행하는�방법을�보기로�하자.�

실례로�《학급명단》에서�녀학생들의�자료만을�보기�위해서는�다음과�같이�한다.�

①�《성별》마당에서�《녀자》라는�값이�입력되여있는�임의의�곳을�찰칵한다.�

②�도구띠에서�자동려과기그림기호�����를�찰칵한다.�

그러면�그림과�같이�녀학생들의�레코드들만이�추출되여�표시된다.�

�

려과한�결과를�원래의�상태�즉�려과하기�전의�모든�레코드목록을�보기�위해서는�

도구띠에서� 을�찰칵하면�된다.�

자동려과가�단지�하나의�선택마당을�려과기준으로�삼는다면�표준려과는�여러개

의�마당을�기준으로�하여�필요한�레코드들을�뽑아낸다.�

실례로�《학급명단》에서�남학생이면서�집주소가�모란봉구역의�개선동인�학생들만

을�표시하기�위해서는�다음과�같이�한다.�

①�《성별》마당에서�임의의�한곳을�찰칵한다.�

②�도구띠에서�표준려과기그림기호� 를�찰칵한다.��

�

�

�

�

�

�

�

�

�

�

�

�

�

자동려과기�

표준려과기�
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그러면�《표준려과기》대화칸이�나타난다.�

③�《마당이름》목록칸에서�《성별》마당을�선택하고�《조건》목록칸에서�《=》

를�선택한다.�

④�《값》입력칸에는�《남자》라고�입력한다.�

⑤�《연산자》지정칸에서�AND를�선택하고�같은�방법으로�《집주소》마당의�《모

란봉구역�개선동》을�지정�및�입력한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

⑥�《확인》단추를�찰칵한다.�

그러면�다음과�같이�자료가�려과되여�조건에�맞는�학생들만이�나타난다.��

�

련습문제 

1.�번호,�이름,�성별,�난날,�집주소,�전화번호,�취미의�항목을�가지는�《소년반명단》자

료기지를�작성하여라.�

2. 소년반학생들의�번호,�이름,�혁명력사,�수학,�외국어,�물리의�항목을�가지는�《1학

기성적》자료기지를�만들고�새로운�레코드를�추가하거나�삭제,�변경하여보아라.�

3. 《성적표》에서�녀학생이면서�콤퓨터성적이�5점인�학생들만을�표시하여라.�

4. 《성적표》에서�혁명력사와�콤퓨터성적이�높은�순서대로�정렬하여라.�

탐 구 

《연산자》지정칸에는�AND외에�또�어떤�연산자들이�있는가?�그�연산자들

을�사용해보아라.�
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제4장. 2차원화상처리 

제1절. 화상편집의 기초 

1. 화상편집의 일반적개념 

1) 색에 대한 개념 

색은�물체가�내보내는�빛의�성질로서�빛의�파장에�따라�여러가지�색으로�구별된다.�

물리학에서는�흰색빛이�붉은색,�풀색,�하늘색빛의�합성으로�이루어진다는것을�증명

하였다.��

색에는�붉은색,�풀색,�푸른색밖에도�여러가지�색이�있으며�같은�색이라고�하여도

진한것과�연한것이�있고�같은�색의�물체도�밝은데서와�어두운데서�볼�때에�색느낌이�다

르다는것을�알수�있다.�또한�밝게�느껴지는�색도�있으며�물체를�보는�각도에�따라서도

색느낌이�달라진다.�이것은�색이�3가지�성질�즉�색상,�색포화도,�색밝기를�가지고있기

때문이다.�

�

�

�

�

�

�

�

�

�

∙�색상(Hue)�

색상은�붉은색,�노란색,�풀색,�푸른색과�같은�색의�상태,�색의�종류로�특징지어지

는�색의�성질이다.��

색상은�파장에�따라�변하는데�일정한�파장간격을�가진다.�색상은�색을�표시하는�가

장�중요한�성질로서�색느낌의�기본이라고�할수�있다.�

∙ 포화도(Saturation)�

같은�색상을�가진�색이라고�하더라도�연한것과�진한것으로�갈라볼수�있다.�포화도

는�색의�농도�또는�밝음도를�나타내는�색의�성질이다.�

색의�포화도는�백분률(％)로�표시한다.�흰색이�전혀�섞이지�않은�순수한�색의�포화

색의 3요소 

포화도 밝기�색상�
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도를�100％로�한다.�흰색을�많이�섞을수록�색이�연해진다.�모든�색은�포화도가�0％로

되면�흰색으로�된다.�즉�포화도는�흰색이�포함되는�비률이라고�볼수�있다.��

색상과�포화도는�색의�기본성질을�나타내기때문에�이것을�통털어�색도라고도�한다.�

∙�밝기(Brightness)�

밝고�어두운�색느낌의�성질이�밝기이다.�다시말하면�색이�가지고있는�밝기의�느낌

을�말한다.�포화도가�0％이면�모든�색이�흰색으로�되는것과는�반대로�밝기가�0이면�모

든�색은�검은색으로�된다.�

천연색TV방송화면을�흑색TV화면으로�보면�화면에는�색이�나타나지�않지만�여러

가지�색은�밝기에�대응하는�흑백색으로�나타난다.�이것은�바로�색상에�따라�밝기가�서

로�다르다는것을�말한다.�

붉은색,�풀색,�푸른색에�대한�밝기는�풀색,�붉은색,�푸른색의�차례로�된다.�이것은

색상의�차이에�의하여�생기는�밝기의�변화이다.�

색의�밝기는�어떤�색빛의�밝기정도를�표시하며�색도는�색의�균형과�진하고�연한�정

도를�표시한다.�

2) 색의 합성과 3원색 

천연색TV에서는�세가지�색의�빛을�내는�형광체에�의하여�여러가지�색을�얻는다.

이�세가지�색이�색더하기법의�3원색인데�여기에는�붉은색(R),�푸른색(B),�풀색(G)이�속

한다.�이�3원색으로�모든�색을�합성할수�있으며�얻어진�색은�자연색과�별로�차이가�없다.�

색더하기법에�의한�색의�합성을�그림에�주었다.�

그림에서�보는바와�같이�여러가지�색

을�흰�판에�비치고�그것들을�겹치면�새로

운�색이�얻어진다.�이것이�색더하기법이

다.�콤퓨터의�수상관에는�붉은색,�풀색,

푸른색으로�된�작은�점광원조가�30만개이

상�배렬되여있다.�그러므로�이�색들을�원

색으로�하는�RGB모형을�리용하여�점광

원조�한조로�빛을�내는�방법으로�여러가지

색을�표시할수�있다.�

미술가들이�그림을�그릴�때�혹은�인쇄기에서�색을�재

현하는�경우에는�3원색으로�청색(C),�분홍색(M),�노란색

(Y)을�쓰는데�이것을�색덜기법의�2차3원색이라고�한다.�

인쇄색은�반사빛에�대한�사람눈의�감각이기때문에�색덜기

법을�리용한다.�실제응용에서는�이�세가지�색을�혼합하여

구성한�인쇄물의�검은색이�리상적이지�못하기때문에�높은

질의�인쇄에서는�검은색(K)을�하나의�특수한�원색으로�취

급하는�CMYK모형을�리용한다.�
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붉은색과�풀색이�겹칠�때�붉은색이�풀색보다�우세하면�감색이�얻어지고�붉은색보다

풀색이�우세하면�노란색이�얻어진다.�이와�같이�붉은색,�푸른색,�풀색의�비률을�변화시

키면서�배합하면�수많은�색을�얻을수�있다.��

색더하기법에서�3원색을�따로따로�비치면�붉은색,�풀색,�푸른색의�세가지�색이�얻

어지고�3원색을�두가지씩�비치면�노란색,�연풀색,�연청색,�보라색,�감색과�같은�여러가

지�색이�얻어진다.�그리고�3원색을�한꺼번에�비치면서�그�비률을�변화시키면�흰색과�포

화도가�다른�여러가지�색을�얻을수�있다.�

이처럼�합성된�색의�색상,�색포화도,�색밝기는�합성하는�3원색의�비률과�밀접한�관

계를�가진다.�

3) 화상파일의 형식 

먼저�화상의�해상도에�대하여�보기로�하자.�

화상을�이루는�가장�작은�요소는�화소(Pixel)이다.�

화소는�화상에서�색과�어느�위치에�있는�요소인가를�나타내며�화소들이�모여�화상

을�이룬다.�

화상에서�단위길이당�들어있는�화소의�수를�화상의�해상도(Resolution)라고�한다.�

보통�1inch당�몇개의�화소가�들어있는가를�의미하는�ppi(=pixel�per�inch)로�표시

한다.�

높은�해상도를�가지는�화상에는�낮은�해상도를�가지는�화상보다�더�많은�화소가�들

어있다.�

실례로�72ppi해상도를�가지는�단위크기(1inch×1inch)의�화상에는�총�5�184(=72�

×72)개의�화소가�들어있는데�300ppi의�해상도를�가지는�단위크기화상에는�총�90�000

개의�화소가�들어있다.�

높은�해상도의�화상은�단위구역을�표시하는데�더�많은�화소가�사용되기때문에�인쇄

하면�낮은�해상도의�화상보다�더�섬세하게�화상을�표시할수�있다.�

일단�어떤�해상도값으로�화상을�만들었거나�콤퓨터에�화상입력한�경우에는�《환상》

과�같은�화상편집기로�가공하여�해상도를�올려�출력한다고�해도�화소수만�많아질뿐�화

상의�질은�개선되지�않는다.�

해상도가�너무�낮으면�인쇄하는�경우�매우�거칠어보이며�반대로�너무�높은�해상도

를�사용하면�필요없이�파일크기가�늘어나�화상을�인쇄하거나�배포하는데�시간이�걸린다.�

인쇄기해상도는�인쇄기가�만들어내는�단위길이당�점의�개수이다.��

인쇄기해상도는�대체로�1inch당�몇개의�점을�만드는가를�의미하는�dpi(=dot�per�

inch)로�표시한다.�

레이자인쇄기는�대부분�300~600dpi출력해상도를�가진다.�

화상을�인쇄하는�경우에는�72~150ppi에서�좋은�결과가�출력된다.�

다음은�화상의�파일형식에�대하여�보기로�하자.�

파일형식은�화상파일을�보관할�때�리용하는�방식을�말하는데�표시는�확장자로�한다.�

화상편집프로그람에는�《환상》,�Adobe�Photoshop�등�여러가지가�있는데�매개�프

로그람마다�거기에서�리용할수�있는�파일형식이�규정되여있다.�
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∙�XCF�

《환상》에서�파일의�기본형식은�XCF이다.��

이�형식은�《환상》에서�화상처리에�필요한�모든�자료를�보관하기�위해�특별히�설계

되였다.��

확장자는�xcf이다.�

xcf파일은�매�층의�화소자료,�현재�선택,�통로,�경로와�안내선들을�부호화한다.�

xcf파일에서�화소자료는�원래�자료로�압축되지�않은�형태로�표시된다.�

화상자료의�매�byte는�.xcf파일의�매�byte와�같다.�따라서�적당한�크기의�화상에�

관한�xcf파일조차도�매우�커질수�있다.�

실례로�3개의�층을�가진�1000×1000�RGB화상은�10MB이상의�XCF파일을�만들게�

된다.�

비록�XCF파일들이�본래�자기�자료를�압축하지�않는다�해도�《환상》은�gzip나�

bzip2압축방법을�리용하여�파일들을�직접�압축할수�있게�해준다.�

∙�BMP�

이�파일형식은�Microsoft�Windows에서�제공하는�파일의�표준형식이다.�

이�파일은�1bit부터�24bit까지의�색을�지원한다.�확장자는�bmp이다.�

BMP는�Bitmap의�략자이다.�

∙�JPEG�

JPEG(Joint�Photographic�Expert�Group)는�24bit까지의�색을�표현할수�있기때

문에�사진화상에�많이�쓰인다.�

이�파일형식은�화상의�압축파일형식으로서�화상을�매우�효과적으로�압축하며�화상

질의�손실을�최소로�하려�할�때�리용하는�압축파일형식이다.�확장자는�jpg이다.�

JPEG압축은�화상압축을�진행할�때�손실이�있으므로�압축률을�지내�높이면�화상질

을�크게�떨굴수�있다.�

JPEG파일은�RGB색방식과�CMYK색방식을�둘다�지원하는�파일형식이다.�

��

2. 화상편집프로그람 

콤퓨터로�화상을�가공하거나�합성�등의�처리를�진행하려면�콤퓨터화상처리를�전문

으로�하는�프로그람도구들이�있어야�한다.�

화상편집프로그람에는�《환상》,�Adobe�Photoshop,�Adobe�Illustrator�등이�있다.�

∙�《환상》�

우리�식�조작체계�《붉은별》에서�동작하는�화상처리프로그람이다.�

《환상》은�많은�기능들을�가지고있다.�

간단한�그리기프로그람,�전문가급의�화상수정프로그람,�직결식다중처리체계,�다량

의�화상묘사도구�생성,�화상의�형식을�변환하는데�사용될수�있다.�
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《환상》은�삽입프로그람들로�무엇이든지�확장할수�있게�설계되였다.�

《환상》의�우점들가운데�하나는�여러�조작체계들에�따르는�많은�자원들을�쉽게�쓸

수�있다는�점이다.�

《환상》은�현재�가능한�화상조작을�폭넓게�지원해준다.�

∙�Adobe�Photoshop�

Adobe�Photoshop는�화상제작�및�편집도구로서�인쇄물이나�웨브설계를�위한�강력

한�화상편집도구를�제공한다.��

웨브를�비롯한�매우�넓은�파일형식을�지원하며�다양한�려과기를�제공하여�매체에�

관계없이�안전하게�작업할수�있다.�

∙�Adobe�Illustrator�

Adobe�Illustrator는�높은�편집기능과�본문처리기능,�포괄적인�색을�지원해주며

쉽고�간편하게�요구하는�그림을�만들거나�수정할수�있게�한다.�

�

여기서는�대표적으로�《환상》에�대하여�보기로�한다.�

1) 《환상》의 기동과 창문구성 

《환상》을�기동하려면�탁상면에서�������을�두번찰칵하거나�《시작》차림표에서�다

음과�같이�지령을�실행한다.�

《시작》→《응용프로그람》→《화상 및 도형》→《환상》 

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

《환상》을�기동하면�다음과�같은�창문이�펼쳐진다.�
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①�기본도구창문:�《환상》에서�작업을�진행하기�위한�여러가지�도구들이�들어

있다.�

②�도구선택항목칸:�기본도구창문에서�도구들을�선택했을�때�그�도구에�따르는�보

조선택항목들이�들어있다.�

③�층조작판:�여기에서는�현재�활성화된�화상의�층구조를�보여주며�여러�방법으로�

조작할수�있게�한다.�

④�붓조작판:�여기에서는�붓,�무늬,�경사도�및�조색판들을�설정한다.�

여기서�층조작판과�붓조작판을�필요에�따라�사용자가�나타나게�혹은�나타나지�않게�

할수�있다.�

2) 파일열기와 보관 

-�새로운�화상창문의�열기�

①�새로운�화상파일을�만들기�위하여서는�기본도구창문에서�《파일》→《새로�작성》

지령을�실행하거나�Ctrl+N건을�누른다.�

④

①�

③

�

②�
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그러면�다음의�《새로�작성》대화칸이�나타난다.��
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②�대화칸의�《견본(T)》,�《화상크기》,�《추가선택항목(A)》을�리용하여�각종�선

택을�진행한다.�

《견본(T)》의�오른쪽에�있는� 를�찰칵하고�해당�용지크기를�선택할수�있다.��
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�

�
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�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

《화상크기》에서는�새�화상의�너비와�높이를�설정한다.�표준적인�단위는�화소이지

만�다른�단위를�선택할수도�있다.�

,� 단추들은�화상이�세로방향인가,�가로방향인가를�선택한다.�

오른쪽에�화상크기와�색방식이�표시된다.�

해상도,�색상�등을�설정하기�위해서는�《추가선택항목(A)》의�왼쪽옆에�있는� 단

추를�찰칵한다.��

그러면�추가적으로�선택할수�있는�항목들이�나타난다.�

여기서�X와�Y해상도는�인쇄에�필요한�값들이다.�

이것들은�화상의�크기에는�영향을�주지�않지만�인쇄할�때�종이우에서의�그것들의

크기를�결정한다.��

《색상공간》에서는�RGB색�혹은�흑백색화상으로�색상을�설정한다.�

《채우기(F)》에서는�화상의�배경층에�채색하려는�색에�대해�4가지�설정을�제공한다.�
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�

�
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�

�

�

�

�

�

�

�

�

�

③�《새로�작성》대화칸에서�속성값들을�선정한�다음�《확인(O)》단추를�찰칵한다.�

그러면�새�화상창문이�펼쳐진다.�

�

-�파일의�열기�

《환상》에서�여러가지�방법으로�화상을�열수�있다.�
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①�기본도구창문이나�화상창문에서�《파일》→《열기》지령을�실행하거나�또는�

Ctrl+O건을�누른다.(최근에�창조한�화상을�열자면�《최근�파일�열기》지령을�실행하면�

된다.)�

�

�

�

�

�

�

�

�

�

�

�

�

�

그러면�《열기》대화칸이�펼쳐진다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

②�해당�파일이름을�선택하고�《열기(O)》단추를�찰칵한다.�

기본도구창문 
화상창문�
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�

�

�

�

�

-�파일의�보관�

작성한�화상파일을�보관하기�위해서는�다음과�같이�한다.�

①�《파일》→《보관》지령을�실행하거나�Ctrl+S건을�누른다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

파일형태선택 

�

파일열기가�실패하는�경우�《열기》대화칸의�《파일류형》의�왼쪽에�있는�

을�찰칵하여�나타나는�목록에서�파일형태를�선택할수�있다.��

알아두기 
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그러면�《보관》대화칸이�펼쳐진다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

②�《이름(N)》칸에�이름을�입력하고�《다른�서류철의�열람(B)》에서�화상파일을�보

관하려는�서류철을�선택한다.��

③�《파일�류형�(확장자로)(T)》의�왼쪽에�있는� 을�찰칵하여�확장자를�설정한다.�

④�《보관(S)》단추를�찰칵한다.�

�

�

련습문제 

�

1.�RGB방식은�어떤�방식인가?�

2.�CMYK방식의�기본조성을�이루는�색은�어떤�색이며�이�색들을�조합하여�여러가지�색

을�만들어보아라.�

3. 화상의�해상도란�무엇인가? 

4.�화상의�파일형식에는�어떤�형식들이�있는가?�

�

�

�

�

�

�

�

�
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제2절. 기본도구창문과 화상창문 

1. 기본도구창문 

《환상》의�기본도구창문은�차림표,�도구칸,�도구선택항목칸으로�이루어졌다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

1) 차림표 

①�파일(F)�

-�새로�작성(N)�

새�창문을�열기�위해�실행한다.�

-�열기(O)�

파일열기지령이다.�

-�최근�파일�열기(R)�

최근에� 작업한� 화상들을� 쉽게� 꺼낼수� 있게�

한다.�

차림표

도구칸�

도구선택
항목칸�
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-�얻기(A)�

화면의�전체�화상을�얻기�위해서�리용한다.�

-�기본설정(P)�

《환상》의�모양,�느낌,�실행에�영향을�주는�여러가지�설정들을�변경할수�있다.�

기본설정정보들은�개인용서류철의�원천파일에�저장되므로�숙련된�사용자들인�경우

도형대면부적인�방법으로가�아니라�본문편집기를�리용하여�편집을�진행할수�있다.�

-�대화창문(D)�

무늬,�조색판,�붓과�같이�화상편집시�리용할수�있는�대화칸들을�필요에�따라�열거

나�닫을수�있으며�그냥�둘수도�있다.�

-�끝내기(Q)�

《환상》을�끝내기한다.��

②�확장(X)�

-�모듈관리기(M)�

모듈관리기는�필요에�따라서�적재할�모듈을�관리하는�도구이다.�

-�단위편집기(U)�

단위편집기는�이�프로그람에서�쓰이는�각종�단위들에�대한�편집을�진행하는�도

구이다.��

《새로�작성》단추를�찰칵하면�《새�단위》대화칸이�나타나는데�이때�나타나는�속성

칸에�항목들을�입력하고�《확인(O)》단추를�찰칵한다.�그러면�새로운�단위가�추가

된다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�



�

�

143

2) 도구칸 

도구칸에는�선택도구,�따내기도구�등�여러가지�종류의�도구들이�있으며�색상령역과

표시기령역이�있다.�

도구들은�쓰이는�용도에�따라�선택도구,�그리기도구,�변형도구,�기타�도구로�분류

할수�있다.�

(1) 선택도구 

화상창문에서�범위를�선택하려고�할�때�선택도구들을�리용한다.�

선택도구에는�직4각형선택도구,�타원형선택도구,�자유선택도구,�모호선택도구,�색

상선택도구,�모양선택(가위)도구가�있다.��

경로도구도�선택도구로�생각할수�있다.�그것은�어떤�닫긴�경로가�선택으로�절환될

수�있기때문이다.�

-�직4각형선택도구������

화상창문에서�직4각형령역을�선택하려고�할�때�이�도구를�리용한다.(이�도구는�화

상우에서�직4각형도�생성한다.)�

《도구》→《선택도구》→《직4각형�선택》을�실행하거나�건반에서�R건을�눌러�이�도

구를�선택할수도�있다.�

이�도구를�찰칵하면�화상창문에서�마우스지시자형태는�십자(＋)모양으로�된다.��

이�도구를�찰칵하고�화상창문에서�끌기하면�끌기를�시작한�첫�점과�마지막�점을�대

각선으로�하는�직4각형범위가�선택된다.�

만일�먼저�선택을�시작한�후�Ctrl건을�누르면�시작점을�중심으로�하는�직4각형

범위가�선택된다.�

반대로�Ctrl건을�먼저�누르고�선택을�진행하면�선택선이�보이지�않는다.�즉�선

택이�되지�않는다.�

한편�선택을�시작한�후� Shift건을�누르면

서�끌기하면�바른4각형령역이�선택되며� Shift

건을�먼저�누르고�선택을�진행하면�선택한�범위

가�나타난다.�

그리고�먼저�선택을�시작한�후�Ctrl＋Shift

건을�누르면�시작점을�중심으로�하는�바른4각

형령역이�선택된다.�반대로�Ctrl＋Shift건을

먼저�누르면�선택이�되지�않는다.�

선택을�취소하려면�선택구역밖에서�찰칵한다.�

도구선택항목칸에서�선택된�도구들의�속성에�대하여�볼수�있으며�사용자의�의도에

맞게�속성들을�설정할수�있다.�

직4각형선택도구를�찰칵하였을�때�도구선택항목칸에는�다음과�같은�방식과�항목들

이�나타난다.�

(현재�선택�바꾸기방식):�새�선택령역이�창조될�때�이미�존재하는�선택을�제거

하거나�교체하게�한다.�
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  (현재�선택에�더하기방식): 새�선택령역을�임의의�존재하는�선택령역에�추가

하게�한다.(Shift건을�눌러�추가방식으로�들어갈수�있다.)�

�

�

�

�

�

�

�

�

�

�

���(현재�선택에서�제거방식):�이미�존재하는�선택령역에서�새�선택령역을�제거한다.�

�

�

�

�

�

�

�

�

�

�

�

���(현재�선택과�교차방식):�이미�존재하는�선택령역과�새�선택령역이�겹치는�부분

을�새�선택령역으로�만든다.(Ctrl+Shift건을�눌러�교차방식을�선택할수도�있다.)�

�

�

�

�

�

�

�

�

�

�

부드러운�경계:�선택경계를�더�미끈하고�부드럽게�한다.�

부드러운�테두리:�직4각형선택에서�네�모서리를�둥그렇게�해준다.�
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조종띠를�가지고�선택령역의�모양을�변화시킬수�있다.�

자동줄임선택:�화상층우에서�선택을�할�때�화상부

분을�포함하는�가장�작은�직4각형령역을�자동적으로�수

축시켜�선택한다.�

크기제약조건에는�《자유롭게�선택》,�《고정된�크기》,

《고정된�가로세로비》가�있다.�

자유롭게�선택:�선택의�제한을�받지�않는다.�

고정된�크기:�너비,�높이�등의�값을�입력하여�선택한�

크기만큼�고정시킬수�있다.�

고정된� 가로세로비:� 입력한� 너비와� 높이값에� 의하여�

고정된�비률로�선택모양을�고정한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

선택따라그리기 

선택부분을�따라�그리기할수도�있다.�

실례로�직 4각형을�그리기�위해서는�다음과�같이�한다.�

①�화상창문을�열고�직 4각형선택도구로�4 각형모양을�선택한다.�

②�《편집》→《선택따라그리기》지령을�실행한다.�그러면�《선택�따라그

리기》대화칸이�펼쳐진다.�

�

�

알아두기 
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�

�

�

�

③�대화칸에서�선분의�너비,�선분형태�등�속성값들을�사용자의�의도에�맞게�

설정한�다음�《따라그리기(S)》단추를�찰칵한다.�

�

 

실선으로 선택따라그리기 
�

�

아래의�그림은�선택따라그리기대화칸에서�속성값들을�변경시키면서�선택따

라그리기를�한것이다.�

�

 

무늬로선택따라그리기 
그리기도구로 

선택따라그리기 �

�

�

���실선으로�선택따라그리기�

무늬로�선택따라그리기� 그리기도구로�선택따라그리기�
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-�타원형선택도구� �

이�도구는�화상창문에서�원형�또는�타원형령역을�선택하거나�또한�화상우에�원이나�

타원을�그리는데�리용한다.�

�

�

�

�

�

�

�

�

�

�

《도구》→《선택도구》→《타원형�선택》지령을�리용하거나�E건을�눌러�선택할수도�

있다.�

타원형선택도구는�직4각형선택도구와�마찬가지로�Ctrl건을�누르면서�끌기하면�시작

점을�중심으로�하는�타원이�선택되며�Shift건을�누른�상태에서�끌기를�진행하면�원형이�

선택된다.��

또한�Shift건과�Ctrl건을�누르면서�끌기를�진행하면�시작점을�중심으로�하는�원이

선택된다.�

-�자유선택도구� ������

어떤�도형을�선택하는�경우�불규칙적인�모양을�선택해야�할�필요가�있다.�

이�도구는�마우스를�끌기하여�자유롭게�선택을�창조하는�도구이다.�

《도구》→《선택도구》→《자유롭게�선택》지령을�실행하거나�또는�F건을�눌러�

이�도구를�선택할수�있다.�

마우스를�끌기할�때�마우스지시자가�움직인�선과�끌기시작점과�마지막점을�련결

하는�둘러막힌�부분을�선택한다.�

�

�

�

�

�

�

�

�

�

직선으로�

련결된�부분�

시작점�

마감점
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-�모호선택도구� �������

이�도구는�색류사성에�기초하여�현재�층이나�화상의�령역을�선택하기�위한�도구

이다.�

이�선택도구는�《도구》→《선택도구》→《모호선택》지령을�실행하거나�또는�Z

건을�눌러�선택할수�있다.(Z는�마술이라는�zauber를�나타낸다.)�

이�도구를�선택하고�화상에서�임의의�곳을�찰칵하면�그�주위에서�선택된�점의�색과�

같은�계통의�색들이�선택된다.�또한�선택위치에서�마우스를�끌기하면�선택범위는�더�커

진다.�

�

�

모호선택도구는�색경계가�예리한�테두리를�가진�대상을�선택하는데�아주�좋은�도구

이다.�

-�색상선택도구� �

이�도구는�색상공통성에�기초하여�화상령역을�선택하

는�도구이다.�

색상도구는�《도구》→《선택도구》→《색상으로�선

택》지령을�실행하거나�Shift+O건을�눌러�선택할수�

있다.�

이�도구는�모호선택도구처럼�동작한다.�
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색상선택도구는�점의�위치는�무시하고�화상창문에서�선택점과�충분히�비슷한�색을�

가진�모든�점들을�선택한다.��

그러므로�화상에서�찰칵과�끌기는�선택범위에�영향을�주지�않는다.��

색상도구에서�추가적으로�선택할수�있는�항목들은�모호선택도구항목과�같다.�

-�모양선택(가위)도구� ������

모양선택(가위)도구는�테두리에서�강한�색변화로�정의되는�범위를�선택할�때�쓸모

있다.��

모양선택(가위)도구를�리용하기�위하여�선택하려는�범위의�테두리에서�조종점모임

을�창조해야�한다.��

해당한�곳을�찰칵하여�새�조종점을�창조하면서�화상의�테두리를�따라�조종점들을�

만든다.�

끝으로�다시�첫�조종점을�찰칵한�다음�령역안의�임의의�곳을�찰칵하면�선택범위가�

형성된다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

(2) 그리기도구 

《환상》에는�연필,�붓,�지우개,�분무기,�펜,�도장,�초점흐리기,�문지르기,�인화기

등과�같은�그리기도구들이�있다.�

그리기도구들은�화상층뿐만아니라�층마스크,�경로,�선택�등과�같이�다른�형태의�그

리기대상들에서도�작업한다.�

-�연필도구� �

연필도구를�리용하면�연필로�그린것�같은�거친�선이�그려진다.�

연필도구는�《도구》→《그리기도구》→《연필》지령을�실행하거나�건반에서�N건을�눌

러�선택할수�있다.�
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연필도구는�매우�작은�화상을�가지고�작업할

때�그리고�높은�확대축소수준에서�작업하면서

정확한�모든�화소를�얻을�필요가�있을�때�리용

한다.�

이�도구를�찰칵하고�Shift건을�누르면서�끌

기하면�직선이�그려진다.�

연필도구선택항목칸에는� 연필도구의� 속성들

이�표시된다.�

불투명:�그리기에�대한�투명도수준을�설정

한다.�

투명도를�높이�설정하면�더�좋은�불투명채우

기결과를�가져오고�낮게�설정하면�더�좋은�투명

채우기결과를�가져온다.�

아래의�그림은�투명도를�낮게�설정한것과�높

게�설정한것을�보여준다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

방식:�그리기적용방식의�설정을�제공한다.�

붓:�붓그림기호를�찰칵하고�붓모양을�선택한다.�

점차�사라지게�하기:�특정한�거리이후에서는�점차�어두워지는�획을�설정한다.��

획은�설정된�거리에서�투명도가�줄어든다.�

증가방식:�초기�색갈투명도를�초과하지�않는�도구에�대하여�증가색갈방식을�작용시

킨다.�

경사도로부터�색상�사용:�전경색이나�배경색을�대신하여�경사도무늬를�선택하여�

쓸수�있다.��

투명도를 낮게 설정 투명도를 높게 설정 점차 사라지기 
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《반대로》를�선택함으로써�경사도방향을�반대로�할수�있다.��

반복:�톱날파형과�삼각파형이�있다.�

톱날파형은�경사도를�반복적으로�사용한다.��

�

�

�

�

�

삼각파형도�경사도를�반복적으로�사용한다.�설정된�거리의�매�마감에서�경사도는�

방향을�바꾸며�거리의�마감까지�그�방향에서�사용된다.�

�

�

�

�

�

-�붓도구� ������

붓도구는�부드러움이�덜하고�무거운�느낌을�주는�색을�칠하는�도구이다.�

붓도구는�《도구》→《그리기도구》→《붓》지령을�실행하여서도�선택할

수�있다.�

이때�얻어진�색은�화상의�전경색으로�된다.��

붓도구로�직선을�그리기�위해서는�먼저�시작점을�찰칵한다.��

다음�Shift건을�누르면서�마지막점을�찰칵하면�직선이�그려진다.�

또는�Ctrl＋Shift건을�누르고�찰칵하면�15°의�각도로�직선을�그린다.�

완전한�수평,�수직�혹은�대각선을�창조하려면�이�건을�리용한다.�

《환상》은�표준적으로�많은�붓들을�지원한다.�

아래의�그림은�《환상》이�지원하는�각이한�붓모양들을�사용하여�그린�그림을�보여

준다.�
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�

�

�

�

�

�

�

�

�

�

�

�

�

�

또한�사용자의�의도에�맞게�새로운�붓모양을�생성하거나�내리적재할수도�있다.�

《붓》대화칸을�리용하면�정해진�모양외에도�여러가지�모양들을�만들어�리용할수�있

다.�여기에서�붓편집기를�쓰거나�특정한�붓파일형식으로�화상을�보관시켜�원하는�붓모

양을�만들수�있다.�

붓모양을�선택하기�위하여서는�다음과�같이�한다.�

①�《대화창문》→《붓》지령을�실행한다.�그러면�《붓》대화칸이�나타난다.�

�

�

�

��

�

�

�

�

�

�

�

�

�

�

�

�

②�해당한�붓을�선택하고� 단추를�찰칵한다.�그러면�《붓도구�편집기》대화칸이�

나타난다.�
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③�《붓도구�편집기》대화칸에서�붓의�모양,�반경�등을�설정하고� 단추를�찰

칵한다.��

그러면�《붓》대화칸에�그�붓이�첨부되며�이렇게�만든�붓은�후에�다시�수정할수�있다.��

-�지우개� �������

지우개도구는�화상의�필요없는�부분을�지우는�도구이다.�

지우개도구는�《도구》→《그리기도구》→《지우개》지령을�실행하거나�Shift+E건을�

눌러서도�선택한다.�

지우개도구를�선택한�다음�화상우에서�끌기하면�끌기한�령역이�지워지는데�이때�무

조건�흰색으로�지워지는것이�아니다.�

전경색을�검은색으로,�배경색을�흰색으로�하고�지우면�흰색으로�지워지며�전경색을�

흰색으로,�배경색을�검은색으로�바꾸고�지우면�검은색으로�지워진다.�다시말하여�지우

개도구는�배경색으로�칠해주는�도구라고�말할수�있다.�

지우개도구를� 선택하면� 도구선택항목칸에�

지우개의�속성들이�나타난다.�

《불투명》은�지우개도구의�투명도를�결정한

다.�알파통로를�가지고있는�층을�지울�때�《불투

명》값을�더�높이�설정하고�쓰면�더�좋은�투명도

를�얻게�된다.�

《증가방식》과�《뚜렷한�경계》는�붓도구에

서와�같다.��

지우기� 복구:� 지우개도구의� 지우기항목은�

화상의�령역이�완전히�투명하다해도�그것을�지

우지�않는다.�이�특성은�알파통로를�가진�층들

에만�리용될�때�작용한다.��

-�분무기� �������

이�도구는�분무기와�같이�공기를�흡입하여�

잉크를�내뿜는�방식으로�잉크의�립자가�조밀하면서도�부드럽게�뿌려�효과를�내는�도구

이다.�

끌지�않고�마우스단추를�계속�누르고있으면�잉크의�량이�계속�증가되는것과�같

이�진하게�칠해진다.�

《도구》→《그리기도구》→《분무기》지령을�실행하든가�또는�A건을�눌러도�분무

기도구가�선택된다.�

이�도구를�선택하고�Ctrl건을�누르면�분무기를�색상도구로�변화시키며�Shift건을�

누르면서�찰칵하면�직선을�생성한다.�

분무기도구선택칸에서�불투명도값을�높이�설정하면�더�좋은�불투명채우기결과를�가

져오고�낮게�설정하면�더�좋은�투명채우기결과를�가져온다.�
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-�펜도구� �������

펜도구는�여러가지�모양의�펜촉을�가지고�글

을�쓰듯이�그리기를�진행하는�도구이다.��

펜처럼�한점에�머물러있는�시간이�길면�잉크

가�퍼져나가듯�펜모양이�점점�커져나간다.�

펜도구는�《도구》→《그리기도구》→《펜》

지령을�실행하거나�K건을�눌러�선택할수도�있다.�

펜을�사용하기�위하여�펜도구선택항목칸에서

설정값들을�사용자의�의도에�맞게�설정한다.�즉�

펜의�크기를�최소에서�최대로�조종할수�있고�수평

선에�대한�펜의�각도를�조절한다.�

또한�펜의�유효크기를�조종하고�펜의�형

태를�선택할수�있다.�

모양그림기호의�중심에�있는�작은�바른4각형우에서�마우스왼쪽단추를�누르고�움직

이면서�펜촉의�모양을�변화시킬수�있다.�

-�도장도구� ��

도장도구는�화상의�일부분을�복사하여�다른�부분에�자연스럽게�붙이는�도구이다.�

도장도구를�선택한�상태에서�복사령역을�설정하고�끌기하면�해당�화상이�복사된다.�

도장도구는�화상의�일부를�도장과�같이�복사하는�《더하는》기능뿐아니라�주변의

견본을�떼내여�화상의�일부분을�없애치우는�《더는》기능도�가지고있다.�

실례로�견본을�떼여내려는�화상을�복사하려면�우선�도장도구를�찰칵하고�견본을�떼

여내려는�장소에서�Ctrl건을�누르면서�마우스를�끌기한다.�

모양변화조종점
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�

이런�방식으로�원천화상을�복사할�때까지�도장도구로�그리기를�할수�있다.�

도구선태항목칸에서�무늬를�선택하고�찰칵하면�선택된�무늬가�복사된다.��

Ctrl건은�화상으로부터�도장할�때�원천을�선택하는데�리용된다.�무늬로부터�도장을

할�때에는�효과가�없다.�

층이�작용할�때�Ctrl건을�누르고�화상우에서�찰칵하면�임의의�화상�또는�층을�복사

할수�있다.�

-�초점흐리기도구� �����

초점흐리기도구는�화상을�흐리게�하거나�선명하게�하는데�리용된다.�

초점흐리기도구는�매�화소를�가까운�화소들과�혼합시킨다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

-�인화기도구� ��

인화기도구는�현재�화상의�색을�밝게�혹은�어둡게�하는데�리용된다.�

인화기도구의�도구선택항목칸에서�류형을�《인화기》로�선택하면�화상의�색이�밝아

지고�태우기를�선택하면�화상의�색이�어두워진다.�
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�

-�문지르기도구� ����

문지르기도구는�현재�작업층이나�화상에서�선택된�부분을�손으로�문지른것과�같은�효

과를�나타낸다.�표준적으로�문지르기도구는�령역테두리를�유연하게�또는�부드럽게�한다.�

-�령역채우기� �

이�도구를�리용하면�선택한�부분을�전경색으로�채울수�있다.�

《도구》→《그리기도구》→《령역채우기》지령을�실행하거나�Shift＋B건을�눌러�이�

도구를�선택할수�있다.�

령역채우기도구를�선택한�상태에서�Ctrl건을�누르면�배경색과�전경색채우기를�절환

할수�있다.�

또한�Shift건을�누르면�비슷한�색이나�전체�선택령역채우기의�리용을�절환할수�있다.�

-�경사채우기� �

경사채우기도구는�어떤�색이�다른�색으로�서서히�변해지는것과�같은�경사도무늬를�

표현하는�도구이다.�

 (3) 변형도구 

-�이동도구� ���

이동도구는�대화칸이나�층,�화상에서�선택령역을�끌기하여�이동시키는데�리용된다.�

화상창문의�《도구》→《변형도구》→《이동》지령을�실행하여�선택할수도�있다.�

�

�

�

�

�

�

�

�

인화기선택� 태우기선택�

�

�

이동도구를�선택하고�화상창문에서�화상을�선택할�때�마우스지시자가�손모양

으로부터�화살모양으로�변한다.�이때�마우스를�찰칵하면�화상이�선택된다.�

알아두기 
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마우스대신�건반에서�화살건을�리용하여�선택령역을�이동시킬수도�있다.�

도구선택항목칸의�《효과》에서�층변형을�선택하면�요구에�따라�단추를�찰칵하거나�

Shift건을�눌러�선택할수�있다.�

다음�《선택변형》을�선택하면�선택이동을�할수�있다.�

《경로변형》은�이동경로추출과�작용경로를�

이동한다.�

-�따내기도구� ����

이� 도구는� 화상에서� 요구하는� 부분을� 따내는�

도구이다.�

실례를�들어�그림을�따내는�방법을�보기로�하자.�

①�도구칸에서�따내기도구를�선택한다.�

②�따내려는�부분을�선택한다.�

�

�

�

�

�

�

�

�

�

�

그러면�따내기령역이�직4각형모양으로�나타나면서�따내기조종점들과�《따내기》대화

칸이�나타난다.�

③�조종점들을�조종하거나�《따내기》대화칸에서�따내기하려는�시작위치,�너비,�높

이,�가로세로비�등을�설정한다.�

�

�

�

�

�

�

�

�

�

�

�

조종점�

층변형�

경로변형
선택변형�
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④�《따내기》단추를�찰칵한다.�

따내기령역이�잘못선택되였을�경우�《따내기》

대화칸에서�《취소(C)》단추를�찰칵하면�따내기령

역이�해제된다.�

따내기도구선택항목칸에서�《현재�층만》을�선

택하면�현재�작업을�하고있는�층에서만�따내기를�

할수�있다.�

《확대�허용�<Alt>》를�선택하면�화상이나�층

경계밖에서�따내기크기를�허용한다.�

《가로세로비�유지�<옮긴건>》을�선택하면�따

내기를�할�때�너비와�높이사이의�고정된�비률을�유

지한다.�

-�회전도구� ����

회전도구는�화상에서�선택부분과�층을�회전시키는데�리용한다.�

《도구》→《변형도구》→《회전》지령을�실행하여�선택한다.�

실례를�들어보기로�하자.�

①�선택도구를�리용하여�회전시키려는�부분을�선택한다.��

②�기본도구창문에서� 를�찰칵하거나�《도구》→《변형도구》→《회전》지령을�실

행한다.��

그러면�선택령역을�조종할수�있는�조종점들과�《회전》대화칸이�나타난다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

③�《회전》대화칸에서�회전정보�즉�회전각도,�중심�등을�입력한다.�또는�선택령역

의�네개의�조종점들가운데�어느�하나를�돌린다.�

회전조종점�
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�

�

�

④�화상이�사용자의�의도에�맞게�회전하였다면�《회전》대화칸에서�《회전(R)》단

추를�찰칵한다.��

-�척도변경도구� ������

화상의�크기를�변경시키는데�리용한다.�

실례를�들어보기로�하자.�

①�화상을�선택한다.�

②�척도변경도구를�찰칵하거나�《도구》→《변형도구》→《척도변경》지령을�실행한다.�

그러면�《척도변경》대화칸이�나타난다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

③�화상의�네�모서리에�생긴�척도변경조종점들을�조종하거나�대화칸에서�너비,�높

이�또는�가로세로비를�입력한�다음�《배률�조절(S)》단추를�찰칵한다.��

회전조종점
점
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-�잘라내기도구� �

이�도구를�리용하여�선택한�범위를�요구하는�방향으로�기울여�변경할수�있다.�

실례를�들어보기로�하자.�

①�기울이려는�부분을�선택한다.�실례로�전체�그림을�선택하기�위해서는�《선택》→

《전체》지령을�실행하거나�Ctrl+A건을�누른다.�

②�기본도구창문에서�잘라내기도구그림기호를�선택하거나�화상창문에서�《도구》→

《변형도구》→《잘라내기》지령을�실행한다.�

그러면�조종점들과�《잘라내기》대화칸이�나타난다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

③�조종점들을�조절하거나�《잘라내기》대화칸에서�잘라내기크기를�입력해준다.�

척도변경조종점�

잘라내기조종점�
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�

④�《잘라내기(S)》단추를�찰칵한다.�

-�투영도구� ������

전체�화상�혹은�선택한�범위를�일정한�방향으로�투영시키려�할�때�이�도구를�리용

한다.�

실례로�전체�화상을�투영시키기�위해서는�다음과�같이�한다.�

①�화상을�불러들인�다음�《선택》→《전체》지령을�실행하거나�Ctrl+A건을�누른다.�

②�기본도구창문에서�투영도구를�선택하거나�《도구》→《변형도구》→《투영》지령

을�실행한다.�그러면�조종점들과�《투영》대화칸이�나타난다.�

�

�

�

�

�

�

�
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�

�

�

�

�

③�조종점들을�조종하고�사용자의�의도에�맞게�변형되였으면�《변형(T)》단추를�찰

칵한다.�

투영조종점�
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-�뒤집기도구� �����

선택한�범위를�요구하는�방향으로�즉�수평,�수직으로�뒤집기를�할수�있다.�

실례를�들어�전체�그림을�뒤집기하는�방

법을�보기로�하자.�

①�《선택》→《전체》지령을�실행한다.�

②�《도구》→《변형도구》→《뒤집기》

지령을�실행한다.�

③� 화상우에서� 찰칵하거나� 도구선택항

목칸에서�뒤집기류형을�선택한�다음�화상우

에서�찰칵하면�해당�방향으로�뒤집기된다.��

Ctrl건을�리용하여�진행할수도�있다.�뒤집기도구를�선택한�상태에서�Ctrl건을�

누르면�마우스지시자의�모양이�수평에서�수직방향으로�또는�수직에서�수평방향으

로�변한다.�

∘�수평뒤집기�

�

�

�

�

�

�

�

�

�

�

�
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∘�수직뒤집기�

�

�

�

�

�

�

�

�

�

�

(4) 기타 도구 

기타�도구에는�경로도구,�색갈찾개도구,�확대도구,�측정도구,�본문도구�등이�있다.�

�

-�경로도구��������

경로도구는�곡선을�편집할수�있고�곡선에�그리기를�할수�있으며�혹은�곡선을�입력

또는�출력,�보관할수�있다.�

기하학적특징을�창조하기�위하여�경로를�리용할수�있다.�

해당�위치에서�찰칵하면�마디점들이�생기는데�이�마디점들을�리용하여�여러가지�모

양의�곡선을�그린다.�

이때�조종점들이�생성되는데�이�조종점을�조종하여�여러가지�모양의�곡선을�그릴수

있다.�

경로도구를�리용하여�곡선을�만들어보자.�

먼저�직선을�그린다.�

그림에서�보는것처럼�해당�위치에서�찰칵하면�마디점들이�나타난다.(왼쪽그림)��

�

�

�

�

�

�

�

�

직선을�곡선모양으로�변경시키려면�선분을�

선택하고�끌기한다.(오른쪽그림)�그러면�선분조

종점이�나타나는데�이�조종점을�조종하여�사용

자의�의도에�맞는�곡선을�그린다.�

곡선이�원만히�되면�경로따라그리기를�실행

한다.�그러면�곡선이�선택경로대로�그려진다.�

마디점�

조종점
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건반에서�Ctrl건과�Alt건을�함께�누른�상태에서�조종점을�이동시키면�전체�곡선이�

이동한다.�

�
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�

�

�

경로따라그리기 

�

《경로�따라�그리기》대화칸을�리용하여�경로도구로�선택한�직선�또는�곡선

을�선분�또는�무늬,�붓도구를�리용하여�따라그리기할수�있다.�

실례로�우의�그림에서�선택한�경로를�따라�그리기�위해서는�다음과�같이�한다.�

화상창문에서�《편집》→《경로따라그리기》지령을�실행한다.�

그러면�《경로�따라�그리기》대화칸이�나타난다.�

 

�

이�대화칸에서�《그리기�도구로�긋기》를�선택한�다음�《따라그리기(S)》단

추를�찰칵한다.�

결과�화상은�그림과�같다.�

�

�

�

�

�

�

�

�

알아두기 
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-�색갈찾개도구� ������

색갈찾개도구는�작업층이나�화상우에서�색상을�찾는데�리용한다.�

실례를�들어보기로�하자.�

①�기본도구창문에서�색갈찾개도구그림기호를�찰칵하거나�화상창문에서�《도구》→

《색갈찾개》를�실행한다.�

②�화상우에서�한점을�선택한다.�

그러면�《색갈찾개》대화칸이�나타난다.�이�대화칸에는�선택된�색상의�정보가�현시

되며�기본도구창문의�전경색/배경색칸에�전경색이�선택한�색으로�바뀐다.�

�

�

�

�

�

�

�

�

�

�

�

�

-�확대도구� �����

어떤�부분을�확대하거나�축소하여�보려고�할�때�이�도구를�리용한다.�

실례로�《연》이�있는�부분을�확대하려고�할�때에는�다음과�같이�한다.��

기본도구창문에서� 를�찰칵하거나�화상창문에서�《도구》→《확대》지령을�실행한다.�

다음�《연》이�있는�부분을�선택한다.�그러면�선택한�부분이�확대된다.�

�

�

�

�

�

�

�

�

�

도구선택항목칸에서�《축소》를�설정하고�화상우에서�끌기하면�화상은�축소된다.�

Ctrl건을�눌러�확대,�축소를�절환시킬수�있다.�

선택된�색상�
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-�측정도구� ����

화상에서�화소거리에�대한�정보를�측정하는데�이�도구를�리용한다.�

실례를�들어보기로�하자.�

①�기본도구창문에서� 그림기호를�찰칵하거나�《도구》→《측정》지령을�실행한다.�

②�해당�위치에서�끌기한다.�

그러면�끌기한�첫점과�마지막점사이�각과�화소수에�대한�정보가�화상창문의�아래에�

있는�상태띠에�현시된다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

도구선택항목칸에서�《정보창문�사용》을�선

택하면�《측정》대화칸이�펼쳐지는데�여기에�측

정정보가�나타난다.�

-�본문도구� �����

화상우에�어떤�문자를�쓰려고�할�때�이�도구를�리용한다.�

본문도구를�리용하여�화상우에�《더�높이�날아라.》를�쓰기�위해서는�다음과�같

이�한다.�

시작점�

끝점

측정정보 현시
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①�기본도구창문에서� 를�찰칵하거나�화상창문에서�《도구》→《본문》지령을�실

행한다.�

②�화상우에서�찰칵하면�《환상》본문편집기대화칸이�나타난다.�

③�도구선택항목칸에서�서체,�서체크기,�서체색갈�등�필요한�설정을�하고�본문편집

기대화칸에�《더�높이�날아라.》를�입력한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

④�《닫기(C)》단추를�찰칵한다.�

�

(5) 색상령역과 표시기령역 

-�색상령역�

색상령역은�그리기,�령역채우기에�리용되는�두가지�색�즉�전경색과�배경색으로�이

루어진�《환상》에서의�기본적인�조색판이다.�

마우스를�찰칵하면�색상편집기대화칸이�열리는데�여기서�사용자의�의도에�맞는�색

을�선택하여�리용할수�있다.�

축소모형의�작은�그림기호를�찰칵하면�전경색과�배경색을�

각각�검은색,�흰색으로�재설정한다.�

두개의�화살모양곡선을�찰칵하면�전경색과�배경색이�서로�

바뀌운다.�

-�표시기령역�

표시기령역은�현재�선택된�붓,�무늬,�경사도를�보여준다.�

표시기령역의�임의의�부분을�찰칵하면�그것을�변화시킬수�

있는�대화칸이�펼쳐진다.�
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�

�

�

�

�

�

�

�

�

여기서�작업대상에�맞는�붓,�무늬,�경사도무늬를�선택하여�리용할수�있다.�

3) 도구선택항목칸 

《환상》을�설치하면�도구선택항목칸이�기본도구창문의�도구칸아래에�나타난다.�

도구선택항목칸이�나타나지�않으면�기본도구창문의�차림표에서�《파일》→《대화창

문》→《도구선택항목》지령을�실행하면�된다.�

《환상》에서�매�도구들은�자체의�전용항목들을�가진다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

도구선택항목칸의�아래에�있는�네가지�단추의�기능은�다음과�같다.�

-�보관�

이�단추는�후에�복귀할수�있도록�현재�도구들에�대한�항목을�보관한다.�

보관� 복귀 지우기
재설정�
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-�복귀�

이�단추는�작용도구에�대하여�앞서�보관한�선택모임을�복귀한다.�선택모임이�작용

도구에�대하여�보관되지�않았다면�단추는�비표시로�되여있다.�

-�지우기�

이�단추는�작용도구들에�대하여�이미�보관한�항목들의�모임을�제거한다.�작용도구

들에�대하여�보관된�선택모임이�없다면�단추는�비표시로�되여있다.�

-�재설정�

이�단추는�작용도구에�대하여�그것들의�표준값으로�항목들을�재설정한다.�

2. 화상창문 

《환상》에서�모든�화상들은�서로�분리된�창문으로�현시된다.�

화상창문의�구조는�다음과�같다.�

�

��

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

○�차림표단추-�이�단추를�찰칵하면�화상차림표가�제시된다.�

○�눈금자-�눈금자가�표준적으로�배치되면�화상안에서�가로세로자리표들을�표시해

주는�눈금자들이�화상의�웃쪽과�왼쪽에�현시된다.�

눈금자를�사용하는데서�가장�중요한것은�안내선들을�생성하는것이다.�눈금자우에서

끌기로�안내선을�창조할수�있고�또�제거할수도�있다.�

제목띠

차림표단추�

차림표띠

눈금자�

작업판 창문크기조절�

고속마스크절환�

지시기자리표계 단위차림표

확대,축소

수직흘림띠�

수평흘림띠

항행조종�

취소단추�상태령역
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○�고속마스크절환-�화상안에서�선택된�령역을�보여주는�방식이다.�

○�지시기자리표계-�화상안에서�마우스지시자의�위치를�보여준다.�

○�단위차림표-�표준적으로�단위들은�눈금자에�따라�사용되며�대체로�화소가�사용

된다.�이�차림표에서�inch,�cm�혹은�사용가능한�몇가지�다른�단위들로�변경할수도�있다.�

○�확대,�축소단추-�화상을�확대하거나�축소하는�기능을�수행한다.�

○�상태령역-�대체로는�표준적으로�현재�활성화된�화상의�부분들을�보여주며�화상

이�소비하고있는�체계기억기의�총�용량을�보여준다.�

○�취소단추-�시간이�걸리는�조작으로�합성작업을�하는�도중에�이�단추를�찰칵하면

즉시에�그것이�실행취소된다.�

○�항행조종-�이�단추를�찰칵하면�화상의�축소모형을�보여주는�작은�창문이�나온다.�

○�작업판-�화상처리를�직접�진행하는�부분으로서�이것은�배경과�대조되게�화상

의�경계를�보여주는�노란색�점선으로�둘러싸여있는�창문의�가운데령역을�차지한다.��

○�창문크기조절-화상창문의�크기를�조절할수�있다.�

�

련습문제 

1.�기본도구창문과�화상창문의�차림표에서�같은�점과�다른�점은�무엇인가?�

2.�선택도구들을�리용하여�임의의�화상에서�선택을�진행해보아라.��

3.�그리기도구들에서�공통점은�무엇이고�다른�점은�무엇인가?�

4.�변형도구들은�어떤�기능들을�수행하며�임의의�화상에서�따내기,�회전,�투영변형을�

해보아라.�

5.�경로도구로�여러가지�형태의�곡선을�그려보아라.�

6.�본문도구를�리용하여�서체의�형식과�크기,�색갈을�변화시키면서�문자를�입력해보아라.�

�

�

�

제 3절. 층과 려과기 

1. 층 

층은�그림이�그려진�투명한�유리판이라고�볼수�있다.�

투명한�유리판우에�그림을�그릴�때�유리판우에�그림을�그리면�색감이�묻은�부분은�

불투명하지만�색감이�묻지�않은�부분은�투명하다.�
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�

그림과�같이�여러개의�유리판들이�있을�때�유리판들의�자리를�바꾸거나�회전시켜�

즉�개개�유리판들을�움직여�각이한�화상을�만들수�있다.�

만일�그림들이�층별로�되여있지�않고�하나의�막으로�되여있다면�일부�그림을�선택

하여�이동시킬�때�전체�화상에�영향을�주게�된다.�

《환상》에서는�화상을�가공할�때�바로�이런�현상을�없애기�위해�층을�도입하여�화

상작업에�드는�품을�훨씬�줄이고�작업을�쉽게�할수�있다.�

《환상》에서�층들은�층조작판에�나타난다.�

층조작판은�층을�관리하기�위한�기본대면부로서�화상의�모든�층들을�관리한다.�

층조작판은�또한�새로운�층을�작성할수�있고�층을�삭제,�층숨기기,�층합치기를�할

수�있다.�

�

�

�

�

�

�

�

�

�

�

《대화창문》→《층》지령을�실행하거나�Ctrl+L건을�누른다.�그러면�다음의�조작

판이�나타난다.�

층

1�

층�
2�

층�
3�

층조작판을�열려면�어떻게�해야�하는가?�

�

생각하기 



�

�

172�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

배경층은�층조작판의�맨아래에�놓이며�새로�창조되는�층들은�그우에�놓이게�된다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

우의�그림에서�보는것처럼�개개의�부분적인�화상층들이�모여�하나의�그림을�완성할

수�있다.�

새층작성�

층올리기

층내리기

층복제

류동하는�층고정

층삭제
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모든�층들은�여러가지�많은�속성들을�가지고있다.�

층조작판에서�층을�선택하고�오른쪽찰칵하여�나타나

는�지름차림표에는�다음과�같은�지령들이�있다.�

-�층속성�편집(E)�

선택한�층의�이름을�바꿀수�있다.�

-�새�층작성(N)�

새로운�층을�작성할수�있다.��

이�지령을�실행하면�새층작성대화칸이�펼쳐지는데�여

기서�층이름과�층의�너비,�층채우기류형을�설정한다.�

-�층복제(U)�

선택한�층의�복사를�진행한다.�

복사할�층을�선택하고�이�지령을�실행하면�선택된�층

이�복사된다.�

-�아래로�합치기(W)�

작업과정에�층을�합치기�할�필요가�있거나�작업이�완

전히�끝난�다음�층합치기를�할�때�리용한다.�

맨우의�층을�선택하고�이�지령을�실행하면�층이�아래

로�내려가면서�합쳐진다.�

-�층경계�크기(O)�

층의�크기를�위한�대화칸이�펼쳐지는데�여기서�층경

계크기를�위한�파라메터들을�설정할수�있다.�

-�층을�화상크기에�맞추기(I)�

층의�내용을�움직이지�않고�층의�크기를�화상의�테두리에�맞추어준다.�

-�층척도변경(S)�

층의�척도를�변경시켜준다.��

이�지령을�실행하면�척도변경을�위한�대화칸이�펼쳐지는데�여기서�파라메터들을�설

정하여�층의�척도를�변경시킨다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

층마스크 

층마스크는�층의�일부분을�사라지게�하거나�나타나게�한다.�

층마스크는�층의�어떤�부분의�투명도를�보이지�않게�하거나�보이게�한다.�

�

알아두기 
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2. 려과기 

려과기는�말그대로�《색려과기》라고�생각하면�된다.�

사진기로�촬영을�할�때�카메라의�렌즈앞에�얇은�렌즈를�끼워�사진에�다양한�효과를�

낼수�있다.��

《환상》은�각종�려과기능을�갖추고있는데�이것들은�자기�기능에�따라�색을�려과하

여�여러가지�효과를�나타낸다.�

려과기는�쓰이는�용도에�따라�여러가지�부류로�나누어져있다.�

려과기에는�초점흐리기려과기,�색상려과기,�잡음려과기,�륜곽검출려과기,�강조려과

기,�일반려과기,�유리효과려과기,�조명효과려과기,�변형려과기,�예술려과기,�넘기기려

과기,�묘사려과기,�결합려과기가�있다.�

1) 초점흐리기려과기 

이�려과기는�여러가지�방법으로�화상�또는�그�일부분을�흐려지게�하는�려과기들의

묶음이다.�

초점흐리기려과기에는�초점흐리기,�정규분포초점흐리기,�선택적인�정규분포초점흐

리기,�운동초점흐리기,�화소초점흐리기들이�있다.�

실례로�선택적인�정규분포초점흐리기방법에�대하여�보기로�하자.�

①�화상을�선택한다.�

②�화상창문에서�《려과기》→《초점흐리기》→《선택적인�정규분포초점흐리기》지령

을�실행한다.�

층마스크는�층의�어떤�부분의�투명도를�조절하며�화상합성을�자연스럽게�하

는데�리용한다.��

따라서�층마스크는�투명층에만�적용되며�배경층에는�적용되지�않는다.�

층에�마스크를�할�때�층마스크에는�그�층과�꼭같은�수의�화소수가�정해지게

된다.�

층마스크의�매�화소는�그�층의�꼭같은�위치에�있는�화소와�쌍을�이루게�된다.�

마스크라는것은� 0~255사이의� 흑백색방식값이다.� 0값을� 가지면� 검은색,�

255값을�가지면�흰색으로�된다.�

층마스크는�선택한�층에서�오른쪽찰칵하면�지름차림표가�나타나는데�여기서

《층마스크추가》를�선택하면�된다.�

이때�나타나는�《층마스크추가》대화칸에서�마스크의�내용을�선택한다．�

�
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그러면�다음과�같은�《선택적인�정규분포초점흐리기》대화칸이�나타난다.�
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�

③�대화칸에서�초점흐리기반경을�설정한다.�이때�미리보기칸에�그�결과가�나타난다.�

④�《확인(O)》단추를�찰칵한다.�
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�

2) 색상려과기 

색상려과기는�화상에서�색상들을�변환하여�여러가지�효과를�얻는�려과기이다.�

색상려과기에는�전경-배경색변환,�경계평균,�성분구성,�려과기묶음,�반평활화,�성

분분해,�색상분석,�색상제거,�색상화,�알파통로넘기기,�잡음제거,�최대/최소색통로�등�

여러가지가�있다.�

실례로�색상교환려과기(이�려과기는�화상의�원래�색상을�다른�색상으로�바꾼다.)

사용법을�보기로�하자.�

려과기사용전 려과기사용후�
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①�화상을�선택한다.�

②�화상창문에서�《려과기》→《색상》→《넘기기》→《색상교환》지령을�실행한다.�

그러면�《색상�교환》대화칸이�펼쳐진다.�

③�대화칸에서�《전경�색상》과�《색상》의�색조절단추들을�리용하여�색값을�조절한다.�

④�《확인(O)》단추를�찰칵한다.�
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3) 잡음려과기 

이�려과기는�화상에�여러가지�형태의�얼룩을�첨가한다.�

잡음려과기는�우연뿌리기,�정규분포잡음,�채취,�3속성잡음,�겹찍기,�분산�려과기들

로�이루어져있다.�



�

�

177

실례로�《려과기》→《잡음》→《정규분포잡음》지령을�실행하여�나타나는�《정규분포잡

음》대화칸에서�해당�설정을�진행한�다음�《확인(O)》단추를�찰칵한다.�
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4) 륜곽검출려과기 

이�려과기들은�서로�다른�색상사이의�경계를�조사하여�대상의�륜곽을�검출한다.�

륜곽검출려과기는�륜곽,�정규분포,�라플라스,�경계검출,�네온등�려과기들로�이루어

져있다.�

�

�

�

�

�

�

�

�

�

�

《려과기》→《륜곽검출》→《륜곽》지령을�실행하여�나타나는�《륜곽》대

화칸에는�알고리듬형태들이�있다.�《알고리듬》의�해당�형태에�따라�어떤�현상

이�일어나는가?�

생각하기 
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5) 강조려과기 

강조려과기들은�화상의�결함들을�없애는데�리용된다.�

강조려과기에는�간격주사해제,�얼룩제거,�줄무늬없애기,�비선형려과기,�륜곽강조,�

비강조마스크�려과기들이�있다.�

얼룩제거려과를�실시하기�위해서는�《려과기》→《강조》→《얼룩�제거》지령을�실행한�

다음�《얼룩�제거》대화칸의�미리보기칸에�나타나는�그림을�보면서�해당�설정을�진행한다.�

6) 일반려과기 

일반려과기에는�회선행렬,�어둠도확장,�밝음도확장이�있다.�

7) 유리효과려과기 

이�려과기는�마치�렌즈나�유리를�통해�화상을�보는것처럼�만드는�려과기이다.�

유리효과려과기에는�렌즈려과기와�유리타일려과기가�있다.�

실례로�《려과기》→《유리효과》→《렌즈》지령을�실행하여�나타나는�《렌즈》대화

칸에서�《렌즈�굴절�첨수》�등을�변화시키고�《확인(O)》단추를�찰칵하면�선택한�화상

에�효과가�나타난다.�
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8) 조명효과려과기 

이�려과기들은�화상에�여러가지�조명효과들을�주는�기능을�가지고있다.�

조명효과려과기는�조명형태에�따라서�섬광,�조명,�불꽃,�별로�이루어져있다.�

실례로�별효과를�주기�위해서는�《려과기》→《조명》→《별》지령을�실행하여�나타

나는�《별》대화칸에서�중심값과�색을�선택하면�된다.�
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�

�

9) 변형려과기 

이�려과기는�여러가지�방법으로�화상을�변형시키는�기능을�수행한다.�

변형려과기에는�계단차광막,�부각,�말아넘기기,�모자이크,�종이말기,�극자리표넘기기,�

물결,�화소밀기,�신문지화,�비데오,�색상전파,�파도,�소용돌이,�바람려과기�등이�있다.�

실례로�극자리표넘기기려과기를�적용하기�위해서는�《려과기》→《변형》→《극자리

표넘기기》지령을�실행하고�《극자리표�넘기기》대화칸에서�해당�설정을�진행한다.�

10) 예술려과기 

예술려과기들은�그림판,�립체화,�유화,�만화와�같은�예술적인�효과들을�주는데�리용한다.�

이�려과기에는�그림판,�만화,�모자이크벽화,�복사사진,�유화,�유연한�백열광이�있다.�

11)  묘사려과기 

대부분의�려과기들은�층에서�층의�내용을�변화시키지만�묘사려과기들은�층에�이미�

있는�내용을�삭제하는�방법으로�화상에�효과를�준다.�

묘사려과기에는�안개,�먼지,�물보라,�에돌이무늬,�격자무늬,�쪼각그림,�우연무늬,�

곡선무늬,�기하학적도형�등이�있다.�

12) 결합려과기 

결합려과기들은�두개�또는�그�이상의�화상들을�하나의�화상으로�결합시키는�기능을

수행한다.�결합려과기에는�합성편집려과기와�필림편집려과기가�있다.�

�

�

�

�

�

�

《별》대화칸에서�색을�선택하기�위해서는�어떻게�해야�하는가?�

생각하기 

�

《필림편집》려과를�진행하기�위해서는�어떻게�해야�하는가?�

생각하기 
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13) 넘기기려과기 

이�려과기들은�화상에�대하여�빛,�빛재질,�방향�설정과�같은�여러가지�선택항목들

을�주어�다른�화상으로�넘기는�효과를�나타낸다.�

넘기기려과기에는�대상넘기기,�말아넘기기,�타일넘기기,�색종이넘기기,�변위,�타일

조종넘기기,�겹넘기기,�프락탈넘기기,�복합넘기기,�분할넘기기,�오목볼록넘기기가�있다.�

련습문제 

1.�층의�좋은�점은�무엇이고�층을�사용하는�리유는�무엇인가?�

2.�층에�마스크를�적용해보아라.�

3.�임의의�화상에�려과기를�적용시켜보면서�어떤�변화가�일어나는가를�보아라.�

실 습 

화상작업 

다음의�그림을�완성하는�과정을�통하여�《환상》에서�리용되는�기본도구들과�

여러�기능들에�대하여�그리고�파일들의�열기와�복사,�화상의�합성에�대하여�학습

하기로�하자.�

�

�

�

�

�

�

�

�

�

�

�

�
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1) 차잔만들기 

①�《파일》→《새로�작성》을�실행한다.�

그러면�《새로�작성》대화칸이�나타난다.�
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②�화상크기와�해상도�등을�설정한�다음�《확인(O)》단추를�찰칵한다.�

③�차잔접시를�그린다.�

먼저�기본도구창문에서�타원형선택도구를�선택하고�도구선택항목칸에서�속성값을�

설정한다.�

전경색을�선택하기�위해�기본도구창문의�색상령역칸에서�전경색을�두번찰칵한다.��

그러면�《전경색바꾸기》대화칸이�나타나는데�여기에서�색을�선택한�다음�《확인(O)》

단추를�찰칵한다.�

다음�새�층을�작성하기�위해�《층》→《새�층작성》지령을�실행한다.�

그러면�《새�층작성》대화칸이�나타난다.�

《층이름(N)》칸에�1이라고�입력하고�층채우기류형을�《투명》으로�설정한�다음�《확

인(O)》단추를�찰칵한다.�

그러면�새로운�층�1이�창조된다.�
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작업을�편리하게�하기�위하여�화상창문에�안내선들을�표시한다.�

다음�화상창문에서�타원형선택도구로�그림과�같이�타원령역을�선택한�다음�기본도

구창문에서�경사채우기를�선택한다.�

도구선택항목칸에서�경사도의�속성을�설정한�다음�선택된�타원령역의�오른쪽�웃부

분에서�왼쪽아래로�끌기하여�경사채우기를�실행시킨다.�
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�

실행취소와 재실행 

�

화상처리작업과정에�잘못하는�경우가�있을수�있다.�

-�실행취소�

화상창문에서�《편집》→《실행�취소》�혹은�Ctrl+Z건을�누른다.�

실행취소는�그리기나�화상작업과정에�결함이�나타나는�경우�이전�상태에로�한

걸음�되돌아가게�한다.�

실행취소기능에�의해�작업내용이�없어지는것이�아니다.�재실행을�사용하면�다

시�그것을�얻을수�있다.�

-�재실행�

화상창문에서�《편집》→《재실행》�혹은�건반에서�Ctrl+Y건을�누른다.�

《재실행》은�《실행취소》기능의�거꿀과정이다.�

알아두기 
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경사채우기를�실행한�다음�테두리선을�긋기�위하여�선택부분안에서�오른쪽찰칵하여�

나타나는�지름차림표에서�《편집》→《선택�따라그리기》지령을�실행한다.�

이때�나타나는�《선택�따라그리기》대화칸에서�《따라�그리기선》을�선택한�다음�속

성값을�그림과�같이�설정한다.��
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다음�《따라그리기(O)》단추를�찰칵한다.�

결과화상은�그림과�같다.�

�

�

�

�

�

�

�

�

�

�

�

접시모양을�만들기�위하여�화상을�변형시킨다.�

기본도구창문에서�직4각형선택도구로�접시를�선택한�다음�투영도구를�선택하고�선

택구역안의�임의의�위치에서�찰칵한다.�

이때�선택구역의�네모서리에�조종점이�나타나는데�이�조종점을�조절하여�접시웃부

분을�안내선이�새겨진�높이까지�변형시킨다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�



�

�

185

�

�

�

�

�

�

�

�

�

�

�

④�접시바닥을�만들어준다.�

먼저�새로운�층�2를�작성한다.��

타원형선택도구로�접시의�크기보다�작게�타원을�선택한다.��

기본도구창문에서�령역채우기도구� 를�선택하고�선택령역에�령역채우기를�한다.�

다음�선택을�해제한다.�
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�

⑤�고뿌를�만든다.�

먼저�새로운�층을�작성한다.�

다음�층속성대화칸에서�층이름을�《고뿌》라고�입력

하고�《확인(O)》단추를�찰칵한다.�

그러면�층조작판에�《고뿌》층이�창조된것을�알수�

있다.�

안내선을�리용하여�화상창문에서�고뿌의�크기를�설

정한다.�

기본도구창문에서�타원형선택도구� 를�찰칵하

고�화상창문에서�고뿌의�크기만큼�원을�선택한다.�
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�

다음�선택따라그리기를�리용하여�고뿌의�형태를�그린다.�
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직4각형선택도구로�원의�웃부분을�선택하고�건반에서�Delete건을�눌러�지워버린�

다음�선택을�해제하기�위해�선택구역밖에서�찰칵한다.�
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다음�타원형선택도구를�리용하여�고뿌의�웃부분을�그린다.�여기서도�선택따라그리

기를�리용하면�된다.�
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�

그림에서�보는것처럼�두�그림이�겹쳐있다.�

화상작업을�편리하게�하기�위하여�층조작판에서�접시층�1,�2의�눈그림기호를�해제

한다.�그러면�화상창문에는�고뿌의�모양만�남게�된다.�
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고뿌의�밑부분을�만들기�위하여�안내선으로�고뿌의�중심을�표시한다.�
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직4각형선택도구로�밑부분을�선택하고�오른쪽찰칵하여�나타나는�지름차림표에

서�《편집》→《복사》지령을�실행한다.��

새�층을�작성한�다음�지름차림표에서�《편집》→《붙이기》지령을�실행한다.�
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선택을�해제한�다음�기본도구창문에서�연필도구� 를�선택한다.�

이때�나타나는�도구선택항목칸에서�연필도구의�크기를�그림과�같이�설정한�다음�고

뿌의�밑부분과�복사된�부분을�련결시킨다.�
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다음�층조작판에서�층합치기를�진행한다.�

층조작판에서�3번�이름을�가진�층을�선택하고�오른쪽찰칵하여�나타나는�지름차림표

에서�《아래로�합치기》지령을�실행한다.��

결과�고뿌의�웃부분과�복사된�밑부분이�하나의�층으로�되였다.�
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⑥�고뿌에�색을�입힌다.�

기본도구창문에서�모호선택도구�����를�선택하

고�고뿌의�바깥부분을�선택한다.�

Shift건을�누르면서�밑부분을�함께�선택한다.�

기본도구창문에서� 경사채우기도구를� 선택하고�

도구선택항목칸에서�경사채우기도구의�속성값을�설

정한다.�
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경사채우기의�도구선택항목칸에서�경사도옆의�색선택그림기호를�찰칵하면�그림과�

같이�각종�경사도무늬의�형태들이�목록으로�현시된다.��

여기서�해당한�경사도무늬를�선택한다.�

선택구역에서�경사채우기를�한다.�

경사도방향은�그림과�같이�오른쪽우에서�왼쪽아래로�한다.�
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다음�바깥선택을�해제하고�고뿌의�안쪽을�선택한다.�

경사도방향을�그림과�같이�왼쪽아래에서�오른쪽우에로�한다.�
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⑦�고뿌의�손잡이를�만든다.�

먼저�새�층을�작성하고�이름을�《손잡이》라고�한다.��

그러면�층조작판에�《손잡이》라는�새로운�층이�창조된다.�
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기본도구창문에서�타원형선택도구를�선택하고�도구선택항목칸에서�타원의�크기를�

설정한�다음�화상창문에서�타원을�선택한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

다음�화상창문의�차림표에서�《편집》→《선

택�따라그리기》지령을�실행한다.�

이때�나타나는�《선택�따라그리기》대화칸

에서�선분너비를�6.0으로�설정하고�《따라그리

기(S)》단추를�찰칵한다.�
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다음�기본도구창문에서�직4각형선택도구로�원의�절반을�선택하고�화상창문에서�《편

집》→《지우기》지령을�실행한다.�또는�Delete건을�누른다.�

�

�

�

�

�

�

�

�

�

직4각형선택도구로�남은�부분을�선택한다.�

기본도구창문에서�투영도구를�선택하고�선택구역안의�임의의�위치에서�찰칵한다.�

그러면�선택구역마당의�네�모서리에�4개의�조종점들과�함께�《투영》대화칸이�나타난다.�

이�조종점들을�조종하여�그림과�같이�《손잡이》를�만든다.��
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손잡이모형이�완성되면�《투영》대화칸의�《변형(T)》단추를�찰칵한�다음�선택을�해

제한다.�
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결과화상은�그림과�같다.�
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그림에서�보면�고뿌손잡이가�고뿌본체보다�앞에�나와있다는것을�볼수�있다.�

이것은�손잡이가�작업층의�맨우에�놓여있기때문이다.�

층조작판에서�《손잡이》층을�선택하고�마우스끌기�또는�층조작판의�아래에�있는�그

림기호� 를�찰칵하여�《고뿌》층밑에�놓이게�한다.�
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손잡이가�완성되면�층조작판에서�맨우의�층�즉�《고뿌》층을�선택하고�《손잡이》층

과�층합치기를�하여�하나의�층으로�만든다.�
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⑧�고뿌안에�담겨있는�차물을�그린다.�

먼저�기본도구창문에서�타원형선택도구를�선택하고�그림과�같이�고뿌안에서�타원을�

선택한다.�
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다음�색상령역에서�전경색을�찰칵하여�나타나는�《전경색바꾸기》대화칸에서�차색갈

의�색을�선택한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�



�

�

196�

기본도구창문에서�령역채우기도구� 를�선택하고�도구선택항목칸에서�《전경색으

로�채우기》를�선택하여�채우기류형을�전경색으로�한�다음�선택령역에�채우기를�진행한다.�

령역채우기는�마우스지시자를�선택구역안에서�찰칵하면�선정된�색이�채워진다.�
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�

선택을�해제한다.�

⑨�접시우에�고뿌를�올려놓는다.�층조작판에서�숨기기하였던�1,�2층의�눈그림기호

를�찰칵하여�숨기기를�해제시킨다.�

화상창문을�보면�고뿌와�접시가�서로�불균형적으로�겹쳐있는것을�볼수�있다.�

기본도구창문에서�이동도구를�선택하고�층조작판에서�《손잡이》층을�찰칵한다.�

이동도구로�고뿌를�선택하고�접시우에�끌어다놓는다.�
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�

⑩�완성된�화상파일을�보관한다.�

파일을�보관하기�전에�층조작판에서�모든�작업층들을�층합치기하기�위하여�오른쪽
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찰칵하여�나타나는�지름차림표에서�《전체층�합치기》지령을�실행한다.�

그러면�층조작판의�모든�층들이�배경층에�하나로�결합된다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

층합치기를�한�다음�화상창문에서�《파일》→《보관》지령을�실행한다.�그러면�《보

관》대화칸이�펼쳐진다.�
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은정차 

차잔만들기 
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대화칸의�《이름(N)》칸에�《차잔만들기》라고�입력하고�보관할�서류철을�선택

한�다음�《파일�류형�(확장자로)(T)》를�찰칵하고�확장자를�설정한�다음�《보관(S)》단

추를�찰칵한다.�

2)�꽃병만들기�

①�새�화상창문을�연다.�

《파일》→《새로�작성》을�실행하여�나타나는�《새로�작성》대화칸에서�화상의�크기를

800×600으로�정한다.�

다음�새�층을�작성하기�위해�층조작판에서�《층》→《새�층작성》지령을�실행한다.�

《새�층작성》대화칸의�《층이름(N)》칸에�《꽃병》이라고�입력하고�《확인(O)》단

추를�찰칵한다.�
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기본도구창문에서� 를�두번찰칵하고�이때�나타나는�《전경색바꾸기》대화칸에

서�그림과�같이�색을�선택하고�《확인(O)》단추를�찰칵한다.�
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다음�화상창문에서�작업을�편리하게�하기�위하여�꽃병의�크기만큼�안내선을�표시한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�



�

�

200�

기본도구창문에서�타원형선택도구를�선택하고�화상창문에서�끌기한다.�

화상창문에서�《편집》→《선택�따라그리기》를�실행한다.�

이때�나타나는�《선택�따라그리기》대화칸에서�선분너비를�1.0으로�하고�《따라그리

기(S)》단추를�찰칵한�다음�선택구역밖에서�찰칵한다.�
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②�층조작판에서�새�층작성그림기호� 를�찰칵하여�새�층을�작성하고�층이름을�1

로�준다.�
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�

화상창문에서�그림과�같이�안내선을�추가하고�타원형선택도구로�타원을�선택한�다

음�선택따라그리기를�진행한다.(왼쪽그림)��

꽃병 

배경 

1�
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�

�

선택구역밖에서�찰칵한다.�

기본도구창문에서�직4각형선택도구로�타원의�절반을�선택한다.�

화상창문에서�《편집》→《지우기》지령을�실행하거나�Delete건을�눌러�선택된�부분

을�지운�다음�선택구역밖에서�찰칵한다.(오른쪽그림)�

층조작판에서�《꽃병》층을�선택한�다음�화상창문에서�그림과�같이�직4각형선택도구

로�선택하고�지우기를�한�다음�선택을�해제한다.�
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기본도구창문에서�지우개도구를�선택하고�큰�원과�작은�원이�사귄�부분을�지우기한

다.�지우기를�할�때�큰�원과�작은�원은�서로�분리된�층으로�되여있으므로�해당한�층을�

선택한�조건에서�지우기를�할수�있다.�

층조작판에서�층합치기를�한다.�

결과�두개의�층이�하나로�합쳐지면서�두�화상이�하나의�층에�놓이게�된다.�
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�

다음�층조작판에서�《꽃병》층을�선택하고�직4각형선택도구로�화상을�선택한다.�

화상창문에서�《편집》→《복사》지령을�실행한다.�
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꽃병 

배경 

1�꽃병 

배경 꽃병 

배경 

1�
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또�하나의�새로운�층을�작성하여�층이름을�《복사》라고�하고�화상창문에서�《편집》→

《붙이기》지령을�실행하여�복사된�화상을�이�층에�붙이기한다.�
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�

이때�나타나는�복사된�화상은�선택된�상태이다.�

기본도구창문에서�이동도구를�선택하고�복사된�화상을�이동시킨다.��
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꽃병 

배경 

복사 
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선택을�해제한다.�

③�복사된�화상을�뒤집기한다.�

화상창문에서�《층》→《변형》→《수평으로�뒤집기》지령을�실행하여�복사된�화상을�

뒤집기한다.�
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그러면�수평뒤집기한�화상이�원래�화상과�겹쳐있는것을�볼수�있다.��

기본도구창문에서�이동도구를�선택하고�뒤집기한�화상을�마우스끌기로�원래�화상과�

맞춘다.�

�

변형형태 

《환상》에는�두가지�형태의�변형이�있다.�

하나는�층에서의�변형이고�다른�하나는�화상에서의�변형형태이다.�

층에서의�변형은�선택된�층에만�변형이�적용되고�화상에서의�변형은�층전체

를�포함한�화상에�적용된다.��

�

알아두기 
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④�꽃병의�웃부분을�완성한다.�

먼저�층조작판에서�새로운�층을�작성하고�층이름을�1이라고�한다.�

타원형선택도구로�그림과�같이�타원을�선택하고�선택따라그리기를�실행한다.�이때

《선택�따라그리기》대화칸에서�선분너비를�1.0으로�한다.�
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�

층조작판에서�층�1을�선택하고�선택도구로�꽃병웃부분의�선

택복사를�진행한다.�

안내선을�그림과�같이�꽃병웃부분의�너비만큼�이동시킨다.�

새로운�층을�작성하고�층이름을�2라고�하고�복사된�화상을�

붙이기한다.�
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복사된�화상의�선택을�해제한�다음�기본도구창문에서�이동도구를�선택하고�마우스

끌기로�아래부분으로�이동시킨다.�

층조작판에서�꽃병층과�2층을�선택하고�겹친�부분을�따로따로�지우기한다.�
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다음�새로운�층�3을�작성하고�우에서�복사한�부분을�붙이기한다.�

이동도구로�복사된�화상을�마우스끌기하여�그림과�같이�이동시킨다.�
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�

다음�지우개도구로�사귐부분을�지우기한다.�

화상창문에서�안내선들을�해제한다.�

이렇게�함으로써�꽃병의�기본형태가�완성되였다.�

복사된�부분

지우기�
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�

층조작판에서�층합치기를�하여�작업층들을�합치기한다.�

⑤�꽃병에�색입히기를�진행한다.�

기본도구창문에서�모호선택도구� 를�선택한다.��

도구선택항목칸에서�방식설정을� (현재선택에�더하기)로�선택하고�《비슷한�색상

찾기》에서�《투명한�령역�선택》을�선택한�다음�그림과�같이�선택을�진행한다.�
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다음�붓조작판에서�무늬를�선택하고�화상창문에서�《편집》→《무늬로�채우기》지령

을�실행한다.�
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그러면�선택구역에�무늬가�입혀지게�된다.��
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선택된�무늬
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선택구역밖에서�찰칵하여�선택을�해제한다.�

다음�화상창문에서�《려과기》→《초점흐리기》→《초점흐리기》지령을�실행하여�꽃

병의�질감을�부드럽게�하여준다.�
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� 려과기를 적용하기 전 려과기를 적용한 후 
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⑥�꽃병에�장식무늬를�새긴다.�

기본도구창문에서�붓도구� 를�선택한다.�

붓도구선택항목칸에서�《방식》을�《화면》으로�설정하고�붓목록에서�《잎》모양의�붓

을�선택한다.�
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다음�선택된�《잎》모양의�붓으로�꽃병의�겉면에�장식을�한다.�

결과�꽃병의�장식무늬가�완성되였다.�
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⑦�꽃병에�꽂혀있는�꽃을�그린다.�

먼저�층조작판에서�새로운�층을�작성하고�층이름을�《꽃》이라고�한다.�
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다음�기본도구창문에서�붓도구를�선택한다.��

붓도구선택항목칸에서�《방식》설정을�《표준》으로�한�다음�《잎》모양의�붓을�선

택한다.�
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선택된�붓을�가지고�《꽃병》우에�꽂혀있는�잎을�그린다.�
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잎우에�꽃을�그린다.�

붓도구에는�꽃모양의�붓형태가�없다.��

《환상》에서는�사용자의�의도에�맞게�여러가지�모양의�붓을�만들어�쓸수�있다.��

실례로�붓조작판을�리용하여�꽃모양의�붓을�만들기�위해서는�다음과�같이�한다.�

붓조작판에서� 을� 선택하고� 조작판아래에� 있는� 새로운� 붓그림기호를� 찰칵한

다.(《대화창문》→《붓》지령을�실행할수도�있다.)��

그러면�《붓도구�편집기》대화칸이�펼쳐진다.�

이름칸에�붓의�이름을�《꽃모양》이라고�준�다음�아래의�속성칸에서�속성값들을�변

경시켜�꽃모양의�붓을�편집한다.�
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붓의�형태가�완성되면�《붓도구�편집기》대화칸아래에�있는�《보관》그림기호를�

찰칵한다.��

그러면�새로�편집한�꽃모양붓이�붓조작판의�붓목록에�추가된다.�
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새로�편집한�붓�



�

�

214�

기본도구창문에서�붓도구를�선택하고�전경색을�노란색으로�설정한다.�

붓도구선택항목칸에서�《방식》설정을�《질감�합치기》로�선택하고�《붓》형태를�새

로�편집한�《꽃모양》붓을�선택한다.�
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꽃모양의�붓도구를�가지고�그림과�같이�잎우에서�찰칵하여�꽃을�그린다.�

다음�전경색을�붉은색으로,�붓형식을�모호원(09)의�형식으로�바꾸고�꽃을�완성

한다.��

층조작판에서�배경층을�제외한�작업층들을�합치기한다.�

화상파일을�xcf로�보관한다.�
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3) 탁상만들기 

①�새�화상창문을�펼친다.�

층조작판에서�새로운�층을�만들고�층이름을�《탁상면》이라고�한다.�

기본도구창문에서�직4각형선택도구를�선택하고�도구선택항목칸에서�속성값을�그림

과�같이�설정한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

화상창문에서�마우스끌기로�령역을�선택한다.�그러면�그림과�같이�네모서리가�둥근�

4각형구역이�선택된다.�
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《전경색바꾸기》대화칸에서�R=135,�G=77,�B=39로�값을�설정하고�《확인(O)》단

추를�찰칵하여�전경색을�선택한다.�

화상창문에서�《편집》→《선택�따라그리기》지령을�실행하고�이때�나타나는�《선

택�따라그리기》대화칸에서�선분의�너비를�3.0으로�설정한다.�

기본도구창문에서�모호선택도구를�선택하고�도구선택항목칸에서�《투명한�령역�선

택》을�설정한다.�
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화상창문의�4각형안에서�찰칵하면�4각형안의�투명한�령역이�선택된다.�

무늬창문에서�무늬를�선택하면�기본도구창문에�선택된�무늬가�나타난다.��
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화상창문의�선택령역을�무늬로�채우기한�다음�선택을�해제시킨다.�
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기본도구창문에서�투영도구를�선택하고�화상을�그림과�같이�변형시킨다.�
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결과�다음과�같은�화상이�얻어진다.�
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�

�

�

②�새�층을�작성하고�이름을�《복사》라고�한다.�

층조작판에서�《탁상면》층을�선택하고�화상창문에서�변형된�화상을�복사한다.�

다음�복사된�화상을�《복사》층에�붙이기한다.�
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�

복사된�화상을�이동도구를�리용하여�그림과�같이�이동시킨다.�
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다음�층조작판에서�층합치기를�하여�《탁상면》층과�《복사》층이�하나의�층으로�되

도록�한다.�

기본도구창문에서�모호선택도구를�선택하고�도구선택항목칸에서�《투명한�령역�선

택》을�해제시키고�그림과�같이�선택한다.�
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�
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�

다음�무늬창문에서�무늬를�선택한�다음�선택부분을�무늬로�채우기하고�선택을�해제한다.�

선택령역
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③�새�층을�작성하고�층이름을�1이라고�한다.�

층조작판에서�《탁상면》층을�선택하고�화상복사를�진행한다.�복사된�화상을�층�1

에�붙이기한다.�

다음�투영도구를�리용하여�복사된�화상을�변형시키고�이동도구를�리용하여�그림과�

같은�위치에�이동시킨다.�

�

�

�

�

�

�

�

�

�

�

선택된�무늬

�무늬로�채워진�부분
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④�탁상다리를�완성한다.�

새�층을�작성하고�층이름을�2라고�한�다음�기본도구창문에서�직4각형선택도구로�탁

상다리형태를�선택한다.�

�

�

�
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�

�

�

�

�

다음�무늬창문에서�무늬를�선택한�다음�선택따라그리기를�한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

기본도구창문에서�모호선택도구를�선택하고�도구선택항목칸에서�《투명한�령역�선

택》을�설정한�다음�화상에서�선택한다.�

무늬창문에서�무늬를�선택하고�선택령역을�무늬로�채우기한다.�

�

�

�

�

�

�

�

�

�

선택된�무늬

선택된�무늬

선택령역�

무늬로�채우기된�부분
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그림을�보면�탁상다리가�큰�탁상면의�우에�놓여있는것을�볼수�있다.�

이것은�탁상다리를�만든�층이�《탁상면》층보다�우에�놓여있기때문이다.�

층조작판에서�층조작을�하여�탁상다리가�탁상면의�밑에�놓이도록�한다.�

�

�
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�

�

�

�

�

�

�

�

⑤�새�층을�작성하고�층이름을�3이라고�한다.�

층조작판에서�층�2를�선택하고�탁상다리를�복사한�다음�층�3에�붙이기한다.�이동도

구를�리용하여�복사된�화상을�이동시킨다.�

�

�

�

�

�

�

�

�

�

�

�

�

선택도구로�이동시킨�탁상다리를�선택한�다음�투영도구로�변형을�준다.�

�

�

�

�

�

�

�

�

복사할�부분�

복사된�화상

이동한�화상�
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탁상의�한쪽다리가�완성되였다.�이와�같은�방법으로�도구들과�층조작판에서의�층조

작을�리용하여�나머지�다리들을�완성시킨다.��

결과�화상은�그림과�같다.�
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�

�

층조작판에서�작업층들을�합치기한�다음�화상파일을�보관한다.�
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4) 문자만들기 

-�먼저�립체문자만들기를�해보자.�

①�새�화상창문을�연다.�

기본도구창문에서�문자도구� 를�선택하고�도구선택항목칸에서�서체형식,�서체크

기,�서체색갈을�설정한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

화상창문안에서�찰칵하면�《환상》본문편집기대화칸이�열리는데�여기에�《장수보약》

이라고�문자를�입력하고�《닫기(C)》단추를�찰칵한다.�

그러면�화상창문에�《장수보약》이라는�문자가�나타난다.�

②�문자에�려과기를�적용한다.�

화상창문에서�《려과기》→《넘기기》→《오목볼록넘기기》지령을�실행한다.�그

러면�《오목볼록넘기기》대화칸이�나타난다.�

《오목볼록넘기기》대화칸에서�설정값들을�그림과�같이�설정하고�《확인(O)》단추

를�찰칵한다.��

그러면�입력된�문자에�려과기효과가�적용된다.�
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③�기본도구창문에서�이동도구를�선택하고�층조작판에서�문자가�입력된�층을�선택

한�다음�층조작판아래에�있는�층복제단추를�찰칵하여�층복사를�한다.�
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�

층복제단추�

복사된�층
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④�이동도구로�화상창문에서�복사된�화상을�선택하고�건반에서�방향건으로�웃쪽으

로�1pixel,�오른쪽으로�1pixel만큼�이동시킨다.�

이와�같은�과정을�여러번�반복하면서�문자의�깊이를�조절한다.�

�

�

�

�

�

�

층조작판을�보면�많은�작업층들이�생겼다는것을�알수�있는데�《배경》층을�제외한�나

머지층들을�모두�합쳐�하나의�층으로�만든다.�

많은�층들을�한번에�합치기�위해서는�층조작판에서�눈그림기호옆의�칸을�찰칵한다.�

그러면�사슬고리그림기호가�나타나는데�합치려는�모든�층들에�이�그림기호가�나타나도

록�한다.��

다음�맨아래에�있는�《배경》층에서�눈그림기호를�해제시킨다.�

마우스로�임의의�층을�선택하고�오른쪽찰칵하여�나타나는�지름차림표에서�《보이는�

층합치기》지령을�실행시킨다.�

다음�화상을�xcf로�보관한다.�

�

-�다른�형식의�문자를�만들어보자.�

①�새�화상창문을�연다.�

기본도구창문에서�문자도구를�선택하고�도구선택항목칸에서�그림과�같이�서체형태,�

서체크기,�서체색갈�등을�설정한다.�

�
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�
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②�《환상》본문편집기대화칸에�《은정차》라고�입력한�다음�《닫기(C)》단추를�찰

칵한다.�

이때�층조작판에는�《은정차》라는�새로운�문자층이�생성된다.�

새�층을�작성하고�문자층과�층합치기를�하여�하나의�투명한�층으로�만든다.�

③�다음�문자에�효과를�적용한다.�

화상창문에서�《조작》→《알파통로조작》→《3차원륜곽선》지령을�실행한다.�

이때�나타나는�《조작:3차원�륜곽선》대화칸에서�속성값들을�설정한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

《찾아보기(B)》단추를�찰칵하면�무늬목록칸이�현시된다.�여기서�무늬를�선택하면�

그림과�같이�문자에�장식효과가�적용되였다.�

�

�

�

�

�

�

�

�

층조작판을�보면�새로운�층들이�창조된것을�볼수�있다.�

이�층들은�조작효과가�실행되면서�자동적으로�창조된�층들이다.�

기본글자가�있는�맨우의�층을�선택하고�《층속성》대화칸에서�층이름을�《은정차》

라고�고친다.�
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�

다음�화상을�보관한다.��

《보관》대화칸에서�화상이름을�입력하고�보관할�서류철을�선택한�다음�파일확장자

를�xcf로�보관한다.�

문자들을�서로�다른�서체와�색으로�묘사하여�문자의�표현을�많이�바꿀수�있다.��

《환상》에서는�문자를�선택이나�경로로�변환하여�그것을�채우기�또는�테두리선을�

만들수�있으며�흥미있는�효과를�얻기�위하여�려과기�또는�조작효과들을�리용할수�있다.�

5) 화상의 합성 

앞에서�작업한�그림화상들을�하나의�그림으로�합성하여보자.�

①�새�화상창문을�펼친다.�

층조작판에서�새로운�층을�작성하고�층

이름을�《배경무늬》라고�한다.�

다음�붓조작판에서�무늬를�선택하고�무

늬목록에서�해당한�무늬를�선택한다.�

층조작판에서�《배경무늬》층을�선택하

고�화상창문에서�오른쪽찰칵하여�나타나는�

지름차림표에서�《편집》→《무늬로�채우기》

지령을�실행한다.�

그러면�선택된�무늬가�화상창문에�채워

진다.�

마스크된�층

투명한�층�

층이름 

교체



�

�

229

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

②�다음�앞에서�작업한�화상파일들을�불러들인다.�

먼저�《탁상》화상을�불러들여보자.�

화상창문에서�《파일》→《열기》지령을�실행하여�나타나는�《열기》대화칸에서�《탁

상》파일을�열기한다.�
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열린�화상의�층조작판에서�《탁상면》층을�선택하고�화상창문에서�화상을�복사한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

다음�새로�만든�화상창문의�층조작판에서�새로운�층을�작성하고�층이름을�《탁상》

이라고�한�다음�복사한�화상을�붙이기한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

③�붙이기한�화상의�비례조절을�한다.�

기본도구창문에서�투영도구를�선택하고�붙이기한�《탁상》화상의�크기를�그림과�같

이�변형이동시킨다.�
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④�이와�같은�방법으로�이미�앞에서�작업한�《차잔》,�《꽃병》,�《문자》화상파일

들을�불러들이고�화상의�크기를�척도변경,�투영도구를�리용하여�비례조절을�한다.�
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�

⑤�실물감을�주기�위하여�《차잔》과�《꽃병》에�그림자효과를�준다.�

먼저�층조작판에서�《차잔》층을�선택한�다음�화상창문에서�《조작》→《그림자》→

《그림자효과》지령을�실행한다.��
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그러면�《조작:�그림자효과》창문이�펼쳐진다.�
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�

여기서�설정값들과�그림자색갈을�선택하고�《확인

(O)》단추를�찰칵한다.��

그러면�그림과�같이�화상에 �그림자가 �적용

된다.�

층조작판을�보면�Drop-shadow라는�새로운�그림

자층이�창조된것을�볼수�있다.��

이�층을�선택하고�투영도구를�리용하여�그림자를

변형시킨다.�
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�

이와�같은�방법으로�《꽃병》에도�그림자효과를�적용한다.�

그림자효과창문에서�설정값은�사용자가�값을�변경시켜보면서�선택한다.�

결과화상은�그림과�같다.�
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작업층들을�모두�합치기한다.�

⑥�완성된�화상에�조명효과를�준다.�

화상창문에서�《려과기》→《조명》→《조명》지령을�실행한다.�

이때�펼쳐지는�《조명》대화칸에서�해당한�선택과�설정값들을�설정한�다음�《확인

(O)》단추를�찰칵한다.�
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⑦�완성된�화상을�보관한다.�
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제 4절. 화상처리 

일반적으로�사진기로�사진을�찍을�때�빛조절을�잘하지�못하거나�화상이�조금�회전되

고�초점이�맞지�않는�등�여러�현상이�나타난다.�

《환상》에는�이러한�결함들을�퇴치하는�좋은�기능들이�있다.�화상처리에서�가장�일

반적인�방법은�합성개선,�색개선,�예리성개선,�잡음(오염)제거�등이다.�

1. 합성개선 

①�화상의�회전�

사진을�찍을�때�사진기를�수직으로�정확히�유지하지�못하여�사진이�기울어지게�나

오는�현상도�있군�한다.�

각도가�틀린�화상을�기본도구창문에서�회전도구를�리용하여�바로잡을수�있다.�

기본도구창문에서�회전도구를�선택하면�《회전》창문이�펼쳐진다.�

�
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�

이�창문에서�중심값과�각도를�설정하여주거나�화상우에서�끌기하면�회전하는�격자

가�나타난다.�

�

�
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�

�

�

�

�

� 기울어진 화상 회전화상 바로선 화상 
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화상이�바로�서게�되면�《회전(R)》단추를�찰칵한다.�

②�화상의�따내기�

화상의�합성�또는�여러가지�화상작업을�위하여�화상에서�어떤�부분을�잘라낼�필요

가�있다.��

화상을�잘라내자면�기본도구창문에서�따내기도구를�선택한�상태에서�따내려는�부분

을�마우스끌기로�선택한다.�이때�네개의�조종점을�가지고�크기를�조종할수�있다.��

또는�따내기도구를�선택했을�때�나타나는�《따내기》대화칸에서�따내기할�위치와�크

기를�설정해준�다음�《따내기》단추를�찰칵하면�된다.�

�
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�

아래의�그림에서�달부분이�있는�화상을�따내기해보자.�
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�

따내기한�화상을�새로운�파일로�보관할수�있다.�

기본화상� 따내기선택� 따내기한 화상�
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2. 색상의 개선 

�

《환상》에는�빛조절이나�외부적요인에�의하여�색이�나빠진�사진들의�결함들을�없앨

수�있는�여러가지�색교정도구들이�있다.�

화상창문의�차림표에서�《층》→《색상》지령을�실행하면�색교정도구들의�차림표가�

현시된다.�
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①�로출문제�

-�밝기-대조도도구�

제일�간단한�방법은�밝기-대조도도구를�리용하는것이다.�

화상창문에서�《층》→《색상》→《밝기-대조도》지령을�실행하면�그림과�같은�대화

칸이�펼쳐진다.�
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�

대화칸에는�《밝기(B)》와�《대조도(T)》조종을�위한�두가지�조종띠가�있다.�

《미리보기(P)》를�선택하여�화상에�반영되는�조종결과를�볼수�있다.�

사용자의�의도에�맞게�조종이�정확히�되였다면�《확인(O)》단추를�찰칵한다.�

아래의�그림화상은�《밝기(B)》와�《대조도(T)》를�72로�준�결과이다.�

�

�

��

�

�

�

�

�

�

�

�

-�수준도구�

그라프의�정보에�토대하여�화상의�밝기를�조절할수�있다.�

화상창문에서�《층》→《색상》→《수준》지령을�실행하면�《수준》대화칸이

펼쳐진다.�

대화칸의�《입력�수준》부분에서는�256계단의�회색값을�나타내는데�제일�왼쪽에는�

완전한�검은색에�해당되는�0이,�오른쪽에는�흰색에�해당되는�255가�놓인다.��

또한�《출력�수준》의�아래에�있는�두개의�3각형을�조절하여�대조도를�조절할

수�있다.�

�

�

�

�

�

�

원래 화상 변화된 화상 

�

《입력�수준》과�《출력�수준》의�아래에�있는�3각형들을�끌기하면�

어떤�효과가�나타나는가?�

생각하기 
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-�곡선도구�

화상의�색조를�세밀하게�조절하기�위해서는�색상곡선을�리용한다.�

색상곡선을�리용하기�위하여�《층》→《색상》→《곡선》지령을�실행하면�《곡선》

대화칸이�나타난다.�

《곡선》대화칸의�색상곡선은�처음에�입력값과�출력값이�같기때문에�곡선이�대

각선으로�나타난다.��

곡선에�여러개의�점을�찍어�화상에서�다양한�값의�색을�보정할수�있다.�
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�

《곡선》대화칸의�《곡선류형》에서� ,� 단추들을�찰칵하면�어떻

게�되는가?�

생각하기 
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조종점을�리용하여�곡선을�변화시키면�그림과�같은�화상이�얻어진다.�
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②�색교정�

화상에서�붉은색과�푸른색이�지내�빠진�경우�제일�쉬운�교정방법은�수준도구를�리

용하는것이다.��

그러면�붉은색,�푸른색,�풀색통로에서�각각�수준을�조정할수�있다.�

색이�원만히�조정되였는지�알려면�기본도구창문에서�색상도구를�선택하고�화상

의�임의의�점을�선택한다.��

그러면�《색갈찾개》대화칸이�열리면서�선택된�색의�조정값이�나타난다.�
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�

만일�화상의�색이�낡았다면�색채-포화도도구를�사용하여야�한다.�

화상창문에서�《층》→《색상》→《색채-포화도》지령을�실행한다.�

그러면�《색채-포화도》대화칸이�펼쳐진다.�

대화칸에는�수정하기�위한�색상을�6가지로�가지고있는데�매�색상을�선택하고�《색

채》,�《밝기》,�《포화도》의�밀기자를�조종하여�원하는�색으로�조절한다.�
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�

실례로�아래의�그림에서�왼쪽그림은�색이�낡은�오래된�그림이고�오른쪽그림은�색채

-포화도도구로�조종한�그림이다.�

탐 구 
�

《색채-포화도》대화칸에서�《색상�초기화(E)》단추를�찰칵하면�어떤�현

상이�일어나는가를�알아보아라.�
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3. 선명도의 개선 

①�흐린�부분의�제거�

사진기의�초점이�정확히�설정되지�않았거나�사진기로�사진을�찍을�때�움직였다면�

결과는�흐트러진�화상이�얻어진다.�



�

�

243

만일�흐트러진�정도가�세다면�어떤�기술로도�방도가�없지만�적당히�흐트러졌다면

화상의�질을�높일수�있다.�

이런�화상을�선명하게�만들기�위한�가장�일반적인�기술을�비강조마스크라고�하며

이것은�잡음이나�흠집을�증가시키지�않고�요소들의�경계들을�예리하게�한다.�

화상창문에서�《려과기》→《강조》→《비강조마스크》지령을�실행한다.�

그러면�다음과�같은�《비강조마스크》대화칸이�펼쳐진다.�
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대화칸에서�미리보기를�설정하고�《반경》,�《총계》,�《턱값》을�조종하는�3개의�

밀기자를�끌기하여�조종한다.�

②�얼룩점없애기�

조명이�약한�조건에서�사진을�찍을�때�또는�로출시간이�매우�빠를�때에는�사진기가

충분한�자료를�얻지�못하며�그�결과�얻어지는�화상은�곰보처럼�보인다.�

이런�결함을�퇴치하는�방법에는�선택적인�정규분포초점흐리기려과와�얼룩제거려과

를�진행하는�방법이�있다.�

이것은�미리보기를�할수�있기때문에�사용자가�값을�설정해보면서�좋은�결과를�주는

값들을�찾을수�있다.�

그러나�화상이�완전히�나쁠�때에는�어떤�방법으로도�그것을�퇴치하기는�매우�힘들

기때문에�그리기도구로�수정하여야�한다.�
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③�부드럽게�하기�

화상이�지내�선명한�경우�해결방도는�약간�그것을�흐리게�하여�부드럽게�하는것

이다.�

화상을�흐리게�하는것은�선명하게�하는것보다�훨씬�더�쉽다.�

화상창문에서�《려과기》→《초점흐리기》지령을�실행하여�화상을�흐리게�할

수�있다.�

화상을�더�부드럽게�하려면�원하는�결과를�얻을�때까지�반복하여야�한다.�

�

4. 결함제거 

사진기로�찍은�화상에는�외부적인�요인�즉�렌즈의�먼지나�머리칼,�손자리�등에�의하

여�여러가지�결함들이�나타나며�결국�화상의�질을�손상시킨다.�

《환상》에는�이러한�결함들을�간단히�퇴치할수�있는�도구들이�있다.�

①�줄무늬제거�

먼지와�기타�렌즈의�결함을�없애는�좋은�도구는�줄무늬없애기려과기와�얼룩제거려

과기이다.�

화상창문에서�《려과기》→《강조》→《줄무늬없애기》�또는�《얼룩제거려과기》

지령을�실행하면�된다.�

결함이�있는�곳과�그�주위의�작은�구역을�선택하는것으로�시작을�하여야�한다.�선

택은�그안의�다른�화소들로부터�결함화소들을�통계적으로�구분할수�있도록�충분히�작아

야�한다.��

만일�전체�화상에�대하여�얼룩제거를�진행하면�좋은�화상을�얻기�힘들다.�

일단�선택을�하면�일반적인�형식을�선택하고�미리보기를�보면서�조종값들을�조종하

여야�한다.�

화상에서�하나이상의�결함을�가지고있다면�매�결함에�대하여�개별적으로�퇴치하여

야�한다.�

②�결함제거�

화상에서�불필요한�《잡음》을�없애는�가장�좋은�방법은�도장도구를�리용하여�진행

하는것이다.�

도장도구는�화상의�일부분을�복사하여�다른�부분에�자연스럽게�붙이는�도구이다.�

도장도구를�선택한�상태에서�복사령역을�설정하고�끌기하면�해당�화상이�복사된다.��

도장도구는�화상의�일부를�도장과�같이�복사하는�《더하는》기능뿐아니라�주변의�

견본을�떼내여�화상의�일부분을�없애치우는�《더는》기능도�가지고있다.�
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련습문제 

1.�화상처리에서�기본은�무엇인가?�

2.�색상도구에서�제일�많이�쓰이는�도구는�무슨�도구인가?�

3. 색상도구와�그리기도구와는�어떻게�차이나는가?�

4.�임의의�화상에서�색상도구를�리용하여�붉은색,�풀색,�푸른색을�제거해보아라.�어떤�

화상이�얻어지는가?�

�

실 습  

《빨간눈》지우기 

�

사진기를�정면으로�바라보는�사람을�사진찍으면�눈의�홍채가�사진기조명을�반사시

켜�그림과�같이�눈이�붉은색처럼�보이게�된다.�

《빨간눈》을�없애기�위해서는�다음과�같이�한다.�

먼저�눈주위를�확대하여�작업하기�쉽게�크고�섬세하게�보이도록�한�다음�타원형선

택도구로�눈의�빨간부분과�그�주위구역을�선택한다.�

�

�

�
�

�

다음�화상창문에서�《도구》→《색상도구》→《곡선》지령을�실행하여�이때�나타나

는�대화칸의�《통로》에서�《붉은색》을�선택한�다음�붉은색통로의�포화도를�떨군다.�
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�

결과�화상은�그림과�같다.�

�

�

�

�

�

�

�

�

�

�

�

�

종합문제 

�

1. 선택도구와�투영도구,�려과기를�리용하여�아래의�그림을�그려보아라.�

�

�

�

�

�

�

�

�

�

�

�
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2.�붓도구편집기를�리용하여�여러가지�형태의�꽃모양붓을�만들어보아라.�

그리고�붓도구와�려과기에서�프락탈도형을�리용하여�꽃나무를�만들어보아라.�

3. 자기가�살고있는�집안의�내부를�그려보아라.�

아래에�실례그림을�주었다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

4. 자기가�다니고있는�학교이름에�발광효과를�주어보아라.�

아래에�실례그림을�주었다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

5. 다음의�그림은�한개의�화상을�합성하여�물우에�비낀�나무의�모습을�형상하였다.�임의

의�화상을�가지고�이런�방식으로�화상합성을�해보아라.�
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6. 실내에서�찍은�사진의�배경을�야외배경으로�바꾸어보아라.�

�

�
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제 5장. 간단한 동화상만들기 

제 1절. 동화상프로그람 

1. 동화상에 대한 리해 

동화상이라고�하면�사진이나�그림(정지화상)과는�달리�움직이는�그림을�말한다.��

동화상은�정지화상들을�련속적으로�보여줌으로써�눈의�잔상효과를�리용하여�마치�

움직이는것처럼�보이게�한다.�동화상의�간단한�실례로�아동영화�같은것을�들수�있다.�

례를�들어�딱장벌레가�이동하는�동화상을�만든다고�하자.�

이것을�만들자면�다음과�같이�딱장벌레의�그림을�위치별로�그리고�그것들을�련속적

으로�보여주어�마치�딱장벌레가�움직이는것과�같이�보이게�한다.�

�

여기서는�딱장벌레의�위치만�바꾼�그림을�카드별로�그렸는데�모양과�색이�변하는�

그림을�그리게�되면�딱장벌레의�위치,�모양,�색이�변하는�동화상을�만들수�있다.�

콤퓨터를�리용하여�동화상을�만드는�방법에는�이와�같이�카드별로�그림을�그리는�

방법이�있고�또�처음위치와�마지막위치만�지정하고�그사이의�장면들은�콤퓨터가�자체로�

계산하게�하여�동화상을�만들어내는�방법도�있다.�

앞에서�본�카드를�Flash에서는�프레임이라고�한다.�

동화상제작프로그람에는�Flash�MX,�3ds�max,�Premiere,�Cool�3D�등이�있다.�

여기서는�Flash�MX에�대하여�보기로�한다.�

Flash는�Web용동화상제작프로그람이다.�Flash로�제작한�동화상을�Flash�Movie

라고�한다.��

Flash는�정지된�화면(프레임)을�련결하여�움직이는�화면을�만들어내고�여기에�배경

음악이나�음성효과�등을�주고�마우스의�작용에�따라�여러가지�동작을�수행하게�한다.�

2. Flash의 화면구성 

Flash는�Windows환경에서�동작하는�프로그람이므로�《붉은별》환경에서�실행시키

자면�Windows환경지원프로그람인�《만능》을�설치할�때�《프로그람설치》단계에서�

Macromeder�Flash�MX를�선택해주어야�한다.�
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이때�나타나는�《설치대화창》에서�《설치파일경로》를�선택하고�Flash�MX설치

파일경로를�지정해준�다음�《설치(S)》단추를�찰칵한다.��

�

�

�

�

�

�

�

�

�

�

�

�

�

�

그러면�Macromedia�Flash�MX가�설치되기�시작한다.�

6.0
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다음은�Flash�MX설치단계인데�Next단추를�찰칵한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

다음과�같은�사용허가와�관련한�대화칸에서�Yes단추를�찰칵한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

그러면�이름,�조직,�계렬번호를�입력하기�위한�대화칸이�나타난다.�
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이름,�계렬번호�등을�입력한�다음�Next단추를�찰칵한다.�

�

�

�

�

�

�

�
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�

�

설치를�어느�등록부에�하겠는가를�설정하는�다음의�대화칸에서�Next단추를�찰칵한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

(만일�다른�등록부에�설치하려면�Browse단추를�찰칵하고�등록부를�선택한다.)�

그러면�설치상태를�보여주는�화면이�나타난다.�
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Flash의�설치가�끝나면�《시작》→Macromedia�Flash�MX를�실행하거나�《시작》

→《응용프로그람》→《Windows응용프로그람》→Programs→Macromedia→Macromedia�

Flash�MX를�실행한다.�그러면�다음과�같은�화면이�펼쳐진다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

Timeline�

도구칸�

Stage�
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그림에서�보는바와�같이� Flash의�화면은�차림표와�도구칸,� Timeline(시간선)과�

Layer(층),�각종�Panel(조색판)�그리고�Stage(무대)로�이루어져있다.�

차림표에는�Flash에서�쓰이는�지령들이�부류별로�들어있다.�

도구칸에는�Flash에서�그림을�그리고�수정할수�있는�도구들이�들어있다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

Timeline에서는�시간에�따라�Movie의�내용을�구성한다.��

Flash에서는�필림처림�시간의�길이를�프레임으로�나눈다.�매�프레임은�자기의�고유

한�내용을�가질수도�있고�이전�프레임의�내용을�사용할수도�있다.�

�

�

�

�

�

�

�

�

�

�

Flash에서는�작업을�쉽게�하기�위하여�Layer를�리용한다.��

Timeline에서는�Layer와�프레임들을�관리한다.�

Stage는�작업을�진행하고�또�작업결과를�보는�부분이다.��

Stage에서�그림을�그리고�본문이나�음성,�단추를�추가하는�등�여러가지�작업을�하

며�여기에�있는것들만�Flash파일을�실행할�때�보인다.�
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이밖에도�작업화면에는�여러가지� Panel들이� 있는데� 표준적으로 � Color � Mixer�

Panel,�Color�Swatches�Panel,�Components�Panel,�Answers�Panel,�Properties�

Panel,�Actions�Panel이�표시된다.�나머지�Panel들은�차림표띠의�Window에�있는�

지령들을�실행하여�나타나게�할수�있다.�

Color�Mixer� Panel,� Color� Swatches� Panel에서는�색과�관련한�작업을�하며

Components�Panel에는�Flash에서�리용할수�있는�부분품들이�있다.��

그리고�Answers�Panel에서는�Flash작업에서�제기되는�의문점들에�대한�대답을�

준다.�Properties�Panel에서는�Flash파일의�가로,�세로�크기라든가�여러가지�도형의�

크기,�속성�등을�조절할수�있다.��

Actions�Panel에서는�Flash의�내장언어인�Action�Script를�리용하여�작업을�할수�있

게�한다.�

3. 간단한 실례 

례 1.�카드별로�된�동화상만드는�방법�

①�Flash를�기동한다.�그러면�새�작업파일이�열려져있다.�

②�Macromedia/Flash�MX/Samples/FLA서류철에�있는�Movement-buttons.�fla파

일을�열기한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�
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그러면�다음과�같은�화면이�펼쳐진다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

③�도구칸에서�선택도구� 를�선택하고�화면에서�딱장벌레를�찰칵한다.�

그러면�딱장벌레의�중심에�흰�점이�생긴다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

④�Edit→Copy지령을�실행한다.�혹은�Ctrl+C건을�누른다.�
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�

�

⑤�File→Close지령을�실행한다.�

⑥�파일을�보관하겠는가고�묻는�대화칸이�나타나는데�여기서�No단추를�찰칵한다.�

�

�

�

�

�

�

�

�

�

새로운�작업파일이�처음에�열려있었기때문에�화면에는�새로운�작업파일이�나타난다.�

⑦�Edit→Paste지령�혹은�Ctrl+V건을�누르면�작업화면에�딱장벌레가�나타난다.�

�

�

�

�

�

�

�

�

�

�

�

�

�
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⑧�Timeline에서�2번프레임을�선택하고�오른쪽찰칵하여�나타나는�지름차림표에서

Insert�Keyframe지령을�실행한다.�

�

�

�

�

�

�

�

�

�

�

�

�

그러면�Timeline이�다음과�같이�된다.�

�

�

�

�

�

�

�

�

�

⑨�Stage에서�딱장벌레를�끌기하여�이동시킨다.�

�

�

�

�

�

�

�

�

�

�

�

⑩�Timeline에서�3번프레임을�선택하고�⑧,�⑨의�과정을�반복한다.�

4,�5번프레임에�대하여서도�반복한다.�

그러면�Timeline은�다음과�같이�된다.�
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�

�

�

�

�

⑪�Window→Toolbars→Controller지령을�실행한다.�

�

�

�

�

�

�

�

�

�

그러면�Controller(조종)조종판이�나타난다.�

⑫� Controller조종판에서� Play단추를�찰칵한다.(혹

은�Enter건을�누른다.)�

그러면�Movie가�실행되는것을�볼수�있다.��

Movie실행을�멈추려면�Stop단추를�찰칵한다.(혹은�Enter건을�누른다.)�

Movie를�반복하여�계속�실행시키려면�Control→Loop�Playback지령을�실행한�다

음�Play단추를�찰칵하면�된다.�

�

�

�

�

�

�

�

�

�

�

�

�

⑬�File→Save지령을�실행하면�다음의�보관대화칸이�나타난다.�
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프레임과 키프레임에 대하여 

프레임이�자기의�고유한�내용을�가질수도�있고�이전�프레임의�내용을�가질

수도�있다는것을�앞에서�언급하였다.�

프레임에는�일반프레임(frame)과�키프레임(Keyframe)이�있다.�

일반프레임은�이전�프레임과�비교해볼�때�장면의�변화가�없는�프레임이다.��

그리고�Keyframe은�이전�프레임과�비교해볼�때�장면의�변화가�있는�프레임이다.��

Keyframe은�Timeline에서�조그마한�원이�있는것으로�표시된다.�원의�표시

가�검은색으로�나타나면�이전�프레임과�다른�그림이�나타난것이며�원의�표시가

흰색이면�아무것도�없는�프레임이다.�

�:�Keyframe�

�:�Blank�Keyframe�

앞에서�리용한�Insert�Keyframe은�이전�Keyframe에�있던�그림들이�삽입

된�Keyframe을�추가한다.��

그리고�Insert�Blank�Keyframe은�아무�내용이�없는�Keyframe을�추가한다.�

알아두기



�

�

261

례 2.�첫�장면과�마지막장면을�리용하여�동화상만들기(1)�

①�앞에서�본�례�1의�①�-�⑦단계를�반복하여�딱장벌레를�새�작업파일에�배치한다.�

1번프레임에�있는�딱장벌레의�위치를�아래로�한다.�

Timeline을�보면�1번프레임이�선택되여있는�상태이다.�

�

�

�

�

�

②�10번프레임을�선택하고�오른쪽찰칵하여�나타나는�지름차림표에서�Insert�Key�

frame지령을�실행하면�Timeline에�다음과�같이�표시된다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

③�Timeline에서�10번프레임이�선택되여있는가를�확인하고�딱장벌레의�위치를�

옮긴다.�
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�

�

�

④�Timeline에서�1번부터�10번사이의�임의의�프레임을�선택하고�오른쪽찰칵하여�

나타나는�지름차림표에서�Create�Motion�Tween지령을�실행한다.�

�

�

�

�

�

�

�

�

�

�

�

그러면�Timeline이�다음과�같이�달라진다.�

�

�

�

�

�

�

�

�

�

⑤�Enter건을�눌러�Movie를�실행해본다.�

그러면�딱장벌레가�아래에서부터�우로�올라가는것을�볼수�있다.�
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례 3.�첫�장면과�마지막장면을�리용하여�동화상만들기(2)�

①�File→New지령을�실행하여�새로운�작업파일을�연다.�

②�도구칸에서�원형도구� 를�선택한다.�

③�Stage에서�끌기하여�타원을�하나�그린다.�

�

������

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

④�Timeline에서�10번프레임을�선택하고�오른쪽찰칵하여�나타나는�지름차림표에서�

Insert�Blank�Keyframe지령을�실행한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

그러면�빈�작업화면이�나타난다.�

여기를�찰칵한다.�

끌기한다.�
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�

�

�

�

�

�

�

�

�

⑤�도구칸에서�4각형도구� 를�선택한다.�

⑥�Stage에서�끌기하여�4각형을�하나�그린다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

⑦�1번부터�10번사이의�프레임을�하나�선택한다.�

⑧�화면아래에�있는�Properties조색판을�펼친다.�
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�

�

�

�

�

�

�

�

�

�

�

�

⑨�Properties조색판의�Tween에서�Shape를�선택한다.�

�

�

�

�

�

�

�

�

그러면�Timeline과�Stage가�다음과�같이�된다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

⑩�Enter건을�눌러�Movie를�실행해본다.��

그러면�타원이�4각형으로�변하는것을�알수�있다.�

여기를�찰칵한다.�
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�

�

�

�

4. Layer와 Timeline 

Flash나�화상처리프로그람에서는�Layer(층)가�아주�중요한�개념이다.��

Flash에서도�화상처리프로그람�《환상》에서와�같이�Layer를�리용하여�그림의�위치

와�모양을�바꾸어�편집을�자유롭게�할수�있다.�

Flash를�기동하여�새로운�작업파일을�연다.��

Stage에�4각형을�하나�그린다.�

�

�

Timeline에서�Insert�Layer를�찰칵한다.�그러면�Layer가�하나�더�추가된것을�볼

수�있다.�

�

�

Symbol에 대하여 

�

후에�취급하겠지만�이�실례에서�본�딱장벌레는�Symbol이다.�Symbol이란

다시�사용할수�있는�도형,�단추,�Movie�Clip이다.�여기서�다시�사용할수�있다는

것은�어떤�대상을�Symbol로�만들면�Library에�보관되여�Library에서�Stage로

불러들이는�방법으로�언제든지�사용할수�있다는것이다.�

앞에서�본�실례에서�딱장벌레는�Symbol이므로�움직임설정이�된다.�

그런데�그리기도구로�그린�그림은�Symbol이�아니기때문에�앞에서와�같은�방

법으로�하면�움직이지�않는다.�

�

알아두기 
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�

�

�

�

�

�

�

Timeline에서�새로�생긴�Layer가�선택되여있는가를�확인하고�Stage에�원을�하나�

그린다.�

�

�

�

Timeline을�보게�되면�Layer우에�눈,�자물쇠,�4각형모양의�그림기호들이�있는것을�

볼수�있다.�

�

�

은�Layer의�내용을�표시�또는�숨김하는것으로서�이것을�찰칵하면�전체�Layer

의�내용이�표시되거나�또는�숨겨진다.�그리고�개별적인�Layer의� 을�찰칵하면�그

Layer에�해당한�내용이�표시�또는�숨겨진다.�
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�
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�

�

�

�

은�Layer를�편집할수�없게�한다.�해제하려면�이것을�다시�찰칵하면�된다.��

개별적인�Layer를�편집할수�없게�하려면�그�Layer의� 을�찰칵하면�된다.�

그리고�제일�오른쪽에�있는� 은�Layer의�내용을�외곽선형태로�나타나게�한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

개별적인�Layer만�외곽선형태로�나타나게�하려면�그�Layer의� 을�찰칵하면�된다.�

어떤� Layer를� 삭제하려면� 그� Layer를� 선택하고� 휴지통으로� 끌어다놓으면�

된다.�
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�
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�

�

�

�

�

�

Layer를�두번찰칵하면�이름편집상태로�되는데�이때�Layer의�이름을�바꾸어주면�

된다.��

그리고�Layer의�순서를�바꾸려면�Layer를�해당�위치에�끌어다놓으면�된다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

그림을�보고�알수�있는바와�같이�제일�아래에�있는�Layer가�배경으로�되고�그우의�

Layer들이�배경우에�놓이게�된다.�

Flash에서�매�Layer에는�Stage와�Overlay�두개의�준위가�있다.��

Flash에서�그리기작업을�하면�Stage준위에�그려진다.��

그리고�화상을�비롯하여�Flash에서�만들지�않은것들은�Overlay준위에�놓인다.�앞

으로�배우게�될�Group이나�Symbol�등도�Overlay준위에�놓인다.�

Layer안에서�Overlay준위는�Stage준위의�우에�놓인다.�
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실례를�들어�Stage준위와�Overlay준위에�대하여�보기로�하자.�

①�Flash를�기동하여�새로운�작업파일을�연다.�

②�File→Import지령을�실행한다.�

�

�

�

�

�

�

�

�

�

�

이때�나타나는�Import대화칸에서�적당한�화상파일을�선택하고�Open단추를�찰

칵한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

그러면�Stage에�화상이�들어온다.�
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�

�

�

�

�

③�Properties조색판을�펼치고�다음과�같이�설정한다.�

�

�

�

�

�

�

�

※� 여기서� 설정한� 값들은� 의미가� 있는� 수값들은� 아니다.� Movie의� 크기가� 550×

400pixel이므로� 화상의� 크기를� Stage의� 크기와� 같이� 주고� 중심점을� 일치시켜� 화상이�

Stage의�중심에�놓이게�한것이다.�

④�도구칸에서�원형도구� 를�선택하고�Stage에서�끌기하여�타원을�하나�만든다.�

�

�

�

�

�

�

�

�

�

�

�

�

타원을�그렸는데�Stage에서�보면�타원이�보이지�않는다.�

⑤�도구칸에서� 를�선택하고�Stage에서�화상을�끌기한다.�즉�그림의�위치를�이

동시킨다.�
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�

�

그림이�이동되면�그밑에�있는�타원이�보인다.�

이와�같이�Flash의�Layer에는�Stage준위와�Overlay준위가�있다는것을�알수�있다.�

앞의�실례에서�화상은�Overlay준위에�놓여있고�원은�Stage준위에�놓여있다.�그런

데�Overlay준위가�Stage준위의�우에�놓이므로�그려진�타원이�보이지�않은것이다.�

Stage준위에서는�도형들이�그려지는대로�련결된다.�

례를�들어�다음�그림에서와�같이�Stage에�두개의�타원이�그려졌다고�하자.(물론�두

개의�타원은�한�Layer에�놓여있다.)�

�

�

�

�

�

�

�

�

�

�

�

이제�도구칸에서�선택도구를�선택하고�어느�한�타원을�두번찰칵한다.�그러면�타원

과�테두리선이�선택된다.�

�

�

�

�

�

�

�

�

�
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다음�타원을�이동시켜본다.�

�

�

�

�

�

�

�

�

�

�

�

그림을�보고�알수�있는바와�같이�다른쪽�원의�겹친�부분이�잘리운것을�알수�있다.�

이처럼�Stage준위에서는�도형들이�그려지는대로�련결된다.�

그런데�Overlay준위에서는�도형들이�쌓이는�순서가�있다.�

다음�그림과�같이�3개의�원을�그린다.�

�

�

�

�

�

�

�

�

�

�

�

도구칸에서�선택도구를�선택하고�왼쪽아래에�있는�원을�선택한다.�

다음�Modify→Group지령을�실행한다.�

�

�

�

�

�

�

�

�

�

�
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다음�원을�가운데�웃부분에�있는�원에�겹쳐놓는다.�

�

�

�

�

�

�

�

�

�

�

�

다음�원을�제자리로�옮겨놓는다.�

�

�

�

�

�

�

�

�

�

�

�

그림을�보고�알수�있는바와�같이�웃부분에�있는�원에�아무런�변화도�없다.�그것은�

원을�Group화하였기때문이다.�Group은�Overlay준위에�놓인다.�

이번에는�Group화된�도형들의�순서에�대하여�보자.�

다음�그림과�같이�서로�다른�색의�원을�3개�그리고�Group화하고�다음과�같이�겹쳐

놓는다.�

�

�

�

�

�

�

�

�

�

�
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제일�밑에�깔려있는�푸른색원을�선택하고�차림표띠에서�Modify→Arrange→Bring�

to�Front를�실행한다.�

�

�

�

�

�

�

�

�

�

�

�

�

그러면�푸른색원이�제일�앞으로�나온다.�

�

�

�

�

�

�

�

�

�

�

�

다음�가운데층에�있는�원을�선택하고(노란색원)�Modify→Arrange→Send�Back�

ward를�실행한다.�그러면�노란색원이�뒤로�가는것을�알수�있다.�

�

�

�

�

�

�

�

�

�

�
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이처럼�Overlay준위에서는�도형�혹은�그림들이�겹쳐져도�서로�영향을�주지�않는다.�

�

�

�

�

�

�

�

�

�

�

�

Timeline에서�Layer에�대한�관리를�한다.�

여기서는�Timeline에�있는�그림기호들의�의미와�오른쪽찰칵하였을�때�나타나는�지

름차림표의�내용에�대하여�보기로�한다.�

�

�

�

�

�

�

�

�

�

�

� 모든�Layer들의�내용을�보이지�않게�한다.�다시한번�찰칵하면�보이게�된다.�

� Layer에�열쇠를�채운다.�

� Layer의�모형을�테두리선으로�표시한다.�

� 새로운�Layer를�추가한다.�

� Layer를�Guide�Line�Layer(안내선층)로�만든다.�

� 서류철을�추가한다.�

� Layer�혹은�서류철을�삭제한다.�

탐 구

Flash에서�Layer와�《환상》에서의�Layer는�같은가,�다른가?�그리고�그

관리방법의�차이점에�대하여�말하여라.�
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Layer를�오른쪽찰칵하면�다음과�같은�지름차림표가�표시된다.�

�

�

�

�

�

�

�

�

�

�

�

�

매�항목들의�기능은�다음과�같다.�

Show�All:�숨겨놓은것을�해제시킨다.�

Lock�Others:�모든�Layer에�열쇠를�채운다.�

Hide�Others:�모든�Layer가�보이지�않게�한다.�

Insert�Layer:�새로운�Layer를�추가한다.�

Delete�Layer:�선택된�Layer를�삭제한다.�

Guide:�Layer의�Line을�Guide로�만든다.�

Add�Motion�Guide:�Guide�Line�Layer를�추가한다.�

Mask:�Layer를�Mask로�만든다.�

Insert�Folder:�서류철을�추가한다.�

Delete�Folder:�서류철을�삭제한다.�

Expand�Folder:�서류철을�펼친다.�

Collapse�Folder:�서류철을�닫는다.�

Expand�All�Folder:�모든�서류철을�펼친다.�

Collapse�All�Folder:�모든�서류철을�닫는다.�

Properties:�Layer속성칸을�펼친다.�

Timeline에서�모형의�Animation을�설정해준다.�

�

�

�

�

�

�

�

Timeline의�매�그림기호들의�기능은�다음과�같다.�
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�Center�Frame:�프레임지적자를�현재�선택되여있는�프레임의�가운데�놓이도록�

한다.�

�Onion�Skin:�이전프레임의�모형을�보여준다.�

이것을�선택하면�모형들의�이동을�파악할수�있다.�Motion�Tweening이나�Shape�

Motion을�사용하면�이동경로를�쉽게�파악할수�있으며�수정도�편리하다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�Onion�Skin�Outlines:�이전프레임의�모형의�움직임을�테두리선으로�보여

준다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�Edit�Multiple�Frames:�Movie를�전체적으로�옮기거나�크기를�조절,�회전할�때�

사용한다.�이�기능을�활성화하고�수정하려는�모형을�선택하면�된다.��

모든�프레임에�쓰인�모형의�전체�위치를�수정할수�있기때문에�Movie에�쓰인�모형

과�Motion�등을�수정하기�편리하다.�
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�

�

�

�

�

�

�

�

�

�Modify�Onion�Markers:�프레임지적자를�중심으로�Onion�Skin의�표시범위를�

정하는�Option으로서�범위에�따라�모형의�범위가�다르게�나타난다.�

�Current�Frame:�현재�프레임지적자가�있는�곳의�프레임수를�나타낸다.�

�Frame�Rate:�1초동안에�재생되는�프레임수를�표시한다.�

기정값은�12이다.�이�값을�변화시키려면�이�부분을�두번찰칵하거나�차림표띠에서�

Modify→Movie지령을�실행하여�나타나는�Document� Properties대화칸에서� Frame�

Rate에�값을�입력하면�된다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�Elapsed�Time:�Movie의�재생시간을�표시한다.�

�

Timeline에�있는�프레임을�오른쪽찰칵하면�다음과�같은�지름차림표가�표시된다.�
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�

�

Create�Motion�Tween:�Graphic�Symbol,�Button�Symbol,�Movie�Clip

에�Motion�Tween을�적용한다.�Motion�Tween은�Symbol에만�적용된다.�

Insert�Frame:�프레임을�삽입한다.�

Remove�Frame:�프레임을�삭제한다.�

Insert�Keyframe:�키프레임을�삽입한다.�

Insert�Blank�Keyframe:�빈�프레임을�삽입한다.�

Clear�Keyframe:�선택된�키프레임을�삭제한다.�

Convert�to�Keyframes:�키프레임으로�변환한다.�

Convert�to�Blank�Keyframes:�빈�키프레임으로�변환한다.�

Cut�Frames:�선택된�프레임을�자른다.�

Copy�Frames:�선택된�프레임을�복사한다.�

Paste�Frames:�프레임을�붙인다.�

Clear�Frames:�프레임내용을�지운다.�

Select�All�Frames:�모든�프레임을�선택한다.�

Reverse�Frames:�프레임의�순서를�교체한다.�

Synchronize�Symbols:�앞뒤의�Symbol을�일치시킨다.�

Actions:�Action�Panel을�열기/닫기한다.�

Properties:�Properties�Panel을�열기/닫기한다.�

련습문제 

1.�Window차림표에�있는�지령들을�리용하여�Flash의�작업창문에�있는�창문들을�없애

거나�나타나게�해보아라.�

2.�Window→Toolbar→Main지령을�실행시켜�나타나는�표준지름그림기호들에서�다른�

프로그람들에도�있는것들은�어떤것들인가?�무슨�기능을�수행하는가?�

3.�Flash작업창문에�있는�도구칸을�비롯한�여러�창문들의�위치를�이동시켜보아라.�

4.�원이�타원으로�변하는�동화상을�만들어보아라.�

5.�직4각형이�바른4각형으로�변하는�동화상을�만들어보아라.�
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6.�Timeline의�Layer에�있는�그림기호들의�기능을�리용해보아라.�

7.�Bitmap화상을�불러오고�Group화하는�방법으로�그우에�원과�4각형을�그려보아라.�이

때�Bitmap화상과�원,�4각형을�한층에�놓이게�하여라.�

8.�Group화된�도형들을�여러개�만들어�겹쳐놓고�순서를�바꾸어보아라.�

9.�Timeline에�있는�그림기호들의�기능을�리용해보아라.�

(앞에서�만든�딱장벌레가�이동하는�파일을�리용하여라.)�

�

실 습  

Flash파일의 실행 

Flash에서�새로운�Movie를�만들자면�File→New지령을�실행한다.��

그리고�이미�작성되여있는�Flash파일을�보려면�File→Open지령을�실행한다.�

Open지령을�실행시켜�표준적으로�설치되여있는�견본파일들을�보자.�

File→Open지령을�실행하면�다음과�같은�대화칸이�나타난다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�
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Macromedia/Flash�MX/Sample/FLA서류철을�보면�여러가지�견본파일들이�있다.�

여기서�Timer.fla파일을�선택하고�Open단추를�찰칵한다.�그러면�파일이�열린다.�

�

이제�이�Flash�Movie를�실행시켜보자.�

Control→Test�Movie지령을�실행한다.�

�

�

�

그러면�Flash�Movie가�실행된다.�단추들을�찰칵하면서�Flash�Movie의�동작을�확

인해본다.�Movie검사를�끝내려면�차림표띠에서�File→Close지령을�실행한다.�

이제�Timer.fla파일이�있던�서류철을�보면�Timer.swf파일이�생긴것을�볼수�있다.�

Flash파일(확장자가�fla)은�편집이�가능하지만�swf파일은�편집할수�없다.��

Flash에서�Test�Movie지령을�실행하면�Flash파일이�들어있는�서류철에�swf파일

이�자동적으로�생긴다.�이렇게�만들어진�swf파일은�Flash에�의해�만들어졌기때문에�사

용자가�마음대로�수정할수�없다.�만일�사용자가�직접�swf파일의�설정값들을�조절하려

면�File→Export�Movie지령을�사용해야�한다.�

Flash에서�새로운�Movie를�만들자면�우선�새로운�파일을�만들어야�한다.��
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그런데�Flash프로그람을�실행하면�새로운�파일이�자동적으로�만들어진다.�그러므로�

사용자가�어떤�작업을�하다가�새로운�파일을�만들자면�File→New지령을�실행한다.�

Movie의�크기를�변경시키려면�Modify→Document지령을�실행한다.�

�

�

�

�

�

�

�

�

�

�

그러면�다음과�같은�대화칸이�나타난다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

새로운�Flash파일은�가로�550pixel,�세로�400pixel을�기본값으로�가진다.�

Document�Properties대화칸의�Dimensions에서�가로,�세로크기를�입력한다.�그

리고�Background�Color에서�Movie의�배경색을�설정한다.�

�

�

�

�

�

�

Document�Properties대화칸에서�Frame�Rate의�값을�변화시키면�

어떻게�되겠는가?�

생각하기 
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�

�

Document Properties대화칸에 대하여 

�

○�Dimentions�

여기서는�Stage의�가로와�세로크기를�설정한다.�가로,�세로의�크기는�1부터

2�880pixel까지이다.�

○�Match�

Stage의�크기를�자동적으로�설정한다.�

Printer단추를�찰칵하면�현재�인쇄기에�설정된�종이의�인쇄령역크기만�하게

Stage의�크기를�자동적으로�설정한다.�

Contents단추는�대체로�Flash�Movie를�완성한�다음에�리용하는데�이것을

찰칵하면�그림의�크기에�맞추어�Stage의�크기를�변경시킨다.�

Default단추를�찰칵하면�Stage크기를�기정값으로�설정한다.�

○�Background�Color�

여기서는�Movie의�배경색을�설정한다.�

○�Frame�Rate�

Flash�Movie를�재생할�때�1초에�몇개�프레임을�재생할것인가를�설정한다.�

기본값은�12fps(frame�per�second)이다.�

프레임이란�Flash에서�움직이는�장면의�최소단위로서�필림의�한�카드와�같이

생각하면�된다.�

○�Ruler�Units�

여기서는�눈금자의�단위를�설정해준다.�

�

알아두기 
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제 2절. 화상작업 

1. 화상처리방식 

콤퓨터화상처리방식에는�크게�두가지�종류가�있다.�

그중�하나는�pixel(화소)을�단위로�하여�화상을�표현하는�Bitmap방식의�프로그람

이다.��

여기서�pixel이라는것은�더�가를수�없는�그림의�제일�작은�쪼각이다.�마치�그라프

용지에�어떤�도형을�그렸다면�그라프용지의�제일�작은�한�칸이�1pixel인것이다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

우의�그림에서�보는바와�같이�Bitmap방식에서는�pixel단위로�화상을�표현하며�화

상을�구성하는�매�점들은�자기의�색을�가진다.��

그러므로�Bitmap방식의�화상처리프로그람에서는�종이에�연필로�그림을�그리는것처

럼�쉽게�작업을�할수�있다.��

그러나�pixel단위로�편집을�하기때문에�화상을�확대하여보면�테두리가�계단현상이�

나타나면서�매끄럽지�못한�결함이�있다.��

이런�계단현상이�일어나는�리유는�화상을�확대할�때�색을�표시하는�pixel들이�상대

적으로�크게�표시되기때문이다.��

그러므로�Bitmap방식으로�작업을�진행할�때에는�처음부터�화상파일의�크기를�잘�정

해놓고�작업을�진행해야�한다.�

A�

1pixel�
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100pixel�

1
0
0
p
ix
e
l�

50배 확대 100배 확대 

1pixel 

1pixel의 보임크기가 커진다. 

1pixel 

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

만일�작업도중에�화상의�크기를�크게�한다면�계단현상이�일어나게�된다.��

Bitmap방식의�프로그람들에서는�이�계단현상을�방지하기�위하여�Anti-Alias란�수

법을�리용한다.��

이�방법에서는�중간색을�가지는�pixel을�추가해주어�테두리선을�부드럽게�표시하도

록�한다.�그러나�이�경우에도�화상을�확대하면�거친�선이�나타나게�된다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

대표적인�Bitmap방식의�프로그람으로는�《붉은별》조작체계에서�사용하는�《환상》,�
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《화상편집기》�그리고�Windows조작체계에서�사용하는�Paint,�Adobe�Photoshop�등

을�들수�있다.�

화상처리방식의�다른�하나는�점,�선,�면을�리용하여�화상을�표현하는�Vector방

식이다.��

여기서는�선과�도형들을�겹쳐�쌓아가면서�하나의�그림을�완성한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

Vector방식에서는� 점과� 선들의� 자리표값

을�기준으로�하여�화상을�표현하며�프랑스의�

수학자� 베지어(Bezier)가� 내놓은� 베지어곡선

을�리용하여�곡선을�조종한다.�

그림에서�보는바와�같이�같은�점을�지나

는�곡선이라고�하여도�매�점들에서의�조종값에�

따라�곡선의�모양이�달라진다.��

그리고�Vector방식을�사용하면�화상을�확대하여도�테두리선이�미끈하게�된다.��

그것은�Vector방식에서는�점과�선의�위치에�준하여�화상을�표시하므로�화상을�확대

해서�표시하여도�자기�기본형태를�유지하게�된다.��

마치�그라프용지에�그림을�그려놓고�그것을�확대한다고�한다면�확대하기�전에�이웃

해있던�두�점이�확대되면�이웃한�두�점으로�되지�않고�그사이에�다른�점이�생겨�표시되

는것과�같다.�
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�

우의�그림에서�계단현상이�있는것으로�그림이�되여있는데�그것은�영상표시장치에서�

제일�작은�요소�즉�화면에서의�화소를�념두에�둔것이다.��

그러므로�실지�Vector방식에서는�도형을�그려놓고�아무리�확대하여도�계단현상이�

보이지�않는다.�

대표적인�Vector방식의�프로그람으로는�Adobe�Illustrator,�Corel�Draw,�Macro

media�FreeHand�등이�있다.�

Flash는�화상처리의�면에서�볼�때�Vector방식의�프로그람이다.�

Flash가�Vectror방식의�프로그람이므로�Flash에서의�그림은�선(Line)과�그�내부

를�채우는�면(Fills)으로�이루어져있다.�

�

�

�

x

y 

기준점 

화면의�화소�

선의�굵기만�두꺼워진다.�

50배�확대� 100배�확대�

x=y=1 인�점�

x=y=1.1인�점�

x=y=1인�점�

x=y=1.05인�점�

x=y=1.1인�점�

y=x 인�직선�
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2. Flash의 도구들 

○�원형도구� �

원형도구는�원이나�타원을�그릴�때�리용한다.��

이�도구를�선택하고�Stage에서�끌기하면�타원이�그려진다.�Shift건을�누르고�끌기

하면�원이�그려진다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

원형도구로�도형을�그릴�때�그려지는�선과�면의�

색은�도구칸의�Colors부분에서�한다.�

Stroke�Color에서는�테두리선,�Fill�Color에서

는�면의�색을�지정한다.�

Stroke�Color와�Fill�Color아래에�있는것들의�기능은�다음과�같다.�

:�테두리선은�검은색,�면의�색은�흰색으로�설정해준다.�

:�선�혹은�면의�색을�없앤다.�

:�선과�면의�색을�바꾸어준다.�

Stroke�Color나�Fill�Color에�있는�4각형모양의�그림기호를�찰칵하면�조색판이�나

타난다.�

�
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여기서�자기가�사용하려는�색을�선택하면�된다.�

만일�사용하려는�색이�없으면�조색판의�오른쪽�웃구석에�있는� 그림기호를�찰칵

하여�나타나는�창문에서�색을�선택하면�된다.�또는�Color�Mixer에서�색을�선택하여도�

된다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

테두리선의�굵기와�형식은�Properties의�Stroke�height와�Stroke�style에서�

한다.�
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칠해지는�면의�형식은�Color�Mixer�Panel의�Fill�style에서�설정한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

Fill�style의�Linear와�Radial은�경사도무늬색을�칠할�때�리용한다.��

Bitmap는�화상파일로�타원의�내부를�칠할�때�리용한다.�

○�4각형도구� �

4각형도구는�4각형,�둥근4각형을�그릴�때�리용한다.��

이�도구를�선택하고�Stage에서�끌기하면�4각형이�그려진다.�Shift건을�누르면서�끌

기하면�바른4각형이�그려진다.�

선의�굵기를�설정한다. 선의�모양을�설정한다.�
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4각형도구를�선택하면�도구칸의�Options에�Round�Rectangle�Radius

가�표시된다.�

이것은�둥근4각형을�만들�때�모서리를�어느�정도로�하겠는가를�결정

한다.��

Round�Rectangle�Radius를�찰칵하면�Rectangle�Settings대화칸이�나타난다.�

Corner�Radius에�적당한�값을�입력하고�Stage에�4각형을�그리면�둥근4각형이�그

려진다.�

�

�

�

�

�

�

�

�

테두리선과�면에�대한�내용은�원형도구와�같다.�

○�연필도구� �

연필도구는�실지�연필로�그린것�같은�선이나�도형을�그릴�때�

리용한다.�

연필도구를�선택하면�도구칸의�Options에� Pencil� Mode가�

표시된다.�

여기서는�마우스의�움직임을�어떻게�처리하겠는가를�설정한다.��

Straighten을�선택하면�마우스의�움직임을�직선으로�인식하고�그린다.��

Smooth를�선택하면�마우스의�움직임을�최대한으로�부드럽게�표현하며�Ink를�선택

하면�마우스의�움직임을�그대로�나타낸다.�

다음�그림은�연필도구의�방식을�바꾸어가면서�그린�그림이다.�
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실례로�연필도구를�리용하여�꽃을�그려보기로�하자.�

①�Flash를�기동하여�새�작업파일을�연다.�

②�도구칸에서�연필도구를�선택한다.�

③�Properties에서�선의�굵기를�4,�Stroke�style을�Solid로�설정한다.�

�

�

�

�

�

�

�

�

④� 연필도구의� 방식을� Straighten으로� 설정하고�

Stage에�원을�하나�그린다.�

그려보면�알수�있는바와�같이�정확한�원을�그리지�않았는데도�원모양이�된다.�

⑤�연필도구의�방식을�Smooth로�놓고�꽃잎을�그린다.�

�

�

�

그림을�보고�알수�있는바와�같이�Straighten보다�곡선이�자연스럽게�된다.�

⑥�줄기와�잎사귀를�그려서�그림을�완성한다.�

Straighten Smooth� Ink�
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○�붓도구� �

붓도구는�연필도구와�같이�기본적인�그리기도구로서�색을�칠할�때�리용한다.��

연필도구는�선을�그리는�도구이지만�붓도구는�면을�칠하는�도구이다.��

붓도구는�원형도구나�4각형도구와�마찬가지로�단일한�색�혹은�경사도무늬색,�Bitmap

화상으로�칠할수�있다.�

�

붓도구를�선택하면�도구칸의�Options부분에�Brush�Mode,�Brush�Size,�Brush�

Shape,�Lock�Fill이�나타난다.(아래�왼쪽그림)�

�

�

�

�

�

�

�

�

�

Brush�Mode에는�우의�오른쪽그림과�같이�5가지가�있는데�여기서는�Brush를�어떻

게�적용하겠는가를�설정한다.�
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Paint�Normal:�같은�Layer의�Fill,�Stroke부분을�칠한다.�

Paint�Fills:�Fill부분과�빈�부분을�칠한다.�

Paint�Behind:�같은�Layer의�빈�부분만�칠한다.�

Paint�Selection:�선택령역의�Fill부분만�칠한다.�

Paint�Inside:�붓으로�처음�찰칵한�Fill부분만�칠한다.�

Brush�Size에서는�붓의�크기를�설정하고�Brush�Shape에서는�붓의�모양을�설정한다.�

Fill�Lock는�경사도무늬로�색을�칠할�때�중심점을�고정시키는�역할을�한다.�Fill�

Lock를�선택하면�제일�마지막에�칠한�경사도무늬를�기억하고있다가�다시�경사도무늬를�

칠할�때�중심점을�일치시켜준다.�

○�잉크병도구� �

잉크병도구는�테두리선의�색,�두께�등을�변경할�때�리용한다.�이�도구는�테두리선

이�없는�도형에�테두리선을�만들어줄�때에도�리용한다.�

�

�

�

�

�

�

�

�

�

�

테두리선의�굵기와�형태는�Properties에서�한다.�
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○�선도구� �

선도구는�직선을�그릴�때�리용한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

선에 대하여 

�

Flash에서�사귀는�선들은(곡선도�포함하여)�사귐점을�기준으로�하여�개개로

갈라진것으로�본다.�

실례로�선도구나�연필도구를�리용하여�Stage에�사귀는�두�선을�그리자.�

�

�

알아두기 
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�

도구칸에서�선택도구( )를�선택하고�마우스지시자를�선에�가져간다.�마우

스지시자의�모양이� 와�같이�될�때�찰칵한다.�그러면�선의�토막이�선택되는것을

알수�있다.�

�

�

마우스지시자의�모양이� 와�같이�되였을�때�두번찰칵하면�련결된�선들이�모

두�선택된다.�

이처럼�선들이�사귀게�되면�사귐점을�중심으로�서로�다른�선으로�인식한다.

또한�사귀는�선이�아니라�하여도�선의�속성�즉�굵기,�형식,�직선인가,�곡선

인가�하는것들이�달라도�분리된�선으로�본다.�

례를�들어�보기�위하여�연필도구의�방식을�Straighten으로�해놓고�다음과

같이�곧은�부분과�구부러진�부분이�있는�선을�그려본다.�

�

�

선택된�토막
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이제�선택도구로�곡선부분을�선택하면�오른쪽에�있는�직선부분이�선택되지

않는다.�

�

다른�실례로서�선도구를�가지고�Stage에�직선을�하나�그린다.�

�
�

선택도구를�선택하고�Stage에서�끌기하는�방법으로�선의�가운데부분만�선택

한다.�

�

마우스를�

끌기한다.

선택되지�않는다.�
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○�손바닥도구� �

손바닥도구는�Stage에서�보임위치를�조절할�때�리용한다.��

다른�도구로�작업하는�도중에�공백건을�누르면�손바닥도구로�바뀐다.�

○�확대경도구� �

확대경도구는�화면을�확대하거나�축소할�때�리용한다.�

확대경도구를�선택하면�Options부분이�다음과�같이�된다.(오른쪽그림)�

+표식이�있는�확대경을�선택하면�작업화면을�확대하고�-표식이�있는�

확대경을�선택하면�작업화면을�축소한다.��

Alt건을�누르면�확대,�축소가�바뀐다.��

다른�도구로�작업하는�도중에�공백건과�Ctrl건을�누르면�확대경도구로�

바뀐다.�

�

그러면�가운데부분이�선택된다.�이제�잉크병도구의�형식을�점선으로�바꾸고

Stage에서�찰칵한다.��

다음�선택도구를�선택하고�Stage의�빈�부분을�찰칵하여�선택령역을�해제한

다.�그러면�선의�가운데부분이�점선으로�바뀐것을�알수�있다.�

�

�

�

이제�선택도구를�찰칵하는�방법으로�직선을�선택하면�직선의�속성이�다른�부

분이�선택되지�않는것을�알수�있다.�

�
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○�령역채우기도구� �

령역채우기도구는�닫긴�구역에�색을�칠하거나�면의�색을�수정한다.�

령역채우기도구를�선택하면�Options에�Gap�Size와�Lock�Fill이�표시된다.�

�

�

�

�

�

�

�

�

�

그림에서�보는�바와�같이�Gap�Size에는�4가지가�있는데�여기서는�틈이�있는�부분을�

어떻게�처리하겠는가를�설정한다.�

Don't�Close�Gaps:�테두리가�완전히�막힌�곳에만�적용된다.�

Close�Small�Gaps:�테두리에�미세한�틈이�있어도�적용된다.�

Close�Medium�Gaps:�테두리에�약간의�틈이�있어도�적용된다.�

Close�Large�Gaps:�테두리에�큰�틈이�있어도�적용된다.�

�

�

�

�

�

Lock�Fill의�내용은�붓도구에서와�같다.�

○�색상변환도구� �

색상변환도구는�경사도무늬의�크기,�방향,�그�중심을�조절할�때�리용한다.�
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색상변환도구를�선택하고�경사도무늬가�적용된�부분을�찰칵하면�다음의�그림과�같

이�된다.�

�

�

�

�

가운데있는�점은�경사도무늬의�중심점이고�4각형모양의�점은�경사도무늬의�가로세

로비,�다음�조종점은�크기,�마지막�조종점은�경사도무늬의�방향을�조종하는�점이다.�

�

�

�

�

�

실례로�립체감이�나는�구를�만들어보기로�하자.�

①�Flash를�기동하여�새�작업파일을�연다.�

②�도구칸에서�원형도구를�선택하고�Stage에�원둘레를�하나�그린다.�
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③�령역채우기도구를�선택하고�Fill�Color를�원형경사도로�설정하고�첫번째�색조종

점은�흰색,�두번째�색조종점은�검은색으로�설정한�다음�Stage에서�원의�아낙을�찰칵하

여�경사도무늬색을�칠한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

만일�립체감이�나게�보이지�않으면�색상변환도구를�리용하여�중심점을�이동시키면�

된다.�

○�자유변형도구� �

자유변형도구는�모형에�확대,�축소,�회전,�기울

이기�등과�같은�변형을�줄�때�리용한다.�

자유변형도구를�선택하면�Options에�Rotate� and�

Skew,�Scale,�Distort,�Envelope가�표시된다.�
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차림표띠에서�Modify→Transform에�있는�부분차림표지령들을�실행시키는�방법

으로도�모형들을�변형시킬수�있다.�

�

�

�

�

�

�

�

�

�

�

�

�

여기서�Flip�Vertical과�Flip�Horizontal은�화상을�우아래로,�량옆으로�대칭되게�

변환한다.�

�

�

�

�

�

○�색채집기도구� �

색채집기도구는�선의�색,�굵기�등의�속성을�얻어내는데�리용한다.��

이�도구로�면에�대한�색정보도�얻을수�있다.�이�도구를�리용하면�같은�속성을�가진�

그림을�그릴수�있다.�

이�도구로�선에�관한�정보를�얻어내면�자동적으로�잉크병도구로�바뀌고�면에�대한�

정보를�얻어내면�색붓기도구로�바뀐다.�

○�지우개도구� �

지우개도구는�잘못된�Fill부분이나�Stroke부분을�지울�때�리용한다.�

Stage에�있는�Fill,�Stroke부분을�한꺼번에�모두�지우려면�지우개도구를�두번찰칵

하면�된다.�

원본화상 Flip�Horizontal� Flip�Vertical�
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지우개도구를�선택하면�Options에�Erase�Mode,�Faucet(수도꼭지),�Erase�Shape

가�표시된다.�

�

�

�

�

�

�

�

�

�

�

�

�

Erase�Mode에서는�지우개도구를�어떻게�사용하겠는가를�설정한다.��

Erase�Mode에는�다음과�같이�5가지가�있다.�

Erase�Normal:�일반적인�지우개로서�선,�면부분을�지운다.�

Erase�Fills:�면부분만�지운다.�

Erase�Lines:�선부분만�지운다.�

Erase�Selected�Fills:�선택된�Fill부분만�지운다.�

Erase�Inside:�지우개도구로�처음에�찰칵한�닫긴�구역의�면부분만�지운다.�

어떤�닫긴�부분을�한꺼번에�지우려고�할�때에는�지우개도구의�Faucet를�찰칵하고�

지우면�된다.�

다음�그림은�지우개방식을�바꾸어가며�같은�동작을�한것이다.�

�

�

�

�

�

�

�

�

�

�

�

�

�
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○�선택도구� �

선택도구는�모형을�선택하고�모형의�위치를�이동시키고�모형의�모양을�변형할�때�

리용한다.�

Flash에서�Drawing모형들은�선과�면으로�이루어져있다.�이�두가지는�서로�분리되

여있으므로�따로따로�선택할수�있다.�

다음�그림은�선이�선택된�경우,�면이�선택된�경우,�두가지가�다�선택된�경우를�보

여준것이다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

선택도구가�선택된�상태에서�Drawing모형의�면을�찰칵하면�면이�선택된다.��

Shift건을�누른채로�찰칵하면�선택된�면이�추가된다.�선택령역을�해제하려면�그림

이�없는�빈�곳을�찰칵하면�된다.�또는�건반에서�Ctrl+Shift+A건을�누르면�된다.��

선이�선택된�경우� 면이�선택된�경우�

선과�면이�선택된�경우�
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두번찰칵하면�면과�그�주위에�있는�선들도�선택된다.�

선을�선택하기�위해서는�선택도구가�선택된�상태에서�Drawing모형의�선을�찰칵하

면�된다.��

선을�두번찰칵하면�같은�속성을�가지는�선들이�모두�선택된다.�선의�굵기와�색이�

다르면�선택되지�않는다.�

Stage에서�마우스를�끌기하는�방법으로도�선택령역을�지정할수�있다.�이때�그�범위

안에�있는�선과�면이�선택된다.�

�

�

�
�

�

선택도구의�모양에�따르는�기능은�다음과�같다.�

�선택도구상태�

�이동도구상태:�이때�찰칵하고�끌기하면�모형을�이동시킬수�있다.�

�곡선편집상태:�이때�찰칵하고�끌기하면�곡선을�수정할수�있다.�

�점편집상태:�이때�찰칵하고�끌기하면�개별적인�점의�위치를�이동시킬수�있다.�

�

다음의�실례를�통하여�선택도구를�리용한�도형의�이동에�대하여�보기로�하자.�

①�원형도구를�리용하여�Stage에�타원을�하나�그린다.�

Fill�Color와�Stroke�Color는�적당한�색으로�한다.�

②�View→Grid→Show�Grid지령을�실행하여�격자선이�나타나게�한다.�

끌기한다.�

선택령역�
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�

�

�

�

�

�

�

�

�

�

�

③�도구칸에서�선택도구를�선택하고�타원을�두번찰칵한다.�그러면�선과�면이�모두�

선택된다.�

�

�

�

�

�

�

�

�

�

�

�

④�타원의�중심부분에서�끌기한다.�

타원의�중심이�격자선에�맞추어지면�타원의�중심에�작은�원이�표시되는데�이때�마

우스단추를�놓는다.�

�

�

�

�

�

�

�

�

�

�

�

그러면�타원이�이동된다.�
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�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

자(Rulers)와 격자선(Grid), 안내선(Guide)에 대하여 

�

Flash에서는�도형을�그리거나�이동과�같은�편집을�편리하게�할수�있도록�자

와�격자선을�리용한다.��

View차림표에서�이에�대한�설정을�한다.�

View→Rulers를�실행하면�자가�나타난다.�단위는�pixel이다.�

View→Grid에는�다음과�같은�부분차림표지령들이�있다.�

�

�

�

Show�Grid를�실행하면�Stage에�격자선이�표시된다.��

그리고�Snap�to�Grid를�실행하면�도형을�그리거나�이동시킬�때�격자선에�맞

추어준다.��

그리고�Edit�Grid를�실행하면�다음과�같은�대화칸이�나타난다.�

�

�

�

�

여기서는�격자선의�색과�간격�등을�설정한다.�

View→Guides에는�다음과�같은�4가지�지령들이�있다.�

알아두기 
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�

�

다음은�선택도구를�리용한�도형의�변형에�대하여�보기로�하자.�

①�4각형도구를�리용하여�Stage에�직4각형을�하나�그린다.�

�

�

�

�

�

�

�

�

�

�

�

�

 

�

Show�Guides를�실행하면�안내선이�표시된다.�물론�안내선을�만들어놓아야

표시된다.��

안내선은�《환상》에서와�마찬가지로�자가�표시된�부분을�끌기하면�생긴다.�

Lock�Guides를�실행하면�안내선이�고정된다.�Snap�to�Guides를�실행하면�도형

을�그리거나�이동시킬�때�안내선에�맞추어진다.��

Edit�Guides를�실행하면�다음과�같은�대화칸이�나타난다.�

�
�

여기서는�안내선의�색�등을�설정한다.�
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②�마우스지시자를�선이�있는�부분에�가져가서�곡선편집상태로�만든다.�다음�마우

스를�찰칵하고�끌기하여�4각형의�모양을�변경시킨다.�

�

�

�

�

�

�

�

�

�

�

�

③�마우스지시자를�4각형의�정점에�가져가서�점편집상태로�만든다.�다음�마우스를�

끌기하여�정점을�이동시킨다.�

�

�

�

�

�

�

�

�

�

�

�

�

④�선도구를�리용하여�직선을�하나�긋는다.�

�

�

�

�

�

�

�

�

�

�

�
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⑤�마우스지시자를�사귐점에�가져가서�점편집상태로�만들고�마우스를�찰칵하여�끌

기한다.�

�

�

�

�

�

�

�

�

�

�

�

그러면�사귐점이�옮겨지면서�그에�따라�면도�달라진다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

도형의 이동을 정확하게 하려면 

�

선택도구를�리용하여�선�또는�면을�선택한�상태에서�방향건을�누르면�그�방

향으로�1pixel씩�이동한다.��

Shift건을�누르면서�방향건을�누르면�10pixel씩�이동한다.��

만일�정확한�자리표를�주려면�Properties에서�자리표값을�주면�된다.�

�

�

�

그리고�Snap기능을�리용하여�격자선이나�안내선에�맞추어주는�방법도�있다.

�

알아두기 
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선택도구를�선택하면�Options에�Snap�to�Objects,

Smooth,�Straighten이�표시된다.�

Snap�to�Objects가�선택되면�모형을�이동시킬�때�

다른�모형에�맞추어준다.�

어떤�곡선을�선택하고�Smooth를�찰칵하면�그�곡선을�

원활하게�해주고�Straighten을�찰칵하면�그�곡선을�직

선토막으로�만든다.�이것들은�여러번�적용할수��있다.�

다음의�실례를�통하여�Smooth와�Straighten의�리용법에�대하여�보기로�하자.�

①�도구칸에서�연필도구를�선택하고�방식을�Ink로�설정한다.�그러면�마우스의�움직

임을�그대로�나타낸다.�

②�연필도구로�Stage에�적당한�곡선을�그린다.�

�

�

�

�

�

�

�

�

�

�

�

③�File→Save지령을�실행시켜�작업파일을�적당한�이름을�주어서�보관한다.�

④�선택도구를�선택하고�Stage에서�끌기하는�방법으로�앞에서�그린�곡선을�모두�선

택한다.�

⑤�도구칸의�Optiopns에�있는�Smooth를�찰칵한다.�그러면�곡선이�원활해지는것을

알수�있다.�

�

�

�

�

�

�

�

�

�

�

Smooth를�여러번�적용하면�곡선이�보다�원활해진다.�

Snap�to�Objects

Straighten�

Smooth�
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�

�

�

�

�

�

�

�

�

�

⑥�File→Revert지령을�실행한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

그러면�다음과�같은�대화칸이�나타난다.�

�

�

�

이것은�마지막으로�보관된�상태로�되돌리면�Undo기능을�사용할수�없다는것을�알려

주는�경고대화칸이다.�

Revert명령은�파일을�닫고�다시�그�파일을�열기하는�명령이다.�그러므로�Undo기

능을�리용할수�없다.�대신�처음�상태로�되돌아가려고�할�때�Undo(Ctrl+Z)를�리용하면�

Ctrl+Z를�여러번�실행하여야�하므로�이런�때에는�Revert명령을�리용한다.�

Smooth 를�여러번�적용한�결과�



�

�

314�

Revert대화칸에서�Revert단추를�찰칵하면�처음에�보존된�상태로�된다.�

⑦�선택도구로�Stage에서�끌기하여�곡선을�다시�선택한다.�

⑧�도구칸의�Options에서�Straighten을�찰칵한다.�그러면�곡선의�모양이�변하는것

을�알수�있다.�

�

�

�

�

�

�

�

�

�

�

Straighten을�여러번�적용하면�마지막에는�직선으로�된다.�

�

�

�

�

�

�

�

�

�

�

선택도구의�Options에�있는�Smooth와�Straighten의�기능은�Modify차림표에�있

는�Smooth,�Straighten의�기능과�같다.�

�

�

�

�

�

�

�

�

�

�

�

�

Straighten을�여러번�적용한�결과�
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Modify→Optimize지령은�곡선을�최적화하는�지령이다.�이�지령을�리용하여�곡선

을�변환하면�불필요한�조종점들을�제거하므로�파일의�크기가�줄어든다.�

Modify→Optimize지령을�실행하면�다음과�같은�대화칸이�나타난다.�

�

�

�

�

�

�

�

�

�

�

Smoothing의�밀기자를�이동하여�최적화정도를�조절한다.�

Use�multiple�passes(slower)를�선택하면�여러번�곡선을�최적화하여�더�이상�최적

화할수�없을�때까지�최적화한다.�

Show�totals�message를�선택하면�최적화정보가�표시된다.�

다음�그림은�Smoothing을�중간정도에�놓고�최적화를�진행한�결과이다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

Optimize지령을�실행한�결과�
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�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

탐 구 
�

원형도구,�4 각형도구,�선택도구�등�Flash 의�도구들을�《환상》에서의�도구

들과�비교해보아라.�

�

�

선택도구에 의한 선과 면의 변형 

�

도구칸에서�선택도구를�선택하고�Ctrl건을�누르면서�끌기하면�새로운�조종점

이�생겨�직선�또는�오목한�곡선으로�된다.�

�

�

�

�

알아두기 

Ctrl건을�누른채로�끌기한다.�

Ctrl건을�누른채로�끌기한다.�
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○�부분선택도구� �

부분선택도구는�선�또는�면의�조종점들의�위치와�방향,�세기�등을�조절하는데�리용한다.�

부분선택도구로�조종점을�조종하려는�모형을�찰칵하거나�선택령역을�지정해주면�그

모형에�있는�조종점들이�표시된다.�

�

�

�

�

�

�

�

�

�

�

�

마우스지시자를�조종점에�가져가면�마우스지시자의�모양이� 과�같이�달라지는데�

이때�Alt건을�누르면서�끌기하면�조종점의�방향,�세기를�조절할수�있다.�또한�개별적인�

조종점을�찰칵하여�끌기하는�방법으로�위치를�옮길수�있다.�

실례로�부분선택도구를�리용하여�4각형의�모서리를�둥그렇게�하기�위해서는�다음과�

같이�한다.�

①�4각형도구를�선택하여�Stage에�4각형을�하나�그린다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

②�도구칸에서�부분선택도구를�선택하고�4각형의�테두리선을�찰칵한다.�그러면�조

종점들이�나타난다.�

끌기한다.

찰칵한다.
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③�오른쪽�웃구석에�있는�모서리에�마우스지시자를�가져간다.�

마우스지시자의�모양이� 과�같이�되였을�때�Alt건을�누르고�마우스를�끌기한다.�

그러면�4각형의�모서리가�둥그렇게�된다.�

조종점에�있는�파란색막대기의�길이와�방향을�조절하여�선의�모양을�바꿀수�있다.�

�

�

�

�

�

�

�

�

�

�

○�올가미도구� �

올가미도구는�자유롭게�선택령역을�지정할�때�리용한다.�

�

�

�

�

�

�

�

�

�

�

�
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올가미도구의�Options에는�Magic�Wand,�

Magic�Wand�Properties,�Polygon�Mode가�

있다.�

Magic�Wand는�Bitmap화상에서�비슷한�색

들을�선택할�때�리용한다.�

Bitmap화상의�비슷한�색을�선택하는�방법을�실례를�들어보기로�하자.�

①�File→Import지령을�실행시켜�Bitmap화상을�불러들인다.�

②�불러들인�화상이�너무�크거나�작으면�자유변형도구� 를�리용하거나�Proper�

ties에서�크기를�Stage크기로�조절한다.�

�

�

�

�

�

�

�

�

�

�

�

③�Modify→Break�Apart지령을�실행한다.�

Bitmap화상은�Flash에서�만든�파일이�아니므로�Flash에서�편집할수�없다.�그런데�

Break�Apart지령을�적용하면�Bitmap화상이�Drawing모형으로�된다.�

④�올가미도구를�선택하고�Options에서�Magic�Wand를�선택하고�화상을�찰칵한다.�

�

�

�

�

�

�

�

�

�

�

�

그러면�비슷한�색을�가진�부분들이�선택된다.�

Options에서�Magic�Wand�Properties를�찰칵하면�Magic�Wand의�색범위를�설정

해줄수�있다.��
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Magic�Wand�Properties를�찰칵하면�다음과�같은�대화칸이�나타난다.�

�

�

�

�

�

�

�

�

�

�

이�대화칸의�Threshold에서는�색선택범위를�설정한다.�이�값이�클수록�선택되는�

범위가�커진다.��

Smoothing에서는�선택령역의�경계를�어떻게�하겠는가를�설정한다.�pixel은�pixel

단위로,�Rough는�그보다�좀�낫게,�Normal은�보통,�Smooth는�부드럽게�한다.�

Polygon�Mode를�선택하면�다각형모양으로�선택령역을�만들수�있다.�

○�펜도구� �

펜도구는�주어진�어떤�곡선을�따라�정확한�선을�그릴�때�리용한다.�

펜도구를�선택하고�Stage에서�찰칵하면�직선이�그려진다.�그리고�마우스를�끌기하

면�곡선이�그려진다.�

실례를�들어보기로�하자.�

①�펜도구를�선택하고�Stage에서�찰칵하고�끌기한다.�그러면�다음�그림과�같이�조

종점과�조종손잡이가�표시된다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

②�Stage에서�다음점이�놓일�자리를�찰칵하고�마우스를�끌기한다.�

조종손잡이

조종점
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�

마우스를�놓으면�곡선이�그려진다.�

�

�

�

�

�

�

�

�

�

�

○�문자도구� �

문자도구는�문자렬작업을�할�때�리용한다.�

정지화상이나�동화상을�만들�때�설명을�하기�위하여�문자렬을�리용한다.�이런�문자

렬을�만들�때�문자도구를�리용한다.�그리고�문자렬의�서체,�크기,�색갈,�간격,�맞추기�

등과�같은�편집작업을�할�때에도�리용한다.�

문자렬은�Group이나�Symbol처럼�Layer의�Overlay준위에�놓인다.��

그리고� Break� Apart지령을�리용하여� Drawing모형으로�변환할수�있다.� 그런데�

Drawing모형으로�변환하면�서체변경이라든가�문자렬수정과�같은�문자렬편집작업을�할

수�없게�된다.�

문자도구를�선택하면�Properties에�문자도구와�관련된�설정항목들이�표시된다.�

�

�

�

�

�

�
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문자도구로�만들수�있는�문자렬에는�Static�Text(정적본문),�Dynamic�Text(동적

본문),�Input�Text(입력본문)가�있다.��

Static�Text는�고정된�내용을�가지는�문자렬이고�Dynamic�

Text는�수자로�표시되는�전자시계의�표시판처럼�내용이�달라지

는�문자렬이다.�그리고�Input�Text는�사용자의�입력을�받아들

이는�문자렬이다.��

문자렬의�형태는�Properties의�Times�New�Roman에서�

한다.�

실례로�문자렬�《내�나라�제일로�좋아》를�입력하기�위해서는�다음과�같이�한다.�

①�도구칸에서�문자도구를�선택하고�Stage에서�찰칵한다.�

②�문자렬�《내�나라�제일로�좋아》를�입력한다.�

�

�

�

�

�

�

�

�

�

�

�

�

이때�문자렬을�입력하는데�따라�본문칸이�넓어지는것을�알수�있다.�

③�이번에는�문자도구를�선택하고�Stage에서�끌기하는�방법으로�본문입력칸이�나타

나게�한다.�

④�건반으로�문자렬을�입력한다.�

�

�

�

�

�

�

�

�

�

�

�
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문자렬을�입력할�때�본문입력칸이�다�차면�줄바꾸기가�진행된다.�

실례에서�본바와�같이�Static�Text에는�확장가능한�본문칸과�확장불가능한�본문칸

이�있다.��

확장가능한�본문칸에는�오른쪽�웃구석에�동그라미가�표시되고�확장불가능한�본문칸

에는�4각형이�표시된다.�4각형표식을�두번찰칵하면�확장가능한�본문칸으로�변환된다.�

다음으로�문자렬을�Drawing모형으로�변환하는�방법을�실례를�들어보기로�하자.�

①�문자도구를�리용하여�Stage에�문자렬�《강성대국》을�입력한다.�

�

�

�

�

�

�

�

�

�

�

�

�

②�문자렬을�선택하고�Modify→Break�Apart지령을�실행한다.�그러면�매�글자별로

갈라진다.�

�

�

�

�

�

�

�

�

�

�

�

�

이�상태에서는�매�문자들이�서로�다른�모형으로�된다.�그러므로�문자단위로�작업할

수�있다.�

③�Modify→Distribute�to�Layer지령을�실행하면�매�문자들이�개별적인�층에

놓인다.�
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④�선택도구를�선택하고�어느�한�문자만�선택한다.�실례로�《강》을�선택한다.�

⑤�Modify→Break�Apart지령을�실행한다.�그러면�《강》이�Drawing모형으로�

된다.�

�

�

�

�

�

�

�

�

�

�

�

이제는�선택도구를�리용하여�글자의�모양을�바꿀수�있다.�

�

�

�

�

�

�

�

�

�

�

�

�
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련습문제 

1.�테두리선을�변화시키면서�원과�타원을�그려보아라.�

2.�Properties의�Custome단추를�찰칵하면�어떤�대화칸이�나타나는가?�Type의�내용을�

변화시키면서�원과�타원을�그려보아라.�

3.�경사도무늬가�적용된�원과�타원을�그려보아라.�

4.�4각형도구의�Stroke�Color와�Fill�Color를�변화시켜보면서�여러가지�4각형과�둥근4

각형을�그려보아라.�

5.�손바닥도구와�확대경도구는�왜�필요한가?�

6.�서로�다른�도형을�그리고�선과�면의�속성이�같아지도록�해보아라.�

7.�지우개도구의�방식을�변경시켜보면서�그�기능을�확인해보아라.�

8.�여러가지�도형을�그리고�선택도구를�리용하여�변형시켜보아라.�

9.�아무런�곡선을�그리고�Optimize지령으로�최적화해보아라.�

10.�Ctrl건을�누르고�선택도구로�선을�변형시킬�때�어떤�때�직선이�되는가?�

11.�선택도구와�부분선택도구와의�차이점은�무엇인가?�

12.�문자렬을�입력하고�해체하여�서로�다른�색갈이�되게�하여라.�

�

View차림표에 있는 지령들 

�

View차림표에는�보기와�관련된�지령들이�있다.��

여기서�Outline,�Fast,�Antialias,�Antialias�Text들은�모형들을�어떻게�보

여주겠는가를�설정하는�지령들이다.��

모형들을�선명하게�보여줄수록�작업량이�많아져�작업속도가�떠지게�된다.�

Outline:�모형의�테두리선만�화면에�나타난다.�그러나�본문에는�적용되지�않

는다.�

Fast:�모형의�색을�표시해주지만�문자렬은�거칠게�표시된다.�

Antialias:�문자렬을�제외한�모형들은�부드럽게�표시된다.�

Antialias�Text:�문자렬도�부드럽게�표시된다.�

�

알아두기 
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실 습  

1. 여러가지 도형그리기 

1) 얼굴모양그리기 

①�Flash를�기동하여�새�작업파일을�연다.�

②�Modify→Document를�실행한다.�여기서�작업파일의�크기를�300×200으로�설정한다.�

�

�

�

�

�

�

�

�

�

�

�

③�도구칸에서�원형도구를�선택한다.�

④�Properties에서�선의�굵기를�4,�Stroke�style을�Solid로�한다.�그리고�Fill�Color

를�None으로�한다.�

�

�

�

�

⑤�Stage에�원을�하나�그린다.�

�

�

�

�

�

�

�

�

�
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⑥�Properties에서�Fill�Color를�검은색으로�설정하고�Stage에�타원을�두개�그린다.�

�

�

�

�

�

�

�

�

�

⑦�Properties에서�Fill�Color를�없애고�Stage에�타원을�하나�더�그린다.�

�

�

�

�

�

�

�

�

�

�

�

그러면�얼굴모양이�만들어졌다.�

2) 나무모양그리기 

①�Flash를�기동하여�새�작업파일을�연다.�작업파일의�크기를�적당히�설정한다.�

②�도구칸에서�연필도구를�선택하고�선굵기는�1,�형식은�Solid로�설정한다.�

③�Stage에�나무잎사귀부분을�그린다.�

�

�

�

�

�

�

�

�

�

�
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④�나무의�줄기부분도�그린다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

⑤�도구칸에서�붓도구를�선택하고�Fill�Color를�R=51,�G=102,�B=0으로�설정하고�

붓도구의�Options를�Paint�Inside로�설정한다.�

�

�

⑥�붓도구를�리용하여�나무잎사귀부분을�칠한다.(이때�다문�곡선�안쪽을�처음으로�

찰칵하여야�한다.)�

�

�

�

�

�

�

�

�

�

�
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그림에서�보는바와�같이�잎사귀부분만�칠해졌다.�

⑦�붓도구의�Fill�Color를�R=51,�G=B=0으로�설정하고�우와�같은�방법으로�줄기부

분을�칠하면�나무모양이�완성된다.�

�

�

�

�

�

�

�

�

�

�

�

2. 유리고뿌만들기 

1) 빈 고뿌만들기 

①�Flash를�기동하고�새�작업파일을�연다.�

②�도구칸에서�원형도구를�선택하고�Stroke�Color는�R=70,�G=180,�B=255로,�Fill�

Color는�None으로�설정한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

③�Stage에�고뿌의�웃면과�밑면으로�될�적당한�크기의�타원을�그린다.�
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④�도구칸에서�선도구를�선택하고�우의�타원과�아래타원을�련결하여�고뿌모양을�만

든다.�

작업을�편리하게�하기�위하여�차림표띠에서�View→Snap�to�Objects가�선택되여있

는가를�확인한다.�

만일�선택되여있지�않으면�선택한다.��

이�기능이�선택되면�도형을�그리거나�이동시킬�때�다른�도형에�맞추어�처리한다.�

�

�

�

�

�

�

�

�

�

�

�

⑤�도구칸에서�선택도구를�선택하고�마우스지시자를�고뿌의�아래면에�있는�가리워

져서�보이지�않게�되는�곡선에�가져가서�찰칵하여�선택한�다음�Delete건을�눌러�그�부

분을�지운다.�

�

�

�

�

�

�

�

�

�

�

찰칵한다.
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⑥�선택도구가�선택된�상태에서�밑면의�보이는�곡선부분을�찰칵하여�선택한다.�마

우스지시자를�곡선에�가져가면�지시자의�모양이� 와�같이�되는데�이때�Alt건을�누르

면서�우로�끌기하여�곡선을�하나�복사한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

⑦� 도구칸에서� 색붓기도구를� 선택하고� Fill� Color를� R=220,� G=240,� B=255,�

Alpha=30으로�설정한�다음�고뿌의�기본부분을�찰칵하여�색칠한다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

⑧�색붓기도구의�Fill�Color를�Linear로�놓고�경사도무늬색의�첫번째�조종점을�R=G=B�

=255,�두번째�조종점을�R=70,�G=180,�B=255로�설정한�다음�고뿌의�밑부분에�경사도

무늬색을�채운다.�

찰칵한다.
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�

�

�

⑨�Timeline에서�Layer�1의�자물쇠그림기호위치를�찰칵하여�Layer�1을�고정시켜놓는다.�

�
�

2) 음료수만들기 

①�Timeline에서� Insert� Layer( )를�찰칵하여�새로운�층을�하나�만든�다음

Layer� 2가� 선택되여있는가를� 확인한다.� 그리고� 도구칸에서� 원형도구를� 선택하고�

Stroke�Color와�Fill�Color를�그림과�같이�설정한다.�

�
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②�앞에서�진행한�방법대로�음료수가�담겨져있는�부분을�그린다.�

�

�

�

�

�

�

�

�

�

③�도구칸에서�색붓기도구를�선택하고�Fill�Color를�Linear로�설정하고�첫번째�색

조종점은�R=255,�G=204,�B=0,�두번째�색조종점은�R=255,�G=255,�B=51로�설정한다.�

�

�

�

④�음료수의�웃부분을�칠한다.�

�

�

�

�

�

�

�

�

�

�

�

⑤�음료수의�기본부분도�칠한다.�
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�

�

�

⑥�Timeline에서�Layer�2에�열쇠를�채운다.�그리고�Layer�1의�열쇠를�해제한�다

음� 를�찰칵하여�새로운�층을�하나�더�만든다.�

�

�

�

⑦�Timeline에서�Layer�1을�선택하고�건반에서�Ctrl+C건을�눌러�빈�고뿌를�복사

한다.�

⑧�Layer�3을�선택하고�Ctrl+Shift+V건을�눌러�빈�고뿌를�그�자리에�붙이기한다.�

�

�

�

�

�

�

�

�

�

�

�

�
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실습문제 

다음�그림과�같은�도형들을�그려보아라.�

�

�

�

�

�

�

�

�

�

�

�

�

제 3절. Flash의 모형들 

1. Flash의 모형의 종류와 그것들사이의 변환 

Flash에서�취급하는�화상들에는�크게�보면�Drawing,�Bitmap,�Symbol,�Group

이�있다.�이것들을�통털어�모형이라고�한다.�

Drawing모형:�Flash의�그리기도구(연필,�붓�등)를�리용하여�그린것을�말한다.�

Group모형:� Drawing이나� Text� 등� 두개이상의� 모형을� 묶어놓은것을� 말한다.�

Group모형은�하나의�모형으로�인식된다.�

Symbol모형:�Symbol은�Flash에서�여러번�사용할수�있는�모형을�말한다.�Flash

의�Library에�보관되여�여러번�사용하여도�파일의�크기에는�영향을�주지�않는다.�

여기에는�Graphic�Symbol,�Button�Symbol,�Movie�Clip이�있다.�화상파일이나�

음성파일은�Symbol은�아니지만�Library에�보관되여�Flash에서�여러번�사용할수�있다.�

Bitmap모형:�Flash에서�만든�파일이�아닌�그림파일을�말한다.�Flash에서�그린�그

림이라고�하여도�화상파일로�출력하면�그것도�Bitmap모형으로�된다.�

Flash의�모형들은�다음과�같이�서로�변환할수�있다.�

○�Group,�Bitmap,�Symbol모형은�Drawing모형으로�변환할수�있다.�

○� Drawing,� Bitmap,� Symbol모형은� Group모형으로� 변환할수� 있다.� 그리고�

Group모형은�더�큰�Group모형으로�변환할수�있다.�

○�Drawing,�Group,�Bitmap모형은�Symbol로�변환할수�있다.�

이것을�그림으로�보면�다음과�같다.�
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�

�

Bitmap모형을�Drawing모형으로�변환하기�위해서는�Modify→Break�Apart�혹은

Modify→Trace�Bitmap지령을�실행하며�Bitmap모형을�Symbol모형으로�변환하기�위

해서는�Insert→Convert�to�Symbol지령을�실행하면�된다.�

�

�

�

Bitmap모형을�Group모형으로�변환하기�위해서는�Modify→Group지령을�실행하

면�된다.�

Drawing모형을�Symbol모형으로�또는�Group모형으로�변환하는�방법은�Bitmap모

형의�방법과�같다.�

Group모형을�Drawing모형으로�변환하기�위해서는�Modify→Ungroup�혹은�Modify

→Break�Apart지령을�실행하면�된다.�

매�모형들은�선택된�모양이�서로�다르다.�

Group모형과�Symbol모형은�둘다�파란색테두리가�나타나는데�Symbol모형은�가

운데�중심점의�위치가�표시되는것이�다르다.�

Drawing모형�

Symbol모형�

Group모형� Bitmap모형�
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�

�

�

�

�

�

�

�

�

�

�

�

Symbol모형� Bitmap모형�

Drawing모형� Group모형�

�

Export Image에 대하여 

Flash는�Vector방식으로�동작하는�프로그람이지만�작업결과를�Bitmap방식

의�화상으로도�출력할수�있다.�작업내용을�Bitmap방식의�화상파일로�출력하자면

File→Export�Image지령을�실행하면�된다.�

알아두기 
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�

2. Group모형 

여러�모형들을�Group모형으로�만드는것은�모형들을�선택하고�이동할�때�매�모형에�

대하여�일일이�작업하지�않고�한번에�하기�위해서이다.�

실례를�들어보기로�하자.�

①�도구칸에서�원형도구를�선택하고�Stroke�Color를�No�Color로,�Fill�Color

를�Linear로�설정한다.�

�

�

�

②�Stage에�타원을�하나�그린다.�

그러면�Export�Image대화칸이�나타나는데�여기서�Bitmap방식의�파일형식을

지정해주면�된다.�

�

�

�
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�

③�선택도구를�선택하고�타원을�선택한�다음�Edit→Copy지령을�실행하여�타원을�

복사한다.�

④�Edit→Paste�in�Place지령을�실행하여�그�자리에�타원을�붙여놓는다.�

⑤�도구칸에서�자유변형도구를�선택한다.�그러면�타원에�여러가지�변형을�할수�있

는�조종점들이�표시된다.�

�

⑥�Window→Transform지령을�실행한다.�그러면�Transform대화칸이�나타난다.�

�
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⑦�중심점을�밑면의�가운데로�옮기고�Transform대화칸의�Rotate에�120을�입력한다.�

�

�

�

그러면�타원이�120∘만큼�돌아간다.�

�

�

�

�

�

�

�

�

�

�

�

⑧�마찬가지방법으로�타원을�하나�더�붙이기하여�프로펠라를�완성한다.�

�

�

�

�

�

�

�

�

�

�

�

⑨�중심에�립체감이�나는�원을�하나�그려넣는다.�
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�

�

⑩�선택도구로�모두�선택하고�Ctrl+G건을�눌러�Group모형으로�만든다.�

�

�

�

�

�

�

�

�

�

�

�

⑪�자유변형도구를�선택하고�중심점을�가운데있는�원의�중심점으로�이동시킨다.�

�

�

�

�

�

�

�

�

�

�

�

⑫�선택도구로�프로펠라를�두번찰칵한다.�

그러면�Stage우에�있는�작업창문표시띠가�다음과�같이�된다.�

�

�
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여기서�Group이라고�표시된것은�Group모형편집상태라는것을�보여준다.�

이�상태에서는�Group화를�하지�않은것처럼�생각하고�작업할수�있다.�즉�프로펠라

의�색이라든가�모양�등을�수정할수�있다.�

⑬�Scene�1을�찰칵하여�Group편집상태에서�나온다.�

⑭�Stage에서�프로펠라를�선택하고�Transform대화칸의�Rotate에�아무런�값을�입

력해본다.�

�

�

�

�

�

�

�

�

�

�

�

�

프로펠라가�통채로�회전하는것을�알수�있다.�

이처럼�여러�모형들을�하나로�묶어서�Group모형을�만들면�개별적으로�조작하지�않

고�Group모형을�조작하면�되므로�작업이�편리해진다.�

이미�학습한바와�같이�Layer에는�Overlay준위와�Stage준위가�있다.�

Group모형은�Overlay준위에�놓인다.�만일�Overlay준위에�여러개의�모형이�있다

면�그것들사이의�순서문제가�제기된다.�이것은�Modify→Arrange에�있는�지령들로�해

결한다.�

�

�

�

�

�

�

�

�

�

�

매�지령들의�의미는�다음과�같다.�

Bring�to�Front:�모형을�제일�앞으로�이동시킨다.�

Bring�Forward:�모형을�한단계�앞으로�이동시킨다.�
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Send�Backward:�모형을�한단계�뒤로�이동시킨다.�

Send�to�Back:�모형을�맨뒤로�이동시킨다.�

Lock:�모형의�이동을�금지시킨다.�

Unlock�All:�모형이동금지를�해제한다.�

�

Group화한� 모형은� Modify→Ungroup� 혹은� Modify→Break� Apart지령으로�

Group을�해제한다.��

Ungroup지령은�Group으로�묶어진�모형만�해제한다면�Break�Apart지령은�모든�

모형들을�해체할수�있는데까지(일반적으로�Drawing모형이�될�때까지)�해제한다는데�

두�지령의�차이가�있다.�

실례를�들어�그�차이점을�보기로�하자.�

①�원형도구를�선택하고�Stage에�속이�빈�타원을�하나�그린다.�

�

�

�

�

�

�

�

�

�

�

�

�

②�원형도구로�립체감이�나는�원을�하나�더�그린다.�

�

�

�

�

�

�

�

�

�

�

�

�

③�선택도구로�원과�타원을�선택하고�Insert→Convert�to�Symbol지령을�실행한다.�

그러면�Convert�to�Symbol대화칸이�나타난다.�
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�

�

④�OK단추를�찰칵한다.(이것은�Drawing모형을�Symbol로�변환하는것이다.�Symbol에

대해서는�앞으로�보기로�한다.)�

그러면�타원과�원이�Symbol�1이라는�Graphic�Symbol로�된다.�

�

�

�

�

�

�

�

�

�

�

�

�

⑤�Ctrl+C건을�눌러�Symbol�1을�복사한다.�

⑥�Ctrl+Shift+V건을�눌러�그�자리에�붙이기한다.�

⑦�Ctrl+T건을�눌러�Transform대화칸을�열고�Rotate에�120을�입력한다.�

�

�

�

�

�

�

�

�

�

�

�

�

⑧�하나�또�붙이기하여�Rotate에�240을�입력한다.�
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�
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�

⑨�Edit→Select�All지령을�실행하여�Stage에�있는�모형들을�모두�선택한다.�

⑩�Ctrl+G건을�눌러�Group모형을�만든다.�

⑪�적당한�이름을�주어�보관한다.�

⑫�Ctrl+Shift+G건을�눌러�Ungroup지령을�실행한다.�

�

�

�

�

�

�

�

�

�

�

�

보는바와�같이�3개의�Graphic�Symbol로�해제되고�Ungroup지령은�더�적용할수�

없게�되였다.(회색으로�되였다.)�

�

�

�

�

�

�

�

�

�

�

�
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⑬�File→Revert지령을�실행시켜�마지막으로�보존한�상태로�되돌린다.�

⑭�Ctrl+B건을�눌러�Break�Apart지령을�실행한다.�

두번�실행시키면�다음과�같이�된다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

보는바와�같이�Graphic�Symbol도�해제되여�Drawing모형으로�되였다.�

�

앞에서�Bitmap화상파일에�대하여�Break�Apart지령을�적용하여�Flash에서�편집가

능한�Drawing모형으로�바꾸어보았다.�그러나� Flash에서�도구를�마음대로�적용할수�

없다.�

다음은�Break�Apart지령과�Trace�Bitmap지령의�차이를�실례를�들어보기로�하자.�

①�File→Import지령을�실행하여�적당한�Bitmap화상을�하나�불러들인다.�

�

�

�

�

�

�

�

�

�

�

�

�

②�Modify→Break�Apart지령을�실행하여�Bitmap화상을�Drawing모형으로�변환

한다.�

③�선택도구로�화상을�찰칵해보면�모두�선택된다.�
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�
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�

�

�

이것은�Bitmap에서�리용한�색정보를�선택도구가�인식하지�못해서이다.�

④�Ctrl+Shift+A건을�눌러�선택을�해제한다.�

⑤�올가미도구를�선택하고�방식을�Polygon으로�놓고�선택령역을�지정해준다.�그

러면�선택령역이�만들어진다.�

�

�

�

�

�

�

�

�

�

�

�

⑥�Ctrl+Z건을�눌러�Break�Apart지령을�적용하기�전�상태까지�되돌린다.�

⑦�이번에는�Modify→Trace�Bitmap지령을�실행한다.�그러면�Trace�Bitmap대화칸

이�나타난다.�

�

�

�

�

�

�

�

�

�
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Bitmap화상과�같은�Vector화상을�얻으려면�Color�Threshold를�10,�Minimum

Area를�1,�Curve�Fit를�Pixel,�Corner�Threshold를�Many�corners로�정하면�된

다.�그런데�이렇게�하면�Color�Threshold값이�작아서�많은�색이�사용되고�1pixel단

위로�추적하기때문에�Trace�Bitmap시간이�너무�길어진다.�

⑧�OK단추를�찰칵한다.�

그러면�Vector화상으로�넘기는�과정이�나타난다.�

�

�

�

�

�

�

Vector화상으로�바뀐�결과는�다음과�같다.�

�

�

�

�

�

�

�

�

�

�

이�상태에서는�선택도구로�선택할수�있으며�Flash의�그리기도구로�색을�바꾸어줄수

있다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

Trace Bitmap대화칸 

�

Trace�Bitmap대화칸의�내용은�다음과�같다.�

Color�Threshold:�색허용값으로서�이�값이�크면�색수가�줄어들고�범위가

넓어진다.�

Minimum�Area:�가장�작은�단위의�pixel수를�지정한다.�이�값을�작게�하면

섬세하게�화상을�처리한다.�

Curve�Fit:�테두리선을�부드럽게�하겠는가,�거칠게�하겠는가를�설정한다.�

Corner�Threshold:�경계선의�부드러운�정도를�설정한다.�

알아두기 
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3. Symbol에 대하여 

Flash의�Symbol에는�Graphic�Symbol,�Button�Symbol,�Movie�Clip이�있다.�

Graphic�Symbol은�일반적인�도형이나�그림과�같은�모형이다.��

Button�Symbol은�프로그람들에서�흔히�보게�되는�OK단추와�같이�사용자와의�호

상작용을�진행하는�모형이다.��

Graphic�Symbol이�정지된�화상이라면�Movie�Clip은�동화상Symbol이라고�생각

하면�된다.�

Flash에서�만들어지는�Symbol들은�자동적으로�현재�작업을�진행하는�파일에�대한�

Library에�들어간다.�

Symbol과�Library에�대하여�실례를�통해�보기로�하자.�

①�그리기도구를�리용하여�Stage에�도형을�하나�그린다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

②�Stage에�있는�도형을�선택하고�Insert→Convert�to�Symbol지령을�실행하면�다

음과�같은�대화칸이�나타난다.�

�

�

�

�

�

�

�

�

�

Behavior에서�Graphic를�선택하고�OK단추를�찰칵한다.�

③�Window→Library지령을�실행하면�그림과�같이�Library가�표시된다.�



�

�

350�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

④�자동차바퀴가�선택된�상태에서�F8건을�눌러�Convert�to�Symbol지령을�실

행한다.�

⑤�이번에는�Behavior에서�Button을�선택하고�OK단추를�찰칵한다.�그러면�Library�

에�Button�Symbol이�생긴것을�알수�있다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

⑥�마찬가지방법으로�Movie�Clip을�만들어본다.�
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�

�

�

�

�

�

�

�

�

�

�

�

�

�

Library에서�보면�Graphic�Symbol,�Button�Symbol,�Movie�Clip을�표시하는�그

림기호들이�서로�다른것을�알수�있다.�

다음은�Drawing모형과�Graphic�Symbol의�차이에�대하여�실례를�들어보기로�하자.�

①�4각형도구를�리용하여�Stage에�4각형을�하나�그린다.�

�

�

�

�

�

�

�

�

�

�

②�Timeline에서�10번프레임을�선택하고�오른쪽찰칵하여�나타나는�지름차림표에서�

Insert�Keyframe지령을�실행한다.�

�

�

�

�

�

�

�

�

�
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③�10번프레임이�선택된�상태에서�4각형을�다른�위치로�옮긴다.�

�

�

�

�

�

�

�

�

�

�

�

�

④�1번과�10번사이의�임의의�프레임을�선택하고�오른쪽찰칵하여�나타나는�지름차림

표에서�Create�Motion�Tween지령을�실행한다.�

�

�

�

�

�

�

�

�

�

�

�

Timeline을�보면�다음과�같이�된다.�

�

�

�

�

�

�

�

�

�

�

이것은�Motion�Tween이�적용되지�않았다는�표시이다.�즉�Drawing모형에는�Motion�

Tween이�적용되지�않는다.�
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⑤�Ctrl+Z건을�눌러�4각형을�만든�상태로�되돌아간다.�

⑥�4각형을�선택하고�Graphic�Symbol로�변환한다.�

그리고�②-④번�과정을�다시�수행한다.�

Timeline을�보면�다음과�같다.�

�

�

�

이것은�Motion�Tween이�적용되였다는것이다.�

Enter건을�눌러�실행시켜본다.�그러면�4각형이�이동하는것을�알수�있다.�

�

우의�실례에서�알수�있는바와�같이�Drawing모형으로는�Motion�Tween동화상을�

만들수�없다.��

그것은�Drawing모형은�점으로�이루어진�모형이므로�Motion�Tween을�적용하였을

때�매�점들이�따로따로�움직이게�되기때문이다.��

그러나�Group,�Bitmap,�Symbol은�하나로�묶어져있으므로�Motion�Tween을�적

용할수�있다.�앞으로�학습하겠지만�Shape�Tween의�경우에는�그림의�모양을�그대로�

변형하기때문에�Drawing모형도�가능하다.�

�

어떤�모형을�Symbol로�만들면�그것이�Library에�보관된다.��

Library에�보관된�Symbol은�Stage에서�그것을�없애버려도�Library에�그냥�남아

있다.�

Symbol과�Instance의�차이에�대하여�실례를�통해�보기로�하자.�

①�자동차바퀴를�그린�파일을�펼친다.�

②�Stage에�있는�모든�모형들을�없앤다.�

③�Ctrl+L건을�눌러�Library를�펼친다.�

Library에�자동차바퀴가�보관되여있다.�

④�Library에서�자동차바퀴�Symbol을�Stage에�끌어다놓는다.(미리보기칸에�있는

것을�끌기해도�되고�이름을�끌기해도�된다.)�
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�

그러면�Stage에�자동차바퀴가�나타난다.�

이것을�Symbol의�Instance라고�한다.�

Instance라는것은�Stage에�있는�Symbol의�복사본이다.�

⑤�Library에서�자동차바퀴를�또�끌어서�Stage에�배치한다.�

�

�

�

�

�

�

�

�

�

이처럼�Library에�있는�Symbol을�얼마든지�Stage에�끌어다놓을수�있다.�

Stage에�끌어다놓은�Instance들은�서로�영향을�주지�않고�변경시킬수�있다.�

⑥�자동차바퀴의�어느�한�Instance를�선택하고�자유변형도구를�리용하여�변형한다.�

�

�

�

�

�

�

�

�

�



�

�

355

⑦�어느�한�Instance를�선택하고�Properties를�펼친다.�

Color항목에서�Tint를�선택한다.�

�

�

�

�

�

�

�

⑧�적당한�색을�설정해준다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

알수�있는바와�같이�어느�한�Instance에�적용된�변형이�다른�Instance에는�적용되

지�않는다.�

⑨�어느�한�Instance를�선택하고�Edit→Edit�Selected지령을�실행한다.�

�

�

�

�

�

�

�

�

�

�

�

�
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⑩�자동차바퀴의�검은색을�다른�색으로�바꾸어준다.�

�

�

�

�

�

�

�

�

�

�

�

�

⑪�Edit→Document를�실행하여�Symbol편집상태에서�나온다.�

그러면�모든�Instance들이�변한것을�알수�있다.�

�

�

�

�

�

�

�

�

�

�

�

즉�Symbol을�편집하면�모든�Instance들이�갱신된다.�

�

Button�Symbol은�Flash�Movie에서�마우스의�찰칵이라든가�마우스지시자가�모형

우에�놓였다든가�단추호상작용을�만드는데�리용한다.�

차림표띠에서�Help→Lessons지령을�실행한다.�

�

�

�

�

�

�

�

�
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그러면�다음과�같은�창문이�펼쳐진다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

여기서�오른쪽부분에�있는�제목들에�마우스지시자를�가져가면�제목앞에�검은�원이�

표시된다.�그리고�그것을�찰칵하면�그에�해당한�내용이�펼쳐진다.��

집모양의�그림기호를�찰칵하면�처음상태로�되돌아간다.�이처럼�Button�Symbol은�

마우스의�동작에�따라�장면을�바꾸기도�하는�등�사용자와의�호상작용을�보장한다.�

Button�Symbol을�만들어보기로�하자.�

①�Edit→Deselect�All지령을�실행한다.�

�

�

�

�

�

�

�

�

�

�

�

�
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만일�아무것도�선택되여있지�않으면�이�지령을�실행시킬수�없다.�

이�지령을�실행시키는것은�Stage에�있는�어떤�모형도�선택하지�않은�상태로�만들기

위해서이다.�

②�Insert→New�Symbol지령을�실행하면�Create�New�Symbol대화칸이�나타난다.�

�

③�대화칸에서�Name에�《단추》라고�입력하고�Behavior에서�Button을�선택한�다

음�OK단추를�찰칵한다.�

그러면�Button�Symbol편집상태로�들어간다.��

Stage우에�있는�작업창문표시띠에�《단추》라고�표시된다.�

�

�

�

Timeline을�보면�다음과�같다.�

�

�

�

�

�

�

�

�

Button�Symbol은�4개의�프레임을�가진다.�첫�3개의�프레임은�Button�Symbol의�

가능한�세가지�상태를�표시하며�4번째�프레임은�단추의�령역을�표시한다.�

Button�Symbol의�Timeline에�있는�매�프레임의�기능은�다음과�같다.�

∙�Up프레임은�마우스지시자가�단추우에�있지�않을�때의�단추의�모양이다.�

∙�Over프레임은�마우스지시자가�단추우에�있을�때의�단추의�모양이다.�

∙�Down프레임은�마우스단추를�눌렀을�때의�모양이다.�

∙�Hit프레임은�마우스의�찰칵에�응답하는�령역을�정의한다.�이�령역은�Movie에서�

보이지�않는다.�

Button�Symbol의�프레임에�Movie�Clip이�들어갈수�있다.�그러면�움직이는�단추

를�만들수�있다.�
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④�그리기도구를�리용하여�도형을�그리거나�Bitmap화상을�불러들이든가�혹은�다른�

Symbol의�Instance를�Stage에�배치하여�Up상태�단추의�모양을�완성한다.�그러나�다

른�Button�Symbol은�리용할수�없다.�

⑤�Over프레임을�선택하고�Insert→Keyframe지령을�실행한다.�

⑥�Over상태를�나타내는�도형을�그린다.�

이때에도�Bitmap화상이나�다른�Symbol의� Instance를�리용할수�있으며�Button�

Symbol은�리용할수�없다.�

⑦�Down프레임과�Hit프레임에�대하여�⑤-⑥번�과정을�반복한다.�

Hit프레임에�있는�도형이�Up,�Over,�Down프레임에�있는�모형을�모두�포함하는가

를�확인해야�한다.�만일�Hit프레임을�지정하지�않으면�Up프레임에�있는�모형을�Hit프

레임에�리용한다.�

단추에�음성을�추가할�때에는�추가하려는�프레임을�Timeline에서�선택하고�Properties의�

Sound에서�설정해주면�된다.�

�

�

�

�

�

�

Sound는�미리�Import지령으로�불러들

여놓아야�한다.�

⑧� Edit→Document지령을� 실행시켜

Button편집상태에서�나온다.�

⑨� Library에서� 《 단추 》 Symbol을�

Stage에�끌어다놓는다.�

⑩�Control→Enable�Simple�Button

지령을� 실행한다.� 그래야� 단추의� 동작을�

Stage에서�확인할수�있다.�

Stage에서�단추의�동작을�확인해본다.�

Movie�Clip은�다시�리용하는�동화상을�만들�때�리용한다.��

례를�들어�자동차가�이동하는�동화상을�만든다고�하자.��

이때�바퀴가�돌아가는�동화상을�만들고�Movie�Clip으로�만든다.�다음�이것을�앞바

퀴,�뒤바퀴에�배치하고�이동시키면�바퀴가�굴러가면서�이동하는�동화상을�쉽게�만들수�있다.�

Movie�Clip은�자기의�고유한�Timeline을�가지고있다.�이것은�기본�Flash파일의�

Timeline과�다르다.�그러므로�기본�Flash파일이�정지되여도�Movie�Clip은�그냥�동작

한다.�그리고�Movie�Clip의�Instance를�Button�Symbol의�어느�한�프레임에�배치하

여�움직이는�단추를�만들수�있다.�

Movie�Clip만들기를�실례를�통해�보기로�하자.�
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①�새로운�작업파일을�연다.�

②�Insert→New�Symbol지령을�실행한다.�

이때�나타나는�대화칸의�Behavior에서�Graphic를�선택하고�OK단추를�찰칵한다.�

③�Stage에�적당한�타원을�그린다.�

�

�

�

�

�

�

�

�

�

�

④�타원을�복사하여�붙인다.�

�

�

�

�

�

�

�

�

�

�

⑤�색상변환도구를�리용하여�경사도무늬색방향을�바꾸어준다.�

�

⑥�Stage우에�있는�작업창문표시띠에서�Scene�1을�찰칵한다.�
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�

⑦�Insert→New�Symbol지령을�실행하여�나타나는�Create�New�Symbol대화칸의�

Behavior에서�Movie�Clip을�선택하고�OK단추를�찰칵한다.�

⑧�Library에서�앞에서�만든�Graphic�Symbol을�Stage에�끌어다놓는다.�

�

�

�

⑨�Timeline의� 20번프레임을�선택하고�오른쪽찰칵하여�나타나는�지름차림표에서�

Insert�Keyframe지령을�실행한다.�

⑩�1~20번사이의�임의의�프레임을�선택하고�Properties의�Tween에서�Motion을�

선택한다.�

�

�

�

�

�

⑪�Properties의�Rotate에서�CW를�선택한다.�

�

⑪�Properties의�Rotate에서�CW를�선택한다.�

�

�

�

�

�

�

�

화면을�보면�프로펠라가�기울어진것을�알수�있다.�



�

�

362�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

⑫�Stage우에�있는�작업창문표시띠에서�Scene�1을�찰칵한다.�

⑬�Library에서�앞에서�만든�Movie�Clip을�Stage에�배치한다.�

⑭�Ctrl+Enter건을�눌러�실행시켜본다.�

그러면�프로펠라가�돌아가는것을�알수�있다.�

�

련습문제 

1.�각�모형들사이의�변환을�진행해보아라.�

2.�Flash에서�작업한�파일을�Bitmap형식의�화상파일로�출력해보아라.�

3.�여러개의�Group모형을�만들어놓고�Modify→Arrange에�있는�지령들을�리용하여�

순서를�바꾸어보아라.�

4.�여러가지�모형을�만들어�Ungroup과�Break�Apart지령의�차이를�알아보아라.�

5.�Bitmap화상을�불러들이고�Trace�Bitmap의�설정값들을�변화시키면서�Vector화상으

로�변환시켜보아라.�

6.�Group모형을�하나�만들고�Motion�Tween을�적용해보아라.�

7.�Graphic�Symbol을�만들고�Instance들을�만든�다음�개별적인�Instance들을�변형시

켜보아라.�그리고�Symbol을�변형시켜보아라.�

8.�음성효과를�주어�여러가지�단추를�만들어보아라.�

9.�여러가지�Movie�Clip을�만들어보아라.�

�

Rotate에서�CCW를�선택하면�어떻게�되는가를�알아보아라.�

생각하기 
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실 습 

단추만들기 

1) 단추에 쓰일 Movie Clip만들기 

①�Insert→New�Symbol지령을�실행한다.�

Behavior에서�Movie�Clip을�선택하고�OK단추를�찰칵한다.�

②�도구칸에서�문자도구를�선택하고�Wingdings서체를�선택한다.�

�

�

�

�

③�대문자�H를�입력하면�손가락모양이�생긴다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

④�Timeline에서�10번프레임을�선택하고�오른쪽찰칵하여�나타나는�지름차림표에서�

Insert�Keyframe지령을�실행한다.�

⑤�손을�아래로�이동시킨다.�

⑥�20번프레임을�선택하고�오른쪽찰칵하여�나타나는�지름차림표에서�Insert�Keyframe지

령을�실행한다.�

⑦�손을�다시�제자리로�가져간다.�

⑧� 1번부터� 20번프레임을�선택하고�오른쪽찰칵하여�나타나는�지름차림표에서�Create�

Motion�Tween지령을�실행한다.�

이렇게�하여�손가락이�우에서�아래로�내려왔다가�올라가는�Movie�Clip이�만들어졌다.�
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2) 단추만들기 

①�Insert→New�Symbol지령을�실행한다.�

Behavior에서�Button을�선택하고�OK단추를�찰칵한다.�

②�Stage에�단추로�쓰일�4각형을�하나�그린다.�

③�Over프레임을�선택하고�오른쪽찰칵하여�나타나는�지름차림표에서�Insert�Keyframe

지령을�실행한다.�

④�Ctrl+L건을�눌러�Library를�열고�앞에서�만든�Movie�Clip을�Stage에�끌어다

놓는다.�

�

�

�

�

�

�

�

�

�

�

�

⑤�도구칸에서�문자도구를�선택하고�간단한�설명문을�입력한다.�

�

�

�

�

�

�

�

�

�

�

�

�

⑥� Down프레임을� 선택하고� 오른쪽찰칵하여� 나타나는� 지름차림표에서� Insert�

Blank�Keyframe지령을�실행한다.�

그리고�마우스단추를�눌렀을�때의�단추를�그린다.�

⑦�단추편집창문에서�탈퇴하여�기본화면으로�나온다.�

⑧�Library에서�방금�만든�단추를�끌기하여�Stage에�배치하고�Ctrl+Enter건을�눌

러�단추의�동작을�시험해본다.�
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실습문제 

1.�1번부터�10번프레임에�모두�키프레임을�삽입하고�Transform의�Rotate값을�프레임

마다�다르게�주는�방법으로�프로펠라가�회전하는�동화상을�만들어보아라.�

2.�자동차바퀴를�그리고�Graphic�Symbol로�변환하여라.�

3.�Hit프레임에�있는�모형이�Up,�Over,�Down프레임에�있는�모형보다�작으면�어떻게�

되는가를�실지�해보아라.�

�

�

제 4절. 동화상만들기 

1. Flash동화상의 종류 

Flash에서�동화상을�만드는�방법에는�두가지가�있다.��

하나는�프레임이라고�하는�정지화상을�여러개�만들어서�시간의�흐름에�따라�련속적

으로�보여주는�프레임동화상이고�다른�하나는�첫번째�프레임과�마지막프레임만�주고�나

머지부분은�콤퓨터가�계산하여�만들어주는�Tweening동화상이다.�

프레임동화상은�영화에서�많이�쓰는데�1초동안에�24개프레임을�바꾸는�방법으로�화

면의�움직임을�표현한다.��

Flash에서�사용하는것은�주로�Tweening동화상이다.�

Tweening동화상에는�Motion�Tweening과�Shape�Tweening이�있다.��

Motion�Tweening은�Group이나�Symbol,�Bitmap,�문자렬과�같은�모형에�크기,�

위치,�회전,�색�등의�변화를�주어�동화상을�만드는것을�말한다.��

Shape�Tweening은� Drawing모형의�모양을�변화시켜�동화상을�만드는것을�

말한다.�

�

�

�

�

�

�

�

�

�

�

�
Motion�Tweening
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�

�

�

�

�

�

�

�

�

�

�

�

프레임에�대한�관리는�Timeline에서�한다.�

실례를�들어보자.�

①�Flash를�기동하여�새�작업파일을�연다.�

②�Stage에�적당한�크기의�원을�하나�그린다.�

③�원을�선택하고�Ctrl+G건을�눌러�Group모형으로�만든다.�

④�Timeline에서�5번프레임을�선택하고�오른쪽찰칵하여�나타나는�지름차림표에서

Insert�Keyframe지령을�실행한다.��

Stage에�원이�그냥�표시되여있다.�

⑤�5번프레임이�선택되여있는�상태에서�원의�위치를�이동시킨다.�

⑥�6번프레임을�선택하고�오른쪽찰칵하여�나타나는�지름차림표에서�Insert�Blank�

Keyframe지령을�실행한다.�그러면�빈�Stage가�표시된다.�

⑦�Stage에�원을�하나�그린다.�

⑧�10번프레임을�선택하고�오른쪽찰칵하여�나타나는�지름차림표에서�Insert�Blank�

Keyframe지령을�실행한다.�

⑨�Stage에�오각별을�하나�그린다.�

Timeline이�다음과�같이�되여있다.�

�

�

⑩�1번부터�5번까지�프레임을�선택하고�Properties의�Tween에서�Motion을�선택한다.�

Shape�Tweening�
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�

⑪�6번부터�10번사이의�프레임을�선택하고�Properties의�Tween에서�Shape를�선

택한다.�그러면�Timeline이�다음과�같이�된다.�

�

이제�Timeline에서�Onion�Skin( ),�Onion�Skin�Outlines( ),�Edit�Multiple

Frames( ),�Modify�Onion�Markers( )를�선택해보면서�Stage가�어떻게�달라지

는가를�본다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�
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Enter건을�눌러�실행해보면�처음에�원이�이동하고�다음�원이�오각별로�변한다.�

⑫�Timeline에서�1번프레임을�선택한다.�

⑬�1번프레임을�11번프레임에�끌어다놓는다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

그러면�1번프레임은�빈키프레임으로�된다.�

⑭�마찬가지방법으로�5번프레임을�선택하고�15번프레임으로�끌어다놓는다.�

�

�

�

�

�

�

�

�

�

⑮�1번부터�5번까지�프레임을�선택하고�오른쪽찰칵하여�나타나는�지름차림표에서�

Remove�Frames지령을�실행한다.�

�

�
�

그러면�프레임이�삭제된다.�
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�

�

�

�

�

�

�

�

Enter건을�눌러�파일을�실행해본다.�

그러면�순서가�바뀐것을�알수�있다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

Timeline에서 프레임의 표시 

Timeline에서�프레임들은�적용된�효과에�따라�다르게�표시된다.�

�:�Motion�Tween은�시작키프레임이�검은색�점으로

표시되고�가운데프레임에는�연보라색배경에�검은색화살표가�표시된다.�

�:�Shape�Tween은�시작키프레임이�검은색�점으로

표시되고�가운데프레임에는�연풀색배경에�검은색�화살표가�표시된다.�

�:� 마지막키프레임이�없는것과�같이� Tweening이

제대로�구성되지�않은�경우에는�점선이�나타난다.�

�:�단일키프레임은�검은색�점으로�표시된다.�회색프

레임에는�앞의�프레임과�같은�내용이�포함되여있으며�마지막프레임에는�빈�4각형

이�표시된다.�

�:�Frame�Action을�지정한�프레임에는�소문자�a가

표시된다.�

�:�프레임에�Label이�포함되여있으면�빨간색�기발이

표시된다.�

�:�프레임에�Anchor이름이�붙어있으면�노란색�닻이

표시된다.�프레임에�Anchor이름을�붙이면�전진�또는�후진단추를�리용하여�프레

임사이�혹은�장면사이를�이동할수�있으므로�Movie탐색이�간단해진다.�

�

알아두기 
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2. Motion Tweening 

시작위치와�마지막위치를�지정하여주는�방법으로�동화상을�만드는�방법은�학습하였

다.�이�방법에서는�시작위치와�마지막위치를�이어주는�직선경로를�따라서�모형이�이동

하게�된다.�모형의�이동경로를�조종하려면�Motion�Guide를�리용해야�한다.�

Motion�Guide에�의한�동화상제작을�실례를�들어보기로�하자.�

①�Flash를�기동하여�새�작업파일을�연다.�

②�문자도구를�리용하여�Stage에�Flash라고�쓰고�Graphic�Symbol로�변환한다.�

�

�

�

�

�

�

�

�

�

�

�

③�Insert→Motion�Guide지령을�실행하면�그림과�같이�Timeline의�Layer에�Guide

Layer가�추가된다.�

�

�

�

�

�

�

�

�

�

�

탐 구 

서로�다른�층에�있는�모형들이�같은�Guide�Line 을�사용할수�있는가를�알

아보아라.�
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④�Stage에�경로로�쓰일�곡선을�하나�그린다.�

�

�

�

�

�

�

�

�

�

�

�

⑤� Layer� 1의� 10번프레임을�선택하고�오른쪽찰칵하여�나타나는�지름차림표에서�

Insert�Keyframe지령을�실행한다.�

⑥�Guide�Layer의�10번프레임을�선택하고�오른쪽찰칵하여�나타나는�지름차림표에

서�Insert�Frame지령을�실행하면�다음과�같이�된다.�

�

�

�

�

�

�

�

�

�

⑦�Layer�1의�1번프레임을�선택한다.�

⑧�Flash를�곡선의�끝으로�끌기한다.�

중심점이�일치되면�동그라미가�표시되는데�이때�마우스단추를�놓는다.�

�

�

�

�

�

�

�

�

�

�

움직임을�조종하는�
경로로�쓰일�곡선�
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⑨�Layer�1의�10번프레임을�선택하고�Flash를�반대쪽�끝에�이동시킨다.�

�

�

�

�

�

�

�

�

�

�

�

⑩�Properties의�Color에서�Alpha를�선택한다.�

�

�

�

�

�

�

�

⑪�Alpha값을�0으로�한다.�

�

�

�

⑫� 1번부터� 10번사이의� 임의의� 프레임을� 선택하고� Properties의� Tween에서�

Motion을�선택한다.�

Enter건을�눌러�실행시켜보면�Flash가�Motion�Guide를�따라�움직이면서�점차�연

해지며�없어지는것을�알수�있다.�

�

�

�

�

�

�

�

�

�

�
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⑬�1번부터�10번사이의�임의의�프레임을�선택하고�Properties의�Ease를�100으로,�

Orient�to�path를�선택한다.�

�

�

�

�

�

�

�

그러면�글자가�곡선의�방향에�맞추어�회전하고�또�마지막으로�가면서�이동속도가�

점차�떠지는것을�알수�있다.�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

Ctrl+Enter건을�눌러�Movie를�실행해보면�Guide�Line이�보이지�않는다.�

이처럼�Motion�Guide를�리용하면�움직임경로와�방향을�조절할수�있다.�

3. Shape Tweening 

Shape�Tweening에�의하여�Drawing모형의�모양이�변하는�동화상을�만드는�방법

을�학습하였다.�이�방법에서는�시작모양과�마지막모양에�기초하여�나머지부분은�콤퓨터

가�자체로�계산하여�모양을�변형시킨다.��

모형의�모양변화를�조종하려면�Shape�Hint를�리용하면�된다.�

실례를�들어보기로�하자.�

①�문자도구를�리용하여�Stage에�1이라고�입력한다.�

②�선택도구를�선택하고�Ctrl+Alt건을�누르고�끌기하여�하나�더�만든다.�
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③�문자들을�선택하고�Ctrl+B건을�눌러�도형으로�변환한다.�

④�30번프레임에�빈�키프레임을�추가한다.�

⑤�문자도구를�리용하여�Stage에�2라고�입력하고�하나�더�복사한다.�

�

�

�

�

�

�

�

�

�

⑥�문자들을�도형으로�변환한다.�

⑦�1번부터�29번사이의�프레임을�선택하고�Properties의�Tween에서�Shape를�선택한다.�

⑧�Enter건을�눌러�Movie를�재생해본다.�

⑨�1번프레임을�선택한다.�

⑩�Modify→Shape→Add�Shape�Hint지령을�실행한다.�

�

�

�

�

�

�

�

�

�

�

�
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그러면�Stage에�원안에�a라고�씌여진�모형이�생긴것을�볼수�있다.�

�

�

⑪�Shape�Hint를�하나�더�추가한다.�이번에는�b라고�씌여져있다.�

⑫�a,�b를�수자�1의�우아래에�다음�그림과�같이�이동시킨다.�

�

�

⑬�30번프레임을�선택한다.�

⑭�a,�b를�다음�그림과�같이�이동시킨다.�

�

�
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⑮�Enter건을�눌러�Movie를�재생해본다.�

�
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�

�

Shape�Hint를�리용한것이�자기�모양을�비교적�유지하면서�바뀌는것을�알수�있다.�

Shape�Hint는�최대�26개까지�사용할수�있다.�

4. Mask Layer 

�

�

�

�

�

�

�

�

�

�

Mask를�리용한�Animation만들기를�실례를�들어보기로�하자.�

①�Properties에서�Background를�찰칵하여�Movie의�배경색을�검은색으로�설정

한다.�

�

�

�

②�도구칸에서�문자도구를�선택하고�《배우고�배우고�또�배우자》라고�입력한다.�

�

Mask에 대하여 

�

Mask란�간단히�구멍이�뚫린�검은색종이라고�생각하면�된다.�그러므로�Mask

를�리용하면�구멍이�뚫린�부분만�보이게�된다.�

알아두기 
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③�Transform�Panel에서�Copy�and�apply�transform을�찰칵하여�그�자리에�복

사한다.�

④�문자의�색을�약간�어두운�회색으로�바꾸어준다.�

⑤�문자를�약간�이동시켜�립체감이�나게�한다.�

�

�

�

�

�

�

�

⑥�Timeline에서�Insert�Layer를�찰칵하여�Layer를�추가한다.�

⑦�Layer�2의�1번프레임을�선택한다.�

⑧�원형도구를�리용하여�Stage에�원을�그린다.�

�

�

�

�

�

�

�

�

�
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�

�

⑨�방금�그린�원을�선택하고�F8건을�눌러�Convert�to�Symbol대화칸을�연다.�

⑩�mask라는�Graphic�Symbol로�보관한다.�
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⑪�Layer�2의�20,�40번프레임에�키프레임을�추가한다.�

⑫� Layer� 1의� 40번프레임을�선택하고�오른쪽찰칵하여�나타나는�지름차림표에서

Insert�Frame지령을�실행하여�40프레임까지�늘인다.�

�

�

�

⑬�1번프레임에�있는�mask�Graphic�Symbol을�선택하고�왼쪽으로�이동시킨다.�

�
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�

⑭�20번프레임에�있는�mask�Graphic�Symbol을�선택하여�오른쪽으로�이동시킨다.�

�
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�

⑮�40번프레임에서는�1번프레임에서와�같은�위치에�놓이게�한다.�

⑯�1번부터�39번까지�프레임을�선택하고�오른쪽찰칵하여�나타나는�지름차림표에서�

Create�Motion�Tween을�실행한다.�
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⑰�Timeline에서�Layer� 2를�선택하고�오른쪽찰칵하여�나타나는�지름차림표에서

Mask지령을�실행한다.�

Movie를�실행해보면�Layer�2의�원형부분에서만�글자가�보이는것을�알수�있다.�

�

�

�

�

�

�

�

�

�

�

�

련습문제 

1.�높은데서�떨어져서�튀는�공의�움직임을�만들어보아라.�

2.�모형의�색이�변하는�동화상을�만들어보아라.�

3. 도형이�글자로�변하는�동화상을�만들어보아라.�
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�
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콤퓨터(제 1 중학교 제 2 학년용) 
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